Width of notifications seem arbitrarily small

Reported by Luc-Ace on 2009-03-01
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Mirco Müller
notify-osd (Ubuntu)
Low
Mirco Müller

Bug Description

The fixed width of notifications seems too small as common notification messages get chopped. See attached. I can see limiting the number of characters but it seems the current limit is too small as almost everything gets reduced. In theory it could cause confusion as some notification would look the same.

Related branches

Luc-Ace (luc-ace) wrote :

Either one of the following things should be done:

- limit the title to fit in the notification

- make sure notifications have variable widths. But then notifications shown at the same moment should all have the same width. And when they all disappeared, the normal width should be used again. The problem is that when a smaller notification is on screen and a bigger notification (read wider) the previous notification should also change to a bigger size.

Changed in notify-osd:
status: New → Confirmed
Mirco Müller (macslow) wrote :

Have a look at http://people.ubuntu.com/~mmueller/notify-osd-wrapping.png this is currently upstream notify-osd. I am right now in the process of building a new package for it.

Changed in notify-osd:
assignee: nobody → macslow
importance: Undecided → Low
Mat Tomaszewski (mat.t.) wrote :

Luc-Ace: Thanks for reporting this. Observation - you seem to be using some old version of notify-osd - the recent one would not truncate the title like that (vide MacSlow's comment).

In general, the width is indeed too small. The initial tests were conducted on the netbook screen (1024x600), and the plan was to first see how small we can make it in this extreme environment, and enlarge if necessary, rather than the other way round.

The problem also originates from the default desktop font itself - Vera Sans does not utilize space very well (esp. horizontally). Since we can't change the default font now, enlarging the width of the bubble seems like the most reasonable option.

Changed in hundredpapercuts:
assignee: nobody → Mirco Müller (macslow)
importance: Undecided → Medium
status: New → Confirmed
Luc-Ace (luc-ace) wrote :

Mat: I should have done a better job documenting the exact version but it was early 9.04 days. I can't remember if it was beta, RC or release. A quick retest shows that it is either been fixed or I can't reproduce it anymore. I am leaning towards, it has been changed since it now displays something else besides "Connection Established"

Changed in hundredpapercuts:
status: Confirmed → Triaged
Changed in hundredpapercuts:
milestone: none → round-1
Changed in hundredpapercuts:
assignee: Mirco Müller (macslow) → Mat Tomaszewski (mat.t.)
Mat Tomaszewski (mat.t.) wrote :

The design decision is to increase the bubble width to 20 ems (from the current 18). It will soon be reflected on the project wiki page.

Changed in hundredpapercuts:
status: Triaged → Fix Committed
Matthew Paul Thomas (mpt) wrote :

The current bubble width is 18 ems. Mat and I have just experimented with mockups of bubbles of different widths, and at any width beyond 20 ems the bubbles started looking weird, especially those for volume/brightness. So, I've updated the spec to say that bubbles should be 20 ems wide. <https://wiki.ubuntu.com/NotifyOSD?action=diff&rev2=155&rev1=154>

Changed in hundredpapercuts:
assignee: Mat Tomaszewski (mat.t.) → Matthew Paul Thomas (mpt)
status: Fix Committed → Triaged

Is it possible to have screenshots of 18/19/20 ems please ?

Changed in hundredpapercuts:
assignee: Matthew Paul Thomas (mpt) → nobody
Changed in hundredpapercuts:
assignee: nobody → Mirco Müller (macslow)
status: Triaged → Fix Committed
Mat Tomaszewski (mat.t.) wrote :

Correction:
the current bubble width is 23 ems. The spec stated 18 ems, which was a value proposed initially, based on the original design which assumed a 12pt default font size for the title (120% of the default application font size). That value was then changed to 100% (10pt on the default installation) for the title and 80% for the body text. Hence the default em size is actually around 13.8 px for the 100dpi screen and default font settings, not 16 as it was assumed in the spec.

That's all quite confusing, I know. The bottom line is:
- the current width of the bubble is 23 ems
- the recommended new width is 28 ems
- the spec should be updated to reflect that.

Mirco, any chance you could include a screenshot of the bubble with 28 ems?

Mirco Müller (macslow) wrote :
Changed in notify-osd:
status: Confirmed → Fix Committed
Mirco Müller (macslow) wrote :
Mirco Müller (macslow) wrote :
Mirco Müller (macslow) wrote :
Mirco Müller (macslow) wrote :
Mirco Müller (macslow) wrote :
Mirco Müller (macslow) wrote :
Mat Tomaszewski (mat.t.) wrote :

OK, after reviewing these we're setting for 24 ems.

Ara Pulido (apulido) wrote :

Opened an Ubuntu task to track the release into Ubuntu

Changed in notify-osd (Ubuntu):
importance: Undecided → Low
status: New → Fix Committed
Mirco Müller (macslow) on 2009-06-29
Changed in notify-osd (Ubuntu):
assignee: nobody → Mirco Müller (macslow)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package notify-osd - 0.9.15-0ubuntu1

---------------
notify-osd (0.9.15-0ubuntu1) karmic; urgency=low

  * New upstream version:
    - fixed wrong default values for bubble-width, margin- and icon-size
    - fixed regressions introduced by the move to the surface- and blur-cache
    - improved drawing of gauge/indicator
    - tweaked rendering of layout-grid, added display of layout-grid to
      debug-mode of notify-osd
    - refactored rendering code for bubble
    - migrated rendering of drop-shadow, background, icon, title,
      body and gauge to surface/blur-cache
    - added surface- and blur-cache
    - added debug-output for font-size, screen-dpi, pixels/EM and
      bubble-width in pixels
    - fixed rounding errors in pixel-per-em calculation, changed default bubble
      width to 24 EMs, fixed title- and body-text height,
      fixes LP: #336110 and LP: #391190

 -- Sebastien Bacher <email address hidden> Tue, 21 Jul 2009 10:46:15 +0200

Changed in notify-osd (Ubuntu):
status: Fix Committed → Fix Released
Vish (vish) on 2009-08-10
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Neil J. Patel (njpatel) on 2009-08-17
Changed in notify-osd:
status: Fix Committed → Fix Released
no longer affects: notify-osd
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers