package xserver-xorg-core 2:1.18.3-1ubuntu2 failed to install/upgrade: trying to overwrite '/usr/lib/xorg/modules/libglamoregl.so', which is also in package xserver-xorg-video-glamoregl 0.6.0-0ubuntu4

Bug #1574320 reported by rajesh on 2016-04-24
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
xorg-server (Ubuntu)
Xenial
Low
Timo Aaltonen

Bug Description

package xserver-xorg-core 2:1.18.3-1ubuntu2 failed to install/upgrade: trying to overwrite '/usr/lib/xorg/modules/libglamoregl.so', which is also in package xserver-xorg-video-glamoregl 0.6.0-0ubuntu4. The error occurred after upgrading to 16.04.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: xserver-xorg-core 2:1.18.3-1ubuntu2
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
.tmp.unity_support_test.0:

ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
BootLog:
 Scanning for Btrfs filesystems
 /dev/sda8: clean, 442377/1160992 files, 3820414/4638183 blocks
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Sun Apr 24 15:32:02 2016
DistUpgraded: 2016-04-22 21:43:04,293 DEBUG disabling apt cron job (0o755)
DistroCodename: xenial
DistroVariant: ubuntu
DkmsStatus:
 nvidia-304, 304.131, 3.13.0-85-generic, x86_64: installed
 nvidia-304, 304.131, 4.4.0-21-generic, x86_64: installed
ErrorMessage: trying to overwrite '/usr/lib/xorg/modules/libglamoregl.so', which is also in package xserver-xorg-video-glamoregl 0.6.0-0ubuntu4
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation 82Q33 Express Integrated Graphics Controller [8086:29d2] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Micro-Star International Co., Ltd. [MSI] 82Q33 Express Integrated Graphics Controller [1462:7352]
InstallationDate: Installed on 2014-05-14 (711 days ago)
InstallationMedia: Custom 14.04 - Release amd64
MachineType: Hewlett-Packard HP Compaq dx7400 Small Form Factor.
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic root=UUID=d34389e0-e11f-4e62-8ca9-331d24db62ce ro quiet splash vt.handoff=7
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1
 apt 1.2.10ubuntu1
SourcePackage: xorg-server
Title: package xserver-xorg-core 2:1.18.3-1ubuntu2 failed to install/upgrade: trying to overwrite '/usr/lib/xorg/modules/libglamoregl.so', which is also in package xserver-xorg-video-glamoregl 0.6.0-0ubuntu4
UpgradeStatus: Upgraded to xenial on 2016-04-22 (1 days ago)
dmi.bios.date: 09/03/2008
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: MS7352 1.14
dmi.board.name: 0AB8
dmi.board.vendor: MSI
dmi.chassis.asset.tag: INA90904TR
dmi.chassis.type: 3
dmi.chassis.vendor: MSI
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrMS73521.14:bd09/03/2008:svnHewlett-Packard:pnHPCompaqdx7400SmallFormFactor.:pvr:rvnMSI:rn0AB8:rvr:cvnMSI:ct3:cvr:
dmi.product.name: HP Compaq dx7400 Small Form Factor.
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.12.2+16.04.20160415-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Sun Apr 24 19:36:43 2016
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input USB OPTICAL MOUSE MOUSE, id 8
 input USB2.0 PC CAMERA KEYBOARD, id 9
 input AT Translated Set 2 keyboard KEYBOARD, id 10
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 9963
 vendor HWP
xserver.version: 2:1.18.3-1ubuntu2

rajesh (bhatt-rajesh20) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Changed in xorg-server (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → High
Timo Aaltonen (tjaalton) wrote :

looks like the conflicts/replaces got dropped in a merge

Changed in xorg-server (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
Timo Aaltonen (tjaalton) wrote :

not an issue for yakkety and up

Changed in xorg-server (Ubuntu Xenial):
assignee: nobody → Timo Aaltonen (tjaalton)
status: New → In Progress
Changed in xorg-server (Ubuntu):
assignee: Timo Aaltonen (tjaalton) → nobody
status: Confirmed → Invalid

Hello rajesh, or anyone else affected,

Accepted xorg-server into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xorg-server/2:1.18.3-1ubuntu2.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xorg-server (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in xorg-server (Ubuntu Xenial):
importance: Undecided → High
no longer affects: xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu Xenial):
importance: High → Low
tags: added: packaging
Timo Aaltonen (tjaalton) wrote :

I wasn't able to reproduce the upgrade issue on a chroot, because x-x-v-glamoregl got removed during the upgrade process before installing xserver-xorg-core as the video ABI's conflicted as expected. That said, having the conflicts/replaces in the package is the right thing to do so marking verified.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for xorg-server has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.18.3-1ubuntu2.3

---------------
xorg-server (2:1.18.3-1ubuntu2.3) xenial; urgency=medium

  [ Timo Aaltonen ]
  * control: Add Conflicts/Replaces on xserver-xorg-video-glamoregl.
    (LP: #1574320)

  [ Łukasz 'sil2100' Zemczak ]
  * debian/control, debian/rules:
    - Build xmir for arm64 (LP: #1604851).

 -- Timo Aaltonen <email address hidden> Thu, 21 Jul 2016 08:27:07 +0300

Changed in xorg-server (Ubuntu Xenial):
status: Fix Committed → Fix Released
Paul White (paulw2u) wrote :

Closing as issue fixed some time ago

Changed in hundredpapercuts:
status: Confirmed → Fix Released
To post a comment you must log in.