Print options shouldn't be saved across different sessions

Reported by Matteo Settenvini on 2007-10-18
40
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evince
Expired
Low
Eye of GNOME
Fix Released
Low
One Hundred Papercuts
Low
Unassigned
eog (Ubuntu)
Low
Unassigned
evince (Ubuntu)
Low
Ubuntu Desktop Bugs
gtk+2.0 (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Every time I use an application which makes use of the GtkPrint dialog, and I change the settings listed there, my choiches are remembered and reused for the next time I want to print.

This leds to some confusion in my opinion. For example, it happened to me to print a PDF in evince on a day, selecting it with two pages per sheet, and asking myself the next day (the following time I did printing in evince) why all my curriculum vitae where split in two.
Or, more frequently, print 10 copies of a leaflet, and then forget to check it for the next print which is a Shakespeare's complete novel, going to buy me a coffee, and return after half an hour with three or four spare copies of Macbeth. Not to count the problems the famigerate page selection options, expecially when you've to handle over your work to your colleagues during a meeting, and you discover too late you've got a lot of odd pages of your presentation, but no even-numbered one!

In short, it would be a sensible behaviour if evince or GtkPrint (I think the culprit is the second one, but feel free to correct me if I'm mistaken) would save my choiches across _any printing operation for the same document_ (until the document changes, or the application is closed) instead of _any printing operation for any document_.

If needed, a "Save as default options" button could be added to the printing dialog.

Cheers,
m.

TerryG (tgalati4) wrote :

Thanks for your bug submission and suggestions. I agree print settings are not as cleanly integrated across all applications that need to print.

Marking as Confirmed to preserve reporter's comments.

Changed in evince:
status: New → Confirmed
TerryG (tgalati4) wrote :

Marking as Confirmed as stated.

Changed in gtk+2.0:
status: New → Confirmed
Zeno Gantner (zeno-gantner) wrote :

I have the same problems.

Maybe it would make sense to memorize the printing options of a certain document (say, a specific PDF file in evince), but the printing options should not be saved for the next session/application.

Best regards,
  Zeno

Andrew Senior (a-senior) wrote :

I can confirm the same problem in evince 2.20.1 on Ubuntu 7.10 (I have not checked other applications). For me, the problem manifested itself as an inability to print a single-page EPS file. After some time, I discovered that this was because the print dialog was still set (from a previous document) to print the range of pages from 2-10! Clearly this makes no sense for a single-page document and this suggests that the application (evince) does not check that the settings in the print dialog are rational before presenting them to the user. Hence, this particular issue may be one for evince rather than gtk in general.

Regards,

Andrew.

Noam Yorav-Raphael (noamraph) wrote :

I right now encountered this bug again, and I add my request to fix this bug. What happened to Andrew happened also to me: On a previous session I printed first the odd pages and then the even pages. Some time later, I tried to print a one-page document and it took me some while and frustration to realize that it didn't print because the "even pages" option was selected on a different tab and the document had no even pages.

Why not fix this bug? How hard should it be *not* to save options?

The solution is so simple: Options should be saved for a specific evince process, but not saved between them. If someone wants to change a default, he can go to print settings and change it there.

Changed in evince:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Changed in gtk+2.0:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

> Why not fix this bug? How hard should it be *not* to save options?

because there is thousand of bugs and only a very small number of people contributing, you are welcome to work on the issue and send a patch though

Changed in gtk+2.0:
milestone: none → ubuntu-8.10-beta
Noam Yorav-Raphael (noamraph) wrote :

Thanks to Sebastien's instructions on how to get the source and play with it, I managed to fix the bug.
It required only 25 additional characters in the source!

It turns out that the code to load and save the print settings to a file is surrounded by "#if" directives, which check for a large enough version of GTK (in version 2.11.0, a feature to save and load the print settings was added to GTK). I changed "#if GTK_CHECK_VERSION (2, 11, 0)" into "#if 0 && GTK_CHECK_VERSION (2, 11, 0)" in five places, and it works perfectly now.

I guess that at the end the code should be removed altogether, but currently it works very nicely.

I attached the diff.

Have a good day,
Noam

Sebastien Bacher (seb128) wrote :

the issue is an upstream one, could somebody open the bug on bugzilla.gnome.org?

Changed in gtk+2.0:
status: Confirmed → Triaged
milestone: ubuntu-8.10-beta → none
Changed in evince:
status: Unknown → Confirmed
Noam Yorav-Raphael (noamraph) wrote :

By the way, perhaps gtk+-2.0 should be removed from the "affects" list? This is not a bug with the toolkit - other gtk+ applications behave as you would expect, it's just a mis-feature added to evince.

Sebastien Bacher (seb128) wrote :

closing the gtk task since that's not a gtk bug

Changed in gtk+2.0:
status: Triaged → Invalid
Changed in evince:
status: Confirmed → Triaged
Changed in evince:
status: Confirmed → Fix Released
Noam Yorav-Raphael (noamraph) wrote :

552426 is the bug which says exactly that print settings should be forgotten. 349102 is a mix of people asking that evince will remember their page size and people asking that it use the default settings.

Changed in evince:
status: Fix Released → Unknown
Changed in evince:
status: Unknown → New
Sebastien Bacher (seb128) wrote :

don't open extra tasks without explanation, if an another application has the same bug better to open a new one

Changed in eog (Ubuntu):
importance: Undecided → Low
status: New → Invalid
Matteo Settenvini (tchernobog) wrote :

Sorry, I had to add a note; anyway eog is affected by this bug too.
Do you want me to copy the very description of this bug and to create a new one with the same text?
Isn't that just a duplicate?

Sebastien Bacher (seb128) wrote :

let's use the same bug that's an upstream issue anyway and should be sent to bugzilla.gnome.org

Changed in eog (Ubuntu):
assignee: nobody → desktop-bugs
status: Invalid → Triaged
Alexis de Lattre (alexis-via) wrote :

This bug is unfortunately still present in Ubuntu Karmic.

Changed in evince:
status: New → Invalid
Haggai Eran (haggai-eran) wrote :

This bug still exists in Lucid. Just got me printing 30 pages instead of 3...

Vish (vish) wrote :

Not sure what the bug is about right now , Upstream has closed the bug as incomplete and saying most of the issues are now fixed.
Quoting:

"We already reverted the inital behaviour so that now we save only some of the
settings and per document instead of globally. What's wrong with that?"

What are the issues that are still present? , Could someone comment upstream so that the bug can be re-opened?

Changed in hundredpapercuts:
status: New → Incomplete
Changed in evince (Ubuntu):
status: Triaged → Incomplete
tags: added: patch-rejected-upstream
Haggai Eran (haggai-eran) wrote :

I'm sorry I wasn't clear. The problem I encountered was in eog:
The number of copies setting is stored globally, so that if you print multiple copies of some document, the next time you print another document you will also get multiple copies. This seemed like a paper cut to me :)

As far as I can see, the upstream bug is related to evince, so perhaps it was only solved there.

Vish (vish) wrote :

@Haggai Eran : It needs reporting upstream. Ideally a separate bug would have been better , but looks like there are others subscribed here as well for the EOG problem.

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream.
Once submitted upstream , do report back here with the upstream bug number.
Thanks in advance!

Changed in eog (Ubuntu):
status: Triaged → Confirmed
Changed in eog:
status: Unknown → New
Sebastien Bacher (seb128) wrote :

thank you for sending the bug to GNOME

Changed in eog (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Confirmed → Triaged
Changed in evince:
importance: Unknown → Low
status: Invalid → Expired
Changed in eog:
importance: Unknown → Low
Chris Wilson (notgary) wrote :

There shouldn't be more than one application task opened against a single bug report. If Evince and EoG are both experiencing the same problem, then separate bug reports should be opened so that the separate developers can fix the bugs in their own applications and a line can be drawn under the report without having to wait for the others app devs to catch up.

I'm unable to replicate the behaviour described in the description in Evince, so I am going to close that task. The upstream task for Evince is expired anyway.

Changed in evince (Ubuntu):
status: Incomplete → Invalid
Chris Wilson (notgary) wrote :

I am however able to reproduce it in EoG, so I am going to confirm this as a paper cut.

Changed in hundredpapercuts:
status: Incomplete → Confirmed
importance: Undecided → Low
Matthew Caron (matt-mattcaron) wrote :

Chris,

What version of evince are you using? I'm on 2.30.3 (current as of Ubuntu 10.04) and I can reproduce it as follows:

1. Open a pdf
2. Hit print
3. Select 5 copies
4. Let it print (I print to a virtual PDF printer)
5. Hit print again - still says 5 copies.
6. Close and reopen the application PDF, hit print - still says 5 copies.

The same settings are cached for duplex, etc., depending on printer.

It seems to follow the document, not the program.

Chris Wilson (notgary) wrote :

Ah, I was going from one document to another. Yeah, I get the same behaviour as you for. I'm on 2.32 in case it matters.

As per comment #23, a new report should be filed against Evince, rather than reopening the task on this one.

Chris Wilson (notgary) wrote :

Also, whoever creates the report for Evince, this would make a good paper cut.

Changed in eog:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.