kf5-config reports wrong paths for qtplugins

Bug #1517403 reported by sanette on 2015-11-18
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
kdelibs4support (Ubuntu)
High
Unassigned

Bug Description

On Kubuntu 15.10

The paths given by kf5-config --path qtplugins
have a wrong trailing "/plugins", see

~$ kf5-config --path qtplugins
/usr/lib/x86_64-linux-gnu/plugins/:/usr/lib/x86_64-linux-gnu/qt5/plugins/plugins/

these paths don't exist, only these do:

/usr/lib/x86_64-linux-gnu/
/usr/lib/x86_64-linux-gnu/qt5/plugins/

In a discussion on https://forum.kde.org/viewtopic.php?f=225&t=129082&p=345873#p345873
we suspect this might be the cause of some serious bugs in the theming system; KDE ends up picking
GTK theme instead of its own theme. All icons get wrong, some disappear, etc.

This might even be related to Bug #1451564 (Single-click not working)

Philip Muškovac (yofel) on 2015-11-18
affects: kde-baseapps (Ubuntu) → kdelibs4support (Ubuntu)
tags: added: wily

Confirmed wt:

~$ plasmashell -v
plasmashell 5.4.3

~$ kf5-config -v
Qt: 5.4.2
KDE Frameworks: 5.15.0
kf5-config: 1.0

Changed in kdelibs4support (Ubuntu):
status: New → Confirmed
tags: added: bytesize
tags: added: bitesize
removed: bytesize
Changed in kdelibs4support (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
importance: Undecided → High
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers