libcppnetlib0 is compiled with the wrong compiler and/or ABI (should be gcc5)

Bug #1512695 reported by beniz on 2015-11-03
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
cpp-netlib (Ubuntu)
Medium
Unassigned

Bug Description

I've recompiled https://launchpad.net/ubuntu/+archive/primary/+files/cpp-netlib_0.11.1%2Bdfsg1.orig.tar.gz from https://launchpad.net/ubuntu/+source/cpp-netlib/0.11.1+dfsg1-4 with the default gcc-5.2.1 compiler on Ubuntu 15.10 and the problem goes away.

Ping me if you need testing for a newly compiled package.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: libcppnetlib0 (not installed)
ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
Uname: Linux 4.2.0-16-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.19.1-0ubuntu4
Architecture: amd64
Date: Tue Nov 3 14:05:33 2015
InstallationDate: Installed on 2014-11-04 (364 days ago)
InstallationMedia: Ubuntu-Server 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.3)
SourcePackage: cpp-netlib
UpgradeStatus: Upgraded to wily on 2015-11-02 (0 days ago)

beniz (juban) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cpp-netlib (Ubuntu):
status: New → Confirmed
apetrelli (antonio-petrelli) wrote :

I have a C++ Eclipse project that depends on this package and, after upgrade to wily, it does not compile anymore.

By using:
-D_GLIBCXX_USE_CXX11_ABI=0
the problem goes away, however I suppose it is not a good thing to do.

The error is:

/usr/include/boost/network/uri/uri.hpp:178: riferimento non definito a "boost::network::uri::detail::parse(__gnu_cxx::__normal_iterator<char const*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > >, __gnu_cxx::__normal_iterator<char const*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > >, boost::network::uri::detail::uri_parts<__gnu_cxx::__normal_iterator<char const*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > > >&)"

Note the subnamespace for basic_string.

Changed in cpp-netlib (Ubuntu):
importance: Undecided → Medium
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Medium

Any news? I have the same issue. I tried to locally rebuild the package but the process hangs on the 14th test:

[...]
      Start 13: cpp-netlib-http-client_get_timeout_test
13/17 Test #13: cpp-netlib-http-client_get_timeout_test ............. Passed 8.70 sec
      Start 14: cpp-netlib-http-server_constructor_test
[^C after ten minutes...]

beniz (juban) wrote :

Hey Sebastien, yes this issue is very annoying. In order to get cppnetlib to compile on 15.10 and work around the problem see this: https://github.com/beniz/deepdetect/issues/29
These are the steps we use to build our software on 15.10, and also the reason why we do not support 15.10 yet.
Not sure about the tests though, but the lib is working fine for us overall.

Note that the exact same problem occurs with curlpp. I cannot understand how such issues can even happen when building a new system, and I cannot really understand either why months are required in order to juste rebuild and push the new package.

Hi Beniz! Of course, trying to build this library using the official sources was my first idea. As it worked fine, I naively believed that the clean solution was to locally rebuild the Debian package. Obviously, it is not so straightforward. :( I do not know why the 14th test hangs and I have not the time to investigate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers