FGLRX package cant be installed and run correctly on 15.10 UPGRADE

Bug #1509917 reported by Mikael Thurberg on 2015-10-26
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Critical
Unassigned
fglrx-installer (Ubuntu)
Critical
Unassigned
Nominated for Wily by Alberto Salvia Novella

Bug Description

Hi there!

I cant get my graphics to work properly.. I have an AMD radeon HD 6450 card, I changed the display drivers via

system settings -> programs & updates -> additional drivers

to fglrx there (switching from the default xserver-xorg-video-ati), that worked.

But when I did upgrade the distribution from 15.04 to 15.10, it just "hanged" when loading ubuntu.. it never got into xserver.. managed to get around that by connectin an old monitor via vga to my mobo directly, then it worked somehow by displaying the picture on my main screen via hdmi via amd hd 6450..

Have tried to install fglrx back and forth trying to get it to work, but it does not seem to work..

I did get this message when filing the bug:

"Your system is providing 3D via software rendering rather than hardware rendering. This is a compatibility mode which should display 3D graphics properly but the performance may be very poor. If the problem you're reporting is related to graphics performance, your real question may be why X didn't use hardware acceleration for your system."

What is even more disturbing is that I cant switch back to xserver-xorg-video-ati eighter and run that driver via the "additional drivers" settings dialogue.

Dont know if I should file that into a separate bug but thought it maybe helps reporting that.

Dont know how to get fglrx to work actually.. also the screen is reporting just a single resolution that is very low that I also even cant change..

Thanks for reading.
Have a nice day!

/Micke

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: fglrx 2:15.201-0ubuntu1
ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
Uname: Linux 4.2.0-16-generic x86_64
NonfreeKernelModules: fglrx
.tmp.unity.support.test.1:

ApportVersion: 2.19.1-0ubuntu3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Mon Oct 26 04:13:45 2015
DistUpgraded: Fresh install
DistroCodename: wily
DistroVariant: ubuntu
DkmsStatus: fglrx-core, 15.201, 4.2.0-16-generic, x86_64: installed
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM] [1002:6779] (prog-if 00 [VGA controller])
   Subsystem: XFX Pine Group Inc. Radeon HD 7450 [1682:3200]
InstallationDate: Installed on 2015-05-26 (153 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
MachineType: Hewlett-Packard HP Compaq dc7600 Small Form Factor
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-16-generic root=UUID=3c54a719-bd1c-4b70-8ef6-8e17fd06e3c4 ro text
Renderer: Software
SourcePackage: fglrx-installer
UdevLog: Error: [Errno 2] Filen eller katalogen finns inte: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/01/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 786D1 v01.61
dmi.board.name: 09F8h
dmi.board.vendor: Hewlett-Packard
dmi.chassis.type: 4
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr786D1v01.61:bd07/01/2009:svnHewlett-Packard:pnHPCompaqdc7600SmallFormFactor:pvr:rvnHewlett-Packard:rn09F8h:rvr:cvnHewlett-Packard:ct4:cvr:
dmi.product.name: HP Compaq dc7600 Small Form Factor
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.12.2+15.10.20151015-0ubuntu1
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.64-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.0.2-1ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.0.2-1ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.17.2-1ubuntu9
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.5.0+git20150819-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20150808-0ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu3
xserver.bootTime: Mon Oct 26 04:56:42 2015
xserver.configfile: default
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.17.2-1ubuntu9

Mikael Thurberg (mthurberg) wrote :
Hemal (rathod-hemal) wrote :

Go to link https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/1493888/comments/48

Download .deb files and install. Now #FGLRX is working on AMD with 4.2 kernel on #Ubuntu15.10 #Ubuntu

Mikael Thurberg (mthurberg) wrote :

Thanks (a lot!) Hemal !!

If it works you definitively made my day! :D

Shall I install all of them or choose a specific one, in that case which one?

Once again, Thanks Hemal!

Ouioui (ouioui2003) wrote :

Perfect Hemal !
Your packages have corrected my trouble with ubuntu 15.10 upgrade.

Many thanks !!!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
Ouioui (ouioui2003) wrote :

I need to thanks Sergey Kislyakov (defman21) for packages.

Mikael Thurberg (mthurberg) wrote :

@ouioui

You need to disable automatic updates for the FGLRX package apperently.. otherwise i think you maybe will get the same problem as I did, that is it will install faulty drivers over these via the automatic updates..

See this link for more info:

https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/1493888

Changed in fglrx-installer (Ubuntu):
importance: Undecided → Critical
Changed in fglrx-installer (Ubuntu):
status: Confirmed → Triaged
joseroberto (robertobrj) on 2016-03-07
Changed in fglrx-installer (Ubuntu):
assignee: nobody → joseroberto (robertobrj)
status: Triaged → Confirmed

Just disable FGLRX in that dialogue.

Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Critical

FGLRX is slow in Ubuntu, it is in process of being deprecated, and provides no real benefit over the open source drivers.

I have been myself gaming with open source drivers for years, and it works like a charm out of the box. Sure there are unsupported features like Crossfire, but that does not pay off the bad quality of FGLRX and a slow desktop.

Changed in fglrx-installer (Ubuntu):
status: Confirmed → Triaged
Changed in hundredpapercuts:
status: Confirmed → Triaged

Only assign yourself to bug reports just before starting working of them.

Changed in fglrx-installer (Ubuntu):
assignee: joseroberto (robertobrj) → nobody
To post a comment you must log in.