xdg-screensaver broken in kubuntu (KDE_SESSION_VERSION is 5, not 4 anymore)

Bug #1468030 reported by Luca Olivetti on 2015-06-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
xdg-utils (Ubuntu)
Medium
Unassigned

Bug Description

In line 420 /usr/bin/xdg-screensaver checks for the value of KDE_SESSION_VERSION.
If it is 4, it uses the dbus methods, otherwise, thinking it is kde 3, it uses dcop.
Unfortunately now KDE_SESSION_VERSION is 5 and xdg-screensaver falls back to dcop (which doesn't exists anymore):

$ xdg-screensaver suspend 0x2600007
/usr/bin/xdg-screensaver: 652: /usr/bin/xdg-screensaver: dcop: not found

Changing it to check for 5 instead of 4 at least it appears to work (barring bug #310351)

Note that the rest of xdg-utils also check KDE_SESSION_VERSION, so they will probably fail too, but I didn't try them.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: xdg-utils 1.1.0~rc1-2ubuntu10 [modified: usr/bin/xdg-screensaver]
ProcVersionSignature: Ubuntu 3.19.0-21.21-generic 3.19.8
Uname: Linux 3.19.0-21-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.17.2-0ubuntu1.1
Architecture: amd64
CurrentDesktop: KDE
Date: Tue Jun 23 19:39:45 2015
PackageArchitecture: all
SourcePackage: xdg-utils
UpgradeStatus: No upgrade log present (probably fresh install)

Luca Olivetti (olivluca) wrote :
Luca Olivetti (olivluca) wrote :

Never mind, even after the fix it doesn't work: I tried xdg-screensaver suspend with the window id of an existing window and it still dims the screen after a while.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xdg-utils (Ubuntu):
status: New → Confirmed
Changed in xdg-utils (Ubuntu):
importance: Undecided → Medium
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

That was fixed with that commit
https://cgit.freedesktop.org/xdg/xdg-utils/commit/?id=aa251a926130fbd3f4bade766ce5d2e0e2cb4c73

which is in the current Ubuntu version

Changed in xdg-utils (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers