wireshark-common 1.12.1+g01b65bf-4 failed to upgrade. It now requires "wireshark" group to be a system group.

Bug #1447893 reported by Ilya Bobyr on 2015-04-24
102
This bug affects 18 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
wireshark (Ubuntu)
High
Unassigned
Nominated for Vivid by Alberto Salvia Novella

Bug Description

Wireshark-common pacakge from Utopic created a "wireshark" group that was not a system group. Id higher than 1000.
Wireshark-common that comes with Vivid requests group creation with "--system" flag.
That fails as the group already exists and is not in the system ID range.

ProblemType: Package
DistroRelease: Ubuntu 15.04
Package: wireshark-common 1.12.1+g01b65bf-4
ProcVersionSignature: Ubuntu 3.19.0-15.15-generic 3.19.3
Uname: Linux 3.19.0-15-generic x86_64
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
Date: Thu Apr 23 12:59:22 2015
DuplicateSignature: package:wireshark-common:1.12.1+g01b65bf-4:subprocess installed post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2013-01-04 (839 days ago)
InstallationMedia: Lubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.1)
RelatedPackageVersions:
 dpkg 1.17.25ubuntu1
 apt 1.0.9.7ubuntu4
SourcePackage: wireshark
Title: package wireshark-common 1.12.1+g01b65bf-4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to vivid on 2015-04-23 (0 days ago)

Ilya Bobyr (ilya-bobyr) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wireshark (Ubuntu):
status: New → Confirmed
william (bugz-u) wrote :

work around is :
sudo groupmod -g 666 wireshark
sudo dpkg -a --configure

the number is anything <1000 that is not in use. I chose 666
affected 2 systems so far for me on do-release-upgrade
AA1 intel atom and an intel i7 based PC

autra (autra) wrote :

I'm affected as well.

Is there any step I need to do to recover from this error and make sure everything is clean in my system ? Is apt-get autoremove / restarting enough ?

Thanks !

Changed in hundredpapercuts:
status: New → Confirmed
Changed in wireshark (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
importance: Undecided → High
Ilya Bobyr (ilya-bobyr) wrote :

> work around is :
> sudo groupmod -g 666 wireshark
> sudo dpkg -a --configure

groupmod will only change the group id in /etc/group, but would not update any existing files.
Not sure if it is a big deal, but here is what I did:

sudo apt-get remove wireshark\*
sudo dpkg -a --configure
sudo apt-get install wireshark

This may still leave some files with the old user and group id, I guess, but the main part will be replaced.

Balint Reczey (rbalint) wrote :

@Ilya sudo dpkg -a --configure will update /usr/bin/dumpcap thus william's solution is fine, too.
I have just uploaded a fixed package to Debian unstable.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wireshark - 1.12.4+gb4861da-1

---------------
wireshark (1.12.4+gb4861da-1) unstable; urgency=medium

  [Arnd Hannemann]
  * Fix German debconf translation (Closes: #779826)

  [Balint Reczey]
  * Fix pkg-config file (Closes: #779788)
  * New upstream release 1.12.4 from git snapshot:
    - release notes:
      https://wireshark.org/docs/relnotes/wireshark-1.12.4.html
  * Drop obsolete patches
  * Bump standards version

 -- Balint Reczey <email address hidden> Thu, 30 Apr 2015 07:42:35 +0200

Changed in wireshark (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.