sddm and lightdm can run at the same time

Bug #1446760 reported by Mikaela Suomalainen on 2015-04-21
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Critical
Unassigned
SDDM
Fix Released
Unknown
sddm (Ubuntu)
Critical
Unassigned
Nominated for Vivid by Alberto Salvia Novella

Bug Description

I originally installed Ubuntu MATE 14.10 which I then updated to 15.04. At some point I decided to try KDE Plasma 5, so I installed the kubuntu-desktop package.

I got the prompt asking me whether I wish to run lightdm or sddm and I chose lightdm. However after reboot I got black screen which loaded plasma cursors and I was unable to do anything without going to TTY.

Running "systemctl status lightdm && systemctl status sddm" told me that they both were running and I solved this with "systemctl disable sddm" and rebooted and got lightdm normally.

I think this might have something to do with Ubuntu 15.04 using systemd by default and sddm not having systemd unit.

PS. I am not fully sure if this is sddm issue, but I feel this is. Feel free to move this to correct place if I am wrong.
PPS. I experienced this week or two ago, but I don't think there have been upgrades to these packages, so I am sorry if this is known issue and already fixed.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: sddm 0.11.0-0ubuntu10
ProcVersionSignature: Ubuntu 3.19.0-14.14-generic 3.19.3
Uname: Linux 3.19.0-14-generic x86_64
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
CurrentDesktop: MATE
Date: Tue Apr 21 19:59:52 2015
InstallationDate: Installed on 2014-12-19 (123 days ago)
InstallationMedia: Ubuntu MATE 14.10 "Utopic Unicorn" - amd64 (20141023)
SourcePackage: sddm
UpgradeStatus: Upgraded to vivid on 2015-04-05 (15 days ago)
upstart.sddm.override: manual

Upstream bug report:
https://github.com/sddm/sddm/issues/620
(SDDM and LightDM can run in paralell (thus create conflict)
created 9.Apr.2016

Mikaela Suomalainen (mikaela) wrote :
apport hater (g112) wrote :

I copied your report and edited in my on-upstart observations:

I got the prompt asking me whether I wish to run lightdm or sddm and I chose lightdm. However after reboot I got a text login on TTY1. (NOTE: Very fast, a fraction of time needed for reaching a login manager on that machine)

Running "service lightdm status && service sddm status" told me that they both were STOPPED.
I could run "service lightdm start" or "service sddm start" to start either one manually, but not automatically.

So it's not just on systemd.

NOTE: Even though I selected "lightdm" during sddm installation,
/etc/X11/default-display-manager was still overwritten to says "/usr/bin/sddm"
I fixed that by working around #1422247 and deinstalling sddm.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sddm (Ubuntu):
status: New → Confirmed
Changed in sddm (Ubuntu):
importance: Undecided → Critical
swestlake (westlake2012) wrote :

also occurs with a clean install of the UbuntuGnome iso installation
If one does apt-get install kubuntu-desktop, there is a dpkg-reconfigure for the display manager (which shows both selections: gdm and sddm)

gdm was chosen but it doesn't disable sddm

Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Critical
Changed in sddm (Ubuntu):
status: Confirmed → Triaged
Changed in hundredpapercuts:
status: Confirmed → Triaged

(Running Xubuntu 15.04 here, with kubuntu-desktop installed)

Actually, there are two issues caused by this. One is the two DM's fighting over which gets control of the login screen, as described above. Two, apparently there's a conflicting mouse service that gets activated by sddm, which causes mouse movements within the XFCE session to become jerky and jittery - like the pointer is trying to be in two places at once.

Uninstalling sddm fixes both issues for me.

Seth Galitzer (sgsax) wrote :

I'm seeing this with my lab deployment. We install ubuntu-desktop, xubuntu-desktop, kubuntu-desktop, plasma-desktop, and gnome-shell, so users can select whatever desktop they want. What seems to be happening is that configure of gdm, lightdm, or sddm don't actually disable sddm if another dm is selected. Neither kubuntu-desktop nor plasma-desktop seem to depend on sddm, so removal is easy to do.

I have also discovered that removing the sddm package isn't necessary. I have been able to successfully disable the sddm service to prevent it from starting on boot, and that also allows lightdm to run just fine.

# systemctl disable sddm.service

I've added this to my management tool to make sure it stays disabled even after updates, rather than remove the package in case the dependencies change in the future.

I reproduced this bug in a dailybuild of kubuntu 15.10 (2015-10-02) and marked the bug report as duplication if this one for additional information.

tags: added: wily

Can also confirm that the bug is still present in Wily.

Sneetsher (sneetsher) wrote :

I did want to uninstall anything. So I end up adding a ExecStartPre line to check for default display manager on legacy settings /etc/X11/default-display-manager, now it's working well:

/lib/systemd/system/sddm.service
________________________________
[Unit]
Description=Simple Desktop Display Manager
Documentation=man:sddm(1) man:sddm.conf(5)
After=systemd-user-sessions.service <email address hidden> plymouth-quit.service

[Service]
ExecStartPre=/bin/sh -c '[ "$(basename $(cat /etc/X11/default-display-manager 2>/dev/null))" = "sddm" ]'
ExecStart=/usr/bin/sddm
Restart=always
#PrivateTmp=yes

[Install]
Alias=display-manager.service
WantedBy=graphical.target
________________________________
Reference: Copied from /lib/systemd/system/lightdm.service

Source: https://askubuntu.com/questions/697529/lightdm-sddm-fight-on-greeter-screen
Same case: https://askubuntu.com/questions/714633/how-to-fix-bad-display-driver

Travisgevans (travisgevans) wrote :

I believe I hit this today in 15.10 (testing in VirtualBox). I installed kbuntu-desktop, and it asked which display manager I wanted to use. I just wanted to use the existing one, which I assume was lightdm. So I selected lightdm, and it set up sddm anyway. On boot up, the login screen freaked out, constantly flickering between lightdm and sddm. Both responded to password input, and when I launched Cinnamon, there were two sessions loaded on the same screen at the same time, two panels, one desktop session obscuring the other in a “picture-in-picture” fashion. The mouse did not register properly, there was massive graphical distortion, the system was unusable, and it completely froze after a minute or two until I finally managed to disable one of the DMs.

IMO, this is pretty severe. A non-technical user would be absolutely hopeless if this happened to them.

This bug has been reported upstream, right now:

https://github.com/sddm/sddm/issues/620 (SDDM and LightDM can run in paralell (thus create conflict).

@all: Thanks for taking your time to report this here.

description: updated

@travisgevans: Could you provide the content of /lib/systemd/system/sddm.service ?

Looks pretty old to me with the current version in Wily [1], not having received patches from sddm 0.13 which landed in the current dev.-release Xenial 16.04 [3]. This presents a huge gap in development, and may have been resolved upstream already.

via packagesearch/changelog [2] :

sddm (0.11.0-0ubuntu11) wily
 last update: Mon, 24 Aug 2015 12:40:32 +0200

[1] http://packages.ubuntu.com/search?keywords=sddm&searchon=names&suite=all&section=all
[2] http://changelogs.ubuntu.com/changelogs/pool/universe/s/sddm/sddm_0.11.0-0ubuntu11/changelog
[3] http://changelogs.ubuntu.com/changelogs/pool/universe/s/sddm/sddm_0.13.0-1ubuntu5/changelog

I've tried to reproduce this bug with Xenial in a VirtualBox VM today, and it didn't come up. After installing kubuntu-desktop and reboot, lightdm came up and not sddm. Seems like Flames_in_paradise assumption is correct and the bug is fixed upstream.

Sneetsher (sneetsher) on 2019-05-11
Changed in sddm:
importance: Unknown → Undecided
status: Unknown → New
importance: Undecided → Unknown
status: New → Unknown
Sneetsher (sneetsher) wrote :

This bug could be closed, we couldn't reproduce it on late releases (seems only for 15.04-15.10). Probably fixed by changes from upstream.

Changed in sddm:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.