Dolphin won't keep the folder shortcuts on Kubuntu 15.04 with Plasma 5.

Bug #1422469 reported by Hans Milos Toquica Cáceres on 2015-02-16
48
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Kdenlive
Fix Released
Medium
One Hundred Papercuts
Medium
Unassigned
kdelibs
Fix Released
Low
kde-baseapps (Ubuntu)
Medium
Unassigned
Vivid
Medium
Unassigned
Wily
Medium
Unassigned
kde4libs (Ubuntu)
Medium
Unassigned
Vivid
Medium
Unassigned
Wily
Medium
Unassigned
kdenlive (Ubuntu)
Medium
Unassigned
kio (Ubuntu)
Medium
Unassigned
Vivid
Medium
Unassigned
Wily
Medium
Unassigned

Bug Description

# Impact
KDE software loses 'places' bookmarks when using KDE frameworks 5 and KDELibs4 software at the same time. In particular the default file manager Dolphin will have one of its by-default-visible features rendered useless by this and actively lose data the user created.

## Affects
- kde4libs: which has a sync code that attempts to sync the XDG places file with the legacy KDE file.
- kio (kf5): as it has the same syncing code as kde4libs.
- kde-baseapps (specifically dolphin): as it is using the legacy KDE file while the rest of a plasma5 desktop would use the XDG places file.
- kdenlive: has hardcoded file lookup for the old file to automatically inject its projects folder into the places list (not terribly important feature and actually has provisioning for the file not being found).

# Test Case
1. Open Dolphin.
2. Select the folder you want in the Places shortcut on the left panel.
3. Drag and Drop the folder on the left panel in the "Places" section.
4. Restart the system.

## Kdenlive
Kdenlive has a bit of a different use case it injects itself into the list of places
- create new user
- start kdenlive and go through wizard
- file -> open
- places sidebar should contain an entry for kdenlive projects.

# Regression Potential
Somewhat potentially high unfortunately. The way this had to be resolved was by removing a piece of compatibility tech from kdelibs(4) that would attempt to sync the XDG places bookmarks with the kdelibs<=4 preferred kde-specific places file and instead always use the XDG file. This effectively means that the old places file will not get updated anymore. Applications that had its path hardcoded would use the wrong file and no longer show the same places list as the rest of the system. It is hard to assess whether we have any such application in the archive, but it is a risk worth taking considering we currently lose user data in one of the most obvious places.

# Other Info

## Upstream references
http://quickgit.kde.org/?p=kdelibs.git&a=commit&h=5c0a31a2f2a46aa44b8c34baae67b6951b2abcaf
http://quickgit.kde.org/?p=kde-baseapps.git&a=commit&h=270d2affaafcc9e87ba14f82bfe579e22607e2d2
http://quickgit.kde.org/?p=kio.git&a=commit&h=e919daeb5b144b146dbf459fadb116729b866d21

## Upstream Bug
https://bugs.kde.org/show_bug.cgi?id=345174

---- original report ----

Steps to reproduce:
1. Open Dolphin.
2. Select the folder you want in the Places shortcut on the left panel.
3. Drag and Drop the folder on the left panel in the "Places" section.
4. Restart the system.

What Happens:
Dolphin is set back to default places.

What is expected:
Dolphin displays the customize places shortcuts.

I tried askubuntu, but they deleted my question as off-topic because Kubuntu 15.04 Vivid Vervet with Plasma 5 haven't been released.

Aditional info is that this is not an upgrade, but a fresh install.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1422469/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
tags: added: kubuntu vivid
affects: ubuntu → kubuntu-meta (Ubuntu)
7 comments hidden view all 105 comments

Unlike bug 342685 this is consistently reproducible: new bookmarks are always lost when restarting dolphin. Downgrading kdelibs to 4.14.5 fixed this (but the sorting issues in bug 342685 reappear of course)

Thanks for the bug report!
I can reproduce the problem with kdelibs 4.14.6

*** Bug 345008 has been marked as a duplicate of this bug. ***

Also reproducible with Dolphin git + KF 5.8

The problem persists after reverting commit 2a79feae in kde-baseapps.

All bookmark changes are properly written to disk (.local/share/kfileplaces/bookmarks.xml for KF5 and .kde4/share/apps/kfileplaces/bookmarks.xml for kdelibs4)

e.g. when I add test as bookmark following element will be added to bookmarks.xml:

<bookmark href="file:///home/emmanuel/test">
  <title>test</title>
  <info>
   <metadata owner="http://freedesktop.org">
    <bookmark:icon name="inode-directory"/>
   </metadata>
   <metadata owner="http://www.kde.org">
    <ID>1426502493/1</ID>
    <IsHidden>false</IsHidden>
   </metadata>
  </info>
 </bookmark>

Also updating bookmarks on all running instances works properly.

The problem happens while loading the bookmarks.

KBookmarkGroup doesn't contain the "test" bookmark, will test it with KBookmarkGroupTraverser.

3 comments hidden view all 105 comments

(In reply to Emmanuel Pescosta from comment #5)
> All bookmark changes are properly written to disk
> (.local/share/kfileplaces/bookmarks.xml for KF5 and
> .kde4/share/apps/kfileplaces/bookmarks.xml for kdelibs4)
>
> e.g. when I add test as bookmark following element will be added to
> bookmarks.xml:
>
> <bookmark href="file:///home/emmanuel/test">
> <title>test</title>
> <info>
> <metadata owner="http://freedesktop.org">
> <bookmark:icon name="inode-directory"/>
> </metadata>
> <metadata owner="http://www.kde.org">
> <ID>1426502493/1</ID>
> <IsHidden>false</IsHidden>
> </metadata>
> </info>
> </bookmark>
>
> Also updating bookmarks on all running instances works properly.
>
> The problem happens while loading the bookmarks.

It seems to me that dolphin (kdelibs) only loads/respects ~/.local/share/user-places.xbel now, but ignores ~/.kde4/share/apps/kfileplaces/bookmarks.xml. If I add a bookmark to the latter (using a text editor), it doesn't show in dolphin (and in the file open/save dialog neither); if I add it to user-places.xbel, it works (in both dolphin and the file open/save dialog).

BTW, adding an entry in the file open/save dialog makes it appear in dolphin as well.

(In reply to Wolfgang Bauer from comment #10)

> It seems to me that dolphin (kdelibs) only loads/respects
> ~/.local/share/user-places.xbel now, but ignores
> ~/.kde4/share/apps/kfileplaces/bookmarks.xml. If I add a bookmark to the
> latter (using a text editor), it doesn't show in dolphin (and in the file
> open/save dialog neither); if I add it to user-places.xbel, it works (in
> both dolphin and the file open/save dialog).
>
> BTW, adding an entry in the file open/save dialog makes it appear in dolphin
> as well.

I've been wondering the whole day why my user-places.xbel is empty and why I can't add entries by dragging and dropping in Dolphin.

Thanks for the helpful information:)

(In reply to Wolfgang Bauer from comment #10)
> (In reply to Emmanuel Pescosta from comment #5)
> > All bookmark changes are properly written to disk
> > (.local/share/kfileplaces/bookmarks.xml for KF5 and
> > .kde4/share/apps/kfileplaces/bookmarks.xml for kdelibs4)
> >
> > e.g. when I add test as bookmark following element will be added to
> > bookmarks.xml:
> >
> > <bookmark href="file:///home/emmanuel/test">
> > <title>test</title>
> > <info>
> > <metadata owner="http://freedesktop.org">
> > <bookmark:icon name="inode-directory"/>
> > </metadata>
> > <metadata owner="http://www.kde.org">
> > <ID>1426502493/1</ID>
> > <IsHidden>false</IsHidden>
> > </metadata>
> > </info>
> > </bookmark>
> >
> > Also updating bookmarks on all running instances works properly.
> >
> > The problem happens while loading the bookmarks.
>
> It seems to me that dolphin (kdelibs) only loads/respects
> ~/.local/share/user-places.xbel now, but ignores
> ~/.kde4/share/apps/kfileplaces/bookmarks.xml. If I add a bookmark to the
> latter (using a text editor), it doesn't show in dolphin (and in the file
> open/save dialog neither); if I add it to user-places.xbel, it works (in
> both dolphin and the file open/save dialog).
>
> BTW, adding an entry in the file open/save dialog makes it appear in dolphin
> as well.

(In reply to Kristjan from comment #11)
> (In reply to Wolfgang Bauer from comment #10)
>
> > It seems to me that dolphin (kdelibs) only loads/respects
> > ~/.local/share/user-places.xbel now, but ignores
> > ~/.kde4/share/apps/kfileplaces/bookmarks.xml. If I add a bookmark to the
> > latter (using a text editor), it doesn't show in dolphin (and in the file
> > open/save dialog neither); if I add it to user-places.xbel, it works (in
> > both dolphin and the file open/save dialog).
> >
> > BTW, adding an entry in the file open/save dialog makes it appear in dolphin
> > as well.
>
> I've been wondering the whole day why my user-places.xbel is empty and why I
> can't add entries by dragging and dropping in Dolphin.
>
> Thanks for the helpful information:)

I can confirm that adding an entry in the open/save dialog makes it appear in dolphin. Additionally, both ~/.kde4/share/apps/kfileplaces/bookmarks.xml and ~/.local/share/user-places.xbel get a new entry. So it seems that entries in ~/.local/share/user-places.xbel are ignored like Wolfgang Bauer suggests.
Thanks for the tip!

3 comments hidden view all 105 comments

@Everyone:
Thanks for your help!
All your active cooperation is immensely helpful for us! Awesome :D

Ah ok, the xbel file comes from the freedesktop specification: http://freedesktop.org/wiki/Specifications/desktop-bookmark-spec/

@Marco:
Is it possible to move away from bookmarks.xml to user-places.xbel only? So that we can avoid the syncing.

The following code moves Dolphin to user-places.xbel (fixes the problem of disappearing places):
const QString file = QStandardPaths::writableLocation(QStandardPaths::GenericDataLocation) + "/user-places.xbel";
m_bookmarkManager = KBookmarkManager::managerForExternalFile(file);

22 comments hidden view all 105 comments
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kubuntu-meta (Ubuntu):
status: New → Confirmed
Eneko Nieto (enekonieto) wrote :

Same bugs affects to me.

$ dolphin --version
Qt: 4.8.6
KDE Development Platform: 4.14.6
Dolphin: 14.12.3

$ uname -a
Linux eneko 3.19.0-10-generic #10-Ubuntu SMP Mon Mar 23 16:16:45 UTC 2015 i686 i686 i686 GNU/Linux

22 comments hidden view all 105 comments

*** Bug 345635 has been marked as a duplicate of this bug. ***

Changed in kubuntu-meta (Ubuntu):
importance: Undecided → Low
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Low
21 comments hidden view all 105 comments
Luke Johnstone (john-wella) wrote :

I too am experiencing this. Both on a free install and an upgraded system (a desktop and a laptop). Also my colleague is also experiencing this. All systems are fully up to date. Let me know if I can provide more information, always willing to help :)

22 comments hidden view all 105 comments

Hi. Any update on this?

(In reply to Siddhartha Sahu from comment #19)
> Hi. Any update on this?

We are working on it.

5 comments hidden view all 105 comments

(In reply to Siddhartha Sahu from comment #25)
> (In reply to vonswallow from comment #24)
> > is there a way to manually add bookmarks as a work around for now until its
> > fixed
>
> You can add bookmarks using a file open/save dialog. Eg, Kate -> Ctrl+o ->
> add your bookmarks -> close Kate. Bookmarks will be saved for dolphin too.

Awesome! it worked. Thanks

*** Bug 346494 has been marked as a duplicate of this bug. ***

*** Bug 346509 has been marked as a duplicate of this bug. ***

2 comments hidden view all 105 comments

Same problem for me too.
Using Kubuntu 15.04
Dolphin Version 14.12.3
KDE Development Platform 4.14.6

also I'd like to have "Recently Saved" and "Search For" sections disappear instead of my added entries.

32 comments hidden view all 105 comments
Paul Worrall (nicknak) wrote :

KDE bug tracker says the bug was fixed on 30 Apr 2015.

Changed in kdelibs:
importance: Unknown → Low
status: Unknown → Fix Released
60 comments hidden view all 105 comments

@Emmanuel Pescosta : Thanks for this fix, but how apply it ? I can't see any make file to compile it ?
I'm using Kubuntu 15.04 x64, (fresh install)

(In reply to Kubuntiac from comment #44)
> Any chance someone could give a pointer on how to apply the fix to a current
> install without having to wait for it to come down the line from my distro?
> I'm using Kubuntu 15.04.

(In reply to Guillaume Debray from comment #45)
> @Emmanuel Pescosta : Thanks for this fix, but how apply it ? I can't see any
> make file to compile it ?
> I'm using Kubuntu 15.04 x64, (fresh install)

Clone [0] kdelibs, kio and kde-baseapps, download and apply the patches [1], compile [2] and install [3] them.

[0] git clone git://anongit.kde.org/{REPO_NAME}.git && cd {REPO_NAME}
[1] git apply "path/to/the/patch"
[2] mkdir build && cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release .. && make -j4
[3] sudo make install

Or ask downstream to rebuild patched kdelibs, kio and kde-baseapps packages (like the Arch developers did :))

no longer affects: kubuntu-meta (Ubuntu)
description: updated
no longer affects: kdelibs (Ubuntu)
no longer affects: kdelibs (Ubuntu Vivid)
no longer affects: kdelibs (Ubuntu W-series)
description: updated
description: updated
Changed in kde-baseapps (Ubuntu Vivid):
status: New → Fix Committed
Changed in kde4libs (Ubuntu Vivid):
status: New → Fix Committed
Changed in kio (Ubuntu Vivid):
status: New → Fix Committed
tags: added: verification-needed

After update to version 15.04.0, platform KDE 4.14.7 drag and drop adding works OK. Adding by right click menu "Add to places" works until Dolphin restart. Thanks!

*** Bug 347248 has been marked as a duplicate of this bug. ***

Changed in kdenlive:
importance: Unknown → Medium
status: Unknown → Fix Released
4 comments hidden view all 105 comments
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kde-baseapps (Ubuntu Wily):
status: New → Confirmed
Changed in kde4libs (Ubuntu Wily):
status: New → Confirmed
Changed in kdenlive (Ubuntu):
status: New → Confirmed
Changed in kio (Ubuntu Wily):
status: New → Confirmed
5 comments hidden view all 105 comments

Created attachment 92444
Bug Persists

Kubuntu 15.04 w/Backports PPA; Dolphin 15.04.0 w/KDE 4.14.7

Same for me, bug persists on 15.04 Kubuntu
- Tried to ppa-purge backports, no effect.
- Tried to come back with the na tive theme (brise), no effect.
- Tried to delete ~/.kde/share/apps/dolphin, no effect.

Same here, newly added places still vanish in Kubuntu 15.04 + Beta Backport PPA.

However what works now is that I can move places in the list. E.g. move one from the bottom to the top and that perserves restarts of Dolphin. Before, the place entries were just going back to the "original" order

The bug will be fixed in 15.04.1 which isn't released yet. (tag tomorrow)
Kubuntu doesn't seem to have backported the patch in 15.04 so you'll have to wait some more days ;)

Changed in kde-baseapps (Ubuntu Vivid):
importance: Undecided → Low
Changed in kde-baseapps (Ubuntu Wily):
importance: Undecided → Low
Changed in hundredpapercuts:
importance: Low → Medium
Changed in kde-baseapps (Ubuntu Vivid):
importance: Low → Medium
Changed in kde-baseapps (Ubuntu Wily):
importance: Low → Medium
Changed in kde4libs (Ubuntu Vivid):
importance: Undecided → Medium
Changed in kde4libs (Ubuntu Wily):
importance: Undecided → Medium
Changed in kdenlive (Ubuntu):
importance: Undecided → Medium
Changed in kio (Ubuntu Vivid):
importance: Undecided → Medium
Changed in kio (Ubuntu Wily):
importance: Undecided → Medium

*** Bug 347422 has been marked as a duplicate of this bug. ***

Same problem here, Ubuntu 15.04 with Unity Desktop and Dolphin 14.12.3.

(In reply to Peter Stolz from comment #54)
> Same problem here, Ubuntu 15.04 with Unity Desktop and Dolphin 14.12.3.

Again, this will (hopefully) be fixed in KDE Applications 15.04.1, to be released tomorrow.
Bug your distribution to include the fix in their packages or to update them.

There's no need for more "I still see this with Dolphin 14.12.3" comments here, IMHO.
This bug has originally been reported against dolphin 14.12.3 anyway.

FYI : seems fixed with latest packages on ArchLinux. And it's strange, I don't use yet KDE Applications 15.04.1 :

$pacman -Qs kde | grep '15\.04'
local/filelight 15.04.0-1 (kde-applications kdeutils)
local/kate 15.04.0-1 (kde-applications kdebase)
local/kcalc 15.04.0-1 (kde-applications kdeutils)
local/kde-base-artwork 15.04.0-1
local/kdeadmin-ksystemlog 15.04.0-1 (kde-applications kdeadmin)
local/kdebase-dolphin 15.04.0-3 (kde-applications kdebase)
local/kdebase-kdialog 15.04.0-3 (kde-applications kdebase)
local/kdebase-keditbookmarks 15.04.0-3 (kde-applications kdebase)
local/kdebase-kfind 15.04.0-3 (kde-applications kdebase)
local/kdebase-konq-plugins 15.04.0-3 (kde-applications kdebase)
local/kdebase-konqueror 15.04.0-3 (kde-applications kdebase)
local/kdebase-lib 15.04.0-3
local/kdebase-runtime 15.04.0-4
local/kdegraphics-kolourpaint 15.04.0-1 (kde-applications kdegraphics)
local/kdegraphics-ksnapshot 15.04.0-1 (kde-applications kdegraphics)
local/kdegraphics-mobipocket 15.04.0-1 (kde-applications kdegraphics)
local/kdegraphics-okular 15.04.0-1 (kde-applications kdegraphics)
local/kdegraphics-strigi-analyzer 15.04.0-1
local/kdemultimedia-kmix 15.04.0-1 (kde-applications kdemultimedia)
local/kdenetwork-strigi-analyzers 15.04.0-1 (kde-applications kdenetwork)
local/kdesdk-strigi-analyzers 15.04.0-1 (kde-applications kdesdk)
local/kdeutils-ark 15.04.0-1 (kde-applications kdeutils)
local/kdeutils-kgpg 15.04.0-1 (kde-applications kdeutils)
local/kdeutils-kwalletmanager 15.04.0-1 (kde-applications kdeutils)
local/kompare 15.04.0-2 (kde-applications kdesdk)
local/konsole 15.04.0-1 (kde-applications kdebase)
local/kwrite 15.04.0-1 (kde-applications kdebase)
local/libkipi 15.04.0-1
local/okteta 15.04.0-1 (kde-applications kdesdk)

(In reply to Alain Laporte from comment #56)
> FYI : seems fixed with latest packages on ArchLinux. And it's strange, I
> don't use yet KDE Applications 15.04.1 :

Well, that's not so strange really. Arch apparently added the fixes to their 15.04.0 packages on April 30th (i.e. kdebase-dolphin 15.04.0-3 and kdelibs 4.14.7-2):
https://projects.archlinux.org/svntogit/packages.git/log/trunk?h=packages/kdebase
https://projects.archlinux.org/svntogit/packages.git/log/trunk?h=packages/kdelibs

So you're basically confirming that the fix works... ;-)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdenlive - 0.9.10-2ubuntu2

---------------
kdenlive (0.9.10-2ubuntu2) wily; urgency=medium

  * Fix automatic places injection to use new places file.
    + Add patch kubuntu_use_new_places_file.patch changing the config file
      to inject the projects folder into the 'places' list from the old legacy
      bookmarks.xml to the new user-places.xbel file LP: #1422469

 -- Harald Sitter <email address hidden> Mon, 04 May 2015 15:42:04 +0200

Changed in kdenlive (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde-baseapps - 4:14.12.3-0ubuntu4

---------------
kde-baseapps (4:14.12.3-0ubuntu4) wily; urgency=medium

  * Fix dolphin losing places bookmarks.
    + Add patch
      upstream_Use-user-places.xbel-instead-of-bookmarks.xml-in-pla.patch to
      force dolphin to only use the new user-places.xbel file rather than the
      legacy kfileplaces bookmarks file. LP: #1422469

 -- Harald Sitter <email address hidden> Mon, 04 May 2015 11:04:31 +0200

Changed in kde-baseapps (Ubuntu Wily):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kio - 5.9.0-0ubuntu2

---------------
kio (5.9.0-0ubuntu2) wily; urgency=medium

  * Add upstream patch
    upstream_Remove-bookmarks-syncing-from-KFilePlacesModel-and-u.patch
    to remove faulty bookmarks syncing from places and use a single config for
    places instead. LP: #1422469

 -- Harald Sitter <email address hidden> Mon, 04 May 2015 10:56:34 +0200

Changed in kio (Ubuntu Wily):
status: Confirmed → Fix Released

*** Bug 347893 has been marked as a duplicate of this bug. ***

- Linux 3.16.7-21-desktop
- openSUSE 13.2 (Harlequin) (x86_64)
- KDE: 4.14.6
- Dolphin 14.12.3-16.5

Same problem here, "/local/share/user-places.xbel" is not being updated.. (witch saves "places" i think)

or merge git update with OpenSUSE package....

André

(In reply to André Verwijs from comment #59)
> - Linux 3.16.7-21-desktop
> - openSUSE 13.2 (Harlequin) (x86_64)
> - KDE: 4.14.6
> - Dolphin 14.12.3-16.5
>
>
> Same problem here, "/local/share/user-places.xbel" is not being updated..
> (witch saves "places" i think)
So once again:
Yes, this is a problem in Dolphin 14.12.3, that's the version it has been reported against.

For openSUSE an update to the fixed 15.04.1 is on the way, but it will take a while.

Solved for me with the backports update (Kubuntu 15.04).
Thanks to the devs.

Solved on openSUSE 13.2 with http://download.opensuse.org/repositories/KDE:/Applications/openSUSE_13.2/ repository enabled.
Just wanna to say this bug was fixed.. Thanks to the devs! :)

Jonathan Riddell (jr) wrote :

I installed the new kdelibs, kio, dolphin and kdenlive from vivid-proposed. It successfully saved the bookmarks in the dolphin Places panel and in the kdenlive File->Open dialogue

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde4libs - 4:4.14.6-4~ubuntu3.1

---------------
kde4libs (4:4.14.6-4~ubuntu3.1) vivid; urgency=medium

  * Fix dolphin losing places boomarks.
    + Add patch
      upstream_Remove-bookmarks-syncing-from-KFilePlacesModel-and-u.patch
      making the fileplacesmodel only use the new user-places.xbel and not
      attempt to keep it synced with a legacy file. LP: #1422469

 -- Harald Sitter <email address hidden> Mon, 04 May 2015 11:19:29 +0200

Changed in kde4libs (Ubuntu Vivid):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for kde4libs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde-baseapps - 4:14.12.3-0ubuntu3.1

---------------
kde-baseapps (4:14.12.3-0ubuntu3.1) vivid; urgency=medium

  * Fix dolphin losing places bookmarks.
    + Add patch
      upstream_Use-user-places.xbel-instead-of-bookmarks.xml-in-pla.patch to
      force dolphin to only use the new user-places.xbel file rather than the
      legacy kfileplaces bookmarks file. LP: #1422469

 -- Harald Sitter <email address hidden> Mon, 04 May 2015 11:04:31 +0200

Changed in kde-baseapps (Ubuntu Vivid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kio - 5.9.0-0ubuntu1.1

---------------
kio (5.9.0-0ubuntu1.1) vivid; urgency=medium

  * Add upstream patch
    upstream_Remove-bookmarks-syncing-from-KFilePlacesModel-and-u.patch
    to remove faulty bookmarks syncing from places and use a single config for
    places instead. LP: #1422469

 -- Harald Sitter <email address hidden> Mon, 04 May 2015 10:56:34 +0200

Changed in kio (Ubuntu Vivid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde4libs - 4:4.14.6-4~ubuntu4

---------------
kde4libs (4:4.14.6-4~ubuntu4) wily; urgency=medium

  * Fix dolphin losing places boomarks.
    + Add patch
      upstream_Remove-bookmarks-syncing-from-KFilePlacesModel-and-u.patch
      making the fileplacesmodel only use the new user-places.xbel and not
      attempt to keep it synced with a legacy file. LP: #1422469

 -- Harald Sitter <email address hidden> Mon, 04 May 2015 11:19:29 +0200

Changed in kde4libs (Ubuntu Wily):
status: Confirmed → Fix Released

(In reply to Naufal Fachrian from comment #62)
> Solved on openSUSE 13.2 with
> http://download.opensuse.org/repositories/KDE:/Applications/openSUSE_13.2/
> repository enabled.
> Just wanna to say this bug was fixed.. Thanks to the devs! :)

I think I'm also affected by this bug (openSUSE 13.2) and here when I rearrange a places entry or delete one or add a new one it gets deleted immediately again (<1sec).

Furthermore when I rearrange/delete/add a places entry my whole plasma-desktop crashes (and I have to do 'killall plasma-desktop && plasma-desktop &' to bring it back). I've recorded a short video to demonstrate this "places bug", see https://youtu.be/m04DCjboKnA

So by above mentioned solution to add the KDE:Applications repo doesn't work here. I've upgrade my kde packages to the Applications repo versions but the dolphin problem still exists.

What I'm wondering is also the fact that my ~/.kde4/share/apps/kfileplaces/bookmarks.xml file is really (!) huge and becomming bigger and bigger (3,5MB now).

~ ll ~/.kde4/share/apps/kfileplaces/bookmarks.xml
-rw-r--r-- 1 heart users 3,5M 1. Jul 13:30 /home/heart/.kde4/share/apps/kfileplaces/bookmarks.xml

There are ~15000 lines of code in there which looks like again and again like shown here https://paste.kde.org/pabbfnjtc

(.local/share/user-places.xbel file looking good with 2,9K)

S | Name | Typ | Version | Arch | Repository
--+------------------------------------+------------+--------------+--------+-------------------------
i | Dolphin | Anwendung | | noarch | (Systempakete)
i | dolphin | Paket | 15.04.2-3.8 | x86_64 | KDE:Applications

~ kde4-config --version
Qt: 4.8.6
KDE: 4.14.9
kde4-config: 1.0

(In reply to Hermann from comment #63)
> So by above mentioned solution to add the KDE:Applications repo doesn't work
> here. I've upgrade my kde packages to the Applications repo versions but the
> dolphin problem still exists.
It works fine here.

But adding this repo and installing dolphin from there is not necessary any more anyway.
Dolphin 15.04.1 and kdelibs 4.14.9 are available as official update for openSUSE 13.2.

> What I'm wondering is also the fact that my
> ~/.kde4/share/apps/kfileplaces/bookmarks.xml file is really (!) huge and
> becomming bigger and bigger (3,5MB now).
>
> ~ ll ~/.kde4/share/apps/kfileplaces/bookmarks.xml
> -rw-r--r-- 1 heart users 3,5M 1. Jul 13:30
> /home/heart/.kde4/share/apps/kfileplaces/bookmarks.xml
>
> There are ~15000 lines of code in there which looks like again and again
> like shown here https://paste.kde.org/pabbfnjtc

Wow, a lot of garbage has accumulated in there.
Just delete the whole folder /home/heart/.kde4/share/apps/kfileplaces/, the "places" are not stored there any more to fix this bug (and others).

Strange that it is still growing though. It shouldn't be used at all any more.
Is your system fully up to date?
All kdelibs* and libkde* packages in particular?

> (.local/share/user-places.xbel file looking good with 2,9K)
Looks ok, yes. But verify that the file is writable.

If you still have problems with the latest versions, you might try to delete that one as well and start fresh. Maybe it's gotten corrupted somehow by the earlier problems...

And I don't see how your plasma crashes would be related to this bug at all.

Download full text (3.7 KiB)

> But adding this repo and installing dolphin from there is not necessary any
> more anyway.
> Dolphin 15.04.1 and kdelibs 4.14.9 are available as official update for
> openSUSE 13.2.

> Wow, a lot of garbage has accumulated in there.
> Just delete the whole folder /home/heart/.kde4/share/apps/kfileplaces/, the
> "places" are not stored there any more to fix this bug (and others).
>
> Strange that it is still growing though. It shouldn't be used at all any
> more.
> Is your system fully up to date?
> All kdelibs* and libkde* packages in particular?
Yes, it's fully up to date.

# zypper se -si kdelibs libkde dolphin
S | Name | Typ | Version | Arch | Repository
--+----------------------------+-----------+----------------+--------+-------------------------
i | Dolphin | Anwendung | | noarch | (Systempakete)
i | dolphin | Paket | 15.04.2-3.8 | x86_64 | KDE:Applications
i | kdelibs3-default-style | Paket | 3.5.10-83.1.10 | x86_64 | openSUSE 13.2 OSS
i | kdelibs4 | Paket | 4.14.9-24.2 | x86_64 | openSUSE 13.2 OSS Update
i | kdelibs4-branding-openSUSE | Paket | 13.2-3.6.1 | noarch | openSUSE 13.2 OSS
i | kdelibs4-core | Paket | 4.14.9-24.2 | x86_64 | openSUSE 13.2 OSS Update
i | libKF5KDELibs4Support5 | Paket | 5.10.0-21.19 | x86_64 | openSUSE 13.2 OSS Update
i | libkde4 | Paket | 4.14.9-24.2 | x86_64 | openSUSE 13.2 OSS Update
i | libkdecore4 | Paket | 4.14.9-24.2 | x86_64 | openSUSE 13.2 OSS Update
i | libkdegames | Paket | 15.04.2-3.6 | x86_64 | KDE:Applications
i | libkdegames4 | Paket | 14.12.3-9.5 | x86_64 | KDE:Applications
i | libkdegames6 | Paket | 14.12.3-9.5 | x86_64 | KDE:Applications
i | libkdepim4 | Paket | 4.14.9-24.2 | x86_64 | openSUSE 13.2 OSS Update
i | libkdepimlibs4 | Paket | 4.14.9-24.1 | x86_64 | openSUSE 13.2 OSS Update

> If you still have problems with the latest versions, you might try to delete
> that one as well and start fresh. Maybe it's gotten corrupted somehow by the
> earlier problems...

What I tried now is totally removed ~/.kde4/share/apps/kfileplaces/ and removed also ~/.local/share/user-places* files.
BUT after logout and back in there was now functional plasma-desktop there!?! No kicker, no taskbar/systemtray icons, no plasma widgets, no desktop background picture...
Also 'killall plasma-desktop && plasma-desktop &' didn't bring back a working desktop in this stage :(

I added then a new user in a console and logged me in with this new user and voila, there I have a perfectly working kde/dolphin (incl. places entries working here).
So I copied the working ~/.local/share/user-places.xbel file from this new user to my old user (chowned to old user, home folder name to old user) and logged in again with the old user. Now I had a working desktop again!

The situation now is... I CAN add a new place in dolphin (this new entry st...

Read more...

...should be: "...BUT after logout and back in there was NO functional plasma-desktop there!?!"

(In reply to Hermann from comment #65)
> Yes, it's fully up to date.

Ok.

> What I tried now is totally removed ~/.kde4/share/apps/kfileplaces/ and
> removed also ~/.local/share/user-places* files.
> BUT after logout and back in there was now functional plasma-desktop
> there!?! No kicker, no taskbar/systemtray icons, no plasma widgets, no
> desktop background picture...
> Also 'killall plasma-desktop && plasma-desktop &' didn't bring back a
> working desktop in this stage :(

Strange, that should have absolutely no impact on plasma-desktop.

> I added then a new user in a console and logged me in with this new user and
> voila, there I have a perfectly working kde/dolphin (incl. places entries
> working here).
> So I copied the working ~/.local/share/user-places.xbel file from this new
> user to my old user (chowned to old user, home folder name to old user) and
> logged in again with the old user. Now I had a working desktop again!
>
> The situation now is... I CAN add a new place in dolphin (this new entry
> still gets deleted automatically after 1 sec) BUT after this addition of a
> new places entry plasma-desktop crashes again :(!

That it works with a new user account shows that the bug is fixed.
But again, check that the file is writeable for your user. Depending on how you copied it, that might not be the case.

> Really strange :(

Yes, and especially your Plasma crashes are totally unrelated to this fixed bug report.

And I still don't see any relation to Plasma, Plasma should not care at all whether user-places.xbel exists.
Probably you added some Plasmoid that makes use of it? In this case that might also be the reason why places get removed again automatically.
Try to delete (or at least temporary rename) Plasma's config as well: ~/.kde4/share/config/plasma*

And if Plasma crashes, you should file a bug report against Plasma. But it would be good to find out first which Plasmoid causes this.

Wolfgang, thank you for your patience.... I found it!

The plasma-widget "Homerun-Kicker" (https://blogs.kde.org/2014/01/29/homerun-120) causing this plasma-desktop crash!!!!

I removed the homerun-kicker plasmoid and voila, no more plasma-desktop crashes when editing my dolphin places entries!

~ zypper se -si homerun
S | Name | Typ | Version | Arch | Repository
--+----------------+-------+------------+--------+-----------
i | homerun | Paket | 1.2.5-19.6 | x86_64 | KDE:Extra
i | homerun-kicker | Paket | 1.2.5-19.6 | x86_64 | KDE:Extra
i | libhomerun0 | Paket | 1.2.5-19.6 | x86_64 | KDE:Extra

sumbitted also a new bug in homerun project, https://bugs.kde.org/show_bug.cgi?id=349850

(In reply to Hermann from comment #68)
> Wolfgang, thank you for your patience.... I found it!
Great!

> The plasma-widget "Homerun-Kicker"
> (https://blogs.kde.org/2014/01/29/homerun-120) causing this plasma-desktop
> crash!!!!
And I suppose it also overwrote your changes to the places.

From a quick look at the source code it seems that this still uses both files, and probably tries to synchronize them as well. That's what mainly caused problems in the past, and got removed in kdelibs and dolphin to fix this (and other) bugs. They only use user-places.xbel now.

Maybe there would be an option to turn the "places" off in Homerun?
This might be a workaround.

(In reply to Hermann from comment #69)
> sumbitted also a new bug in homerun project,
> https://bugs.kde.org/show_bug.cgi?id=349850
Thanks.

I would really like to know why are bugs like this one not being caught(and resolved) during the final testing.
At some point there was a situation in which the user downloads 'ready product', installs it and such important feature is not working. He/she decides to install other distro then.
All this hype, and fancy banners, and we receive unfinished product, even though they claim it to be stable. I know this bug is long gone by now, but I would really like to know the answer.
In my opinion:
- not saving bookmarks - not ready
- not working network manager - not ready
- random crashes when connecting second display - definitely not ready
- cpu stuck at pathetically low frequency after waking up from sleep - not ready;))

@Mateusz: It seems, that this is "banana-software" :-))

Paul White (paulw2u) wrote :

Closing as all other bug tasks showing "Fix Released"

Changed in hundredpapercuts:
status: Confirmed → Fix Released
Displaying first 40 and last 40 comments. View all 105 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.