TortoiseHG-nautilus uses icons from gnome-icon-theme-full package, but it's not installed as dependency

Bug #1295579 reported by Norbert on 2014-03-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
tortoisehg (Ubuntu)
High
Unassigned

Bug Description

I use TortoiseHg long time, it's great.

I installed tortoisehg-nautilus package on the newest Ubuntu 14.04 installation.

I opened Nautilus and navigated to a folder with Mercurial repositories. If I press right mouse button on them I see TortoiseHg submenu (so tortoisehg-nautilus is installed normally). But I don't see "green star in circle" overlay icon.

As I know from an issue reported to TortoiseHg developers (https://bitbucket.org/tortoisehg/thg/issue/3615/question-about-overlay-icon-on-a-folder) this and other icons come from 'gnome-icon-theme-full' Ubuntu package.

So I suggest to add 'gnome-icon-theme-full' package as a dependency of 'tortoisehg-nautilus' package.
Without these icons tortoisehg-nautilus is useless.

Steps to reproduce:
1. Install Ubuntu 14.04
2. Install tortoisehg-nautilus package, close Nautilus with (nautilus -q).
3. Open Nautilus and navigate to folder with Mercurial repository(ies).

Expected results:
* Mercurial repository(ies) have "green star in circle" overlay icons.

Actual results:
* Mercurial repositories do not have "green star in circle" overlay icons. These icons come from 'gnome-icon-theme-full', which is not installed.

Note: for clarification I attached "green star in circle" icon. It is located in "/usr/share/icons/gnome/24x24/emblems/emblem-generic.png".

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: tortoisehg-nautilus 2.10-1
ProcVersionSignature: Ubuntu 3.13.0-18.38-generic 3.13.6
Uname: Linux 3.13.0-18-generic i686
ApportVersion: 2.13.3-0ubuntu1
Architecture: i386
CurrentDesktop: Unity
Date: Fri Mar 21 12:54:42 2014
InstallationDate: Installed on 2014-03-17 (4 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha i386 (20140316)
PackageArchitecture: all
SourcePackage: tortoisehg
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Norbert (nrbrtx) wrote :
Norbert (nrbrtx) wrote :

I subscribed <TortoiseHg PPA Packagers> because of the fact, that tortoisehg-nautilus package from ppa:tortoisehg-ppa/releases is affected by this bug too. Tested at least on Ubuntu 12.04.4 (see issue on bitbucket for details).

Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 14.10 (installed from Ubuntu 14.10 _Utopic Unicorn_ - Alpha i386 (20140902)).
Please fix it !

tags: added: utopic
Norbert (nrbrtx) wrote :

It seems that this bug is actual for all current and developing versions of Ubuntu (10.04 LTS lucid, 12.04 LTS precise, 14.04 LTS trusty, 14.10 utopic) - see http://packages.ubuntu.com/saucy/tortoisehg-nautilus .
So if it possible, please add 'gnome-icon-theme-full' to dependencies of the package.

Ludovico Cavedon (cavedon) wrote :

Thank you for the bug report, I have uploaded the fixed version to Debian https://tracker.debian.org/pkg/tortoisehg

Feel free to merge it into Ubuntu if it is not too late with the release cycle.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tortoisehg - 3.1.1-1

---------------
tortoisehg (3.1.1-1) unstable; urgency=low

  * Imported Upstream version 3.1.1.
  * Add tortoisehg-nautilus dependency on gnome-icon-theme-full (Ubuntu) or
    gnome-icon-theme (Debian) (LP: #1295579).
  * Update copyright.

 -- Ludovico Cavedon <email address hidden> Sun, 21 Sep 2014 20:18:55 -0700

Changed in tortoisehg (Ubuntu):
status: New → Fix Released
Norbert (nrbrtx) wrote :

Thank you for the package, Ludovico Cavedon!

But it seems that gnome-icon-theme-full will not be installed. Tested on fresh-installed Ubuntu 14.10.

Before installation:
   apt-cache policy tortoisehg-nautilus
      tortoisehg-nautilus:
        Installed: (none)
        Candidate: 3.1.1-1
        Version table:
           3.1.1-1 0
              500 http://archive.ubuntu.com/ubuntu/ utopic/universe i386 Packages

   apt-cache policy gnome-icon-theme
      gnome-icon-theme:
           Installed: 3.12.0-1ubuntu1
           Candidate: 3.12.0-1ubuntu1
           Version table:
          *** 3.12.0-1ubuntu1 0
                 500 http://archive.ubuntu.com/ubuntu/ utopic/main i386 Packages
                 100 /var/lib/dpkg/status

   apt-cache policy gnome-icon-theme-full
      gnome-icon-theme-full:
        Installed: (none)
        Candidate: 3.12.0-1ubuntu1
        Version table:
           3.12.0-1ubuntu1 0
              500 http://archive.ubuntu.com/ubuntu/ utopic/main i386 Packages

   apt-cache depends tortoisehg-nautilus
      tortoisehg-nautilus
       |Depends: gnome-icon-theme-full <- this dependency was missed
        Depends: gnome-icon-theme
        Depends: python-gi
        Depends: python-nautilus
        Depends: tortoisehg
       |Recommends: ssh-askpass-gnome
           Recommends: ssh-askpass
          ksshaskpass
          kwalletcli
          ssh-askpass-fullscreen
          ssh-askpass-gnome

   sudo apt-get install tortoisehg-nautilus
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      The following extra packages will be installed:
        gir1.2-nautilus-3.0 libjs-jquery libjs-underscore libqscintilla2-11 libqscintilla2-l10n mercurial mercurial-common python-iniparse python-nautilus python-pygments python-qscintilla2 tortoisehg <- there is no gnome-icon-theme-full
      Suggested packages:
        javascript-common qct kdiff3 kdiff3-qt kompare meld tkcvs mgdiff python-mysqldb ttf-bitstream-vera
      The following NEW packages will be installed:
     gir1.2-nautilus-3.0 libjs-jquery libjs-underscore libqscintilla2-11 libqscintilla2-l10n mercurial mercurial-common python-iniparse python-nautilus python-pygments python-qscintilla2 tortoisehg tortoisehg-nautilus <- there is no gnome-icon-theme-full
      0 upgraded, 13 newly installed, 0 to remove and 0 not upgraded.
      Need to get 5 835 kB of archives.
      After this operation, 29,3 MB of additional disk space will be used.
      Do you want to continue? [Y/n]y

After installation:
   apt-cache policy gnome-icon-theme-full
      gnome-icon-theme-full:
        Installed: (none)
        Candidate: 3.12.0-1ubuntu1
        Version table:
           3.12.0-1ubuntu1 0
           500 http://archive.ubuntu.com/ubuntu/ utopic/main i386 Packages

so gnome-icon-theme-full package is not installed (but gnome-icon-theme is preinstalled).

Norbert (nrbrtx) wrote :

Bug exists in Ubuntu Utopic 14.10 final.

Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 15.04 alpha2.

tags: added: vivid
Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 15.04 beta2.

Norbert (nrbrtx) on 2015-03-29
Changed in tortoisehg (Ubuntu):
status: Fix Released → Confirmed
Changed in hundredpapercuts:
status: New → Confirmed
Changed in tortoisehg (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
importance: Undecided → High
Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 15.04 final.

Norbert (nrbrtx) wrote :

Bug does not exist in Ubuntu 15.10 alpha.

Ludovico Cavedon (cavedon) wrote :

> it seems that gnome-icon-theme-full will not be installed. Tested on fresh-installed Ubuntu 14.10.
> ...
> apt-cache depends tortoisehg-nautilus
> tortoisehg-nautilus
> |Depends: gnome-icon-theme-full <- this dependency was missed
> Depends: gnome-icon-theme

Probably because gnome-icon-theme was installed already and it did not pulled gnome-icon-theme-full as well.
However I cannot add that unconditional dependency because it would break on Debian.

However I see
> Bug does not exist in Ubuntu 15.10 alpha.

So I guess it can be closed?

Ludovico Cavedon (cavedon) wrote :

>> Bug does not exist in Ubuntu 15.10 alpha.

> So I guess it can be closed?

Closing.

Changed in tortoisehg (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers