LXDE guest session shows error message "no session for pid <pid for lxsession>"

Bug #1273524 reported by Lyn Perrine on 2014-01-28
92
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Light Display Manager
Medium
Unassigned
1.18
Medium
Unassigned
One Hundred Papercuts
Medium
Unassigned
lightdm (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned
lxsession (Ubuntu)
Medium
Unassigned
Xenial
Undecided
Unassigned

Bug Description

EXPECTED RESULTS:
Log into guest session with no error messages.

ACTUAL RESULTS:
Upon log in to guest session, an error "no session for pid <pid for lxsession>" is printed.

STEPS TO REPRODUCE:
1. Using Lubuntu in trusty, utopic, or vivid with either real or virtual hardware, log into guest session.
2. After being logged in, see error message.

AFFECTED VERSIONS:
lightdm 1.10.0-0ubuntu3 to 1.12.1-0ubuntu1
---
ApportVersion: 2.14.1-0ubuntu3.5
Architecture: amd64
CurrentDesktop: LXDE
DistroRelease: Ubuntu 14.04
InstallationDate: Installed on 2013-10-18 (384 days ago)
InstallationMedia: Lubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016)
NonfreeKernelModules: wl
Package: lxsession
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.13.0-37.64-generic 3.13.11.7
Tags: trusty
Uname: Linux 3.13.0-37-generic x86_64
UpgradeStatus: Upgraded to trusty on 2014-04-18 (202 days ago)
UserGroups:

_MarkForUpload: True
---
ApportVersion: 2.14.1-0ubuntu3.5
Architecture: amd64
CurrentDesktop: LXDE
DistroRelease: Ubuntu 14.04
InstallationDate: Installed on 2013-10-18 (384 days ago)
InstallationMedia: Lubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016)
LightdmConfig:
 [SeatDefaults]
 greeter-session=lightdm-gtk-greeter
 user-session=Lubuntu
LightdmGreeterLog:
 ** (lightdm-gtk-greeter:1874): WARNING **: Failed to load user image: Failed to open file '/home/brendy/.face': No such file or directory
 g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
LightdmGreeterLogOld: ** (lightdm-gtk-greeter:2073): WARNING **: Failed to load user image: Failed to open file '/home/brendy/.face': No such file or directory
NonfreeKernelModules: wl
Package: lxsession
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 3.13.0-37.64-generic 3.13.11.7
Tags: trusty
Uname: Linux 3.13.0-37-generic x86_64
UpgradeStatus: Upgraded to trusty on 2014-04-18 (202 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo www-data
_MarkForUpload: True

Lyn Perrine (walterorlin) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1273524

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxsession (Ubuntu):
status: New → Confirmed

Does this bug prevent to log-in into the guest session?

Changed in lxsession (Ubuntu):
status: Confirmed → Incomplete
Lyn Perrine (walterorlin) wrote :

No this does not prevent logging into the session just prints an annoying error message.

It has a moderate impact on a core package.

Changed in lxsession (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Confirmed
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Medium
Lyn Perrine (walterorlin) wrote :

Today on my updated Utopic amd64 installatoin tihs bug is still around

tags: added: utopix
tags: added: utopic
removed: utopix
Lyn Perrine (walterorlin) wrote :

Also this does not seem to effect the guest session for openbox, but does for lubuntu-netbook session making it more likely this truely is in lxsession.

To reproduce in lubuntu-netbook select guest session as the user in lightdm and in the top panel of lightdm click what by default looks like the lxde logo and change to lubuntu netbook. Then the session logs in and you recieve the error message.

Is this a regression or still unfixed? Only Utopic? Also on real hardware?

It is on trusty and utopic. It is on real hardware and virtual machines. I think it is still unfixed.

dbp (dbpalan) wrote :

Confirmed Trusty still unfixed.

Walter Lapchynski (wxl) on 2014-11-03
Changed in lxsession (Ubuntu):
status: Confirmed → Triaged
Walter Lapchynski (wxl) on 2014-11-03
description: updated
summary: - guest seisson shows error message no seisson for pid xxxx
+ lxsession guest session shows error message "no session for pid <some
+ number>"

confirmed in vivid with 0.4.9.2+git20140410-0ubuntu3 (not surprising, this is the same version as utopic).

the pid is that of lxsession.

only interesting thing in ~/.cache/lxsession/Lubuntu/run.log is at the end:

    Openbox-message: Requested key "XF86 Terminal" does not exist on the display

    (openbox:2555): GLib-CRITICAL **: Source ID 6 was not found when attempting to remove it

These errors are not present in the same file in the normal user session.

Walter Lapchynski (wxl) on 2014-11-03
tags: added: vivid
description: updated
description: updated
summary: - lxsession guest session shows error message "no session for pid <some
- number>"
+ lxsession guest session shows error message "no session for pid <pid for
+ lxsession>"

it is notable that the guest session is ultimately specified by lightdm itself. however, i had no problems with xubuntu (utopic fwiw), so i can confirm that this is indeed a problem with how lightdm's guest session interacts with lxsession.

Walter Lapchynski (wxl) wrote :

@Brendan could you please `apport-collect` on this one and also include the aforementioned run.log?

Walter Lapchynski (wxl) wrote :

sigh. still can't link sourceforge bugs. this is filed upstream. https://sourceforge.net/p/lxde/bugs/702/

Walter Lapchynski (wxl) wrote :

confirmed NOT a problem in saucy with 0.4.9.2-0ubuntu6.

tail of ~/.cache/lxsession/Lubuntu/run.log includes:

    Openbox-message: Requested key "XF86 Terminal" does not exist on the display

but does NOT include:

    (openbox:2555): GLib-CRITICAL **: Source ID 6 was not found when attempting to remove it

so that may be a hint.

Walter Lapchynski (wxl) wrote :

i installed 0.4.9.2+git20140410-0ubuntu1 from trusty in a saucy system and i cannot confirm the bug.

i installed 0.4.9.2-0ubuntu6 from saucy on an utopic system and i can confirm the bug.

i'm starting to think the issue is lightdm, perhaps.

Walter Lapchynski (wxl) wrote :

i installed lightdm 1.8.4-0ubuntu1 from saucy (with lxsession 0.4.9.2-0ubuntu6) and i cannot confirm the bug.

i upgraded lxsession on that same system and i cannot confirm the bug.

long story short, regardless of lxsession version, the bug depends upon lightdm.

summary: - lxsession guest session shows error message "no session for pid <pid for
+ guest session shows error message "no session for pid <pid for
lxsession>"
Changed in lightdm:
status: New → Confirmed
affects: lightdm → lightdm (Ubuntu)
Changed in lightdm (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Walter Lapchynski (wxl) on 2014-11-03
description: updated
summary: - guest session shows error message "no session for pid <pid for
+ LXDE guest session shows error message "no session for pid <pid for
lxsession>"
Lyn Perrine (walterorlin) wrote :
Walter Lapchynski (wxl) wrote :

thx Brendan. don't see anything too weird. that Source ID line doesn't appear to be in there. dbus errors. could you `apport collect`?

apport information

tags: added: apport-collected
description: updated
Lyn Perrine (walterorlin) wrote :

apport information

description: updated

apport information

apport information

apport information

apport information

Changed in hundredpapercuts:
status: Confirmed → Triaged
Kyle Mallory (kyle-mallory) wrote :

I see this bug has been triaged. Is there a patch for it? I'm trying to build an information monitor/radiator machine, and am using lubuntu, lightdm, and guest accounts to autologin and open firefox in fullscreen mode to the radiator URL.

This particular bug (and the error dialog) is preventing the executiong of /usr/lib/lightdm/guest-session-auto.sh until after the dialog is cleared.

I'm happy to rebuild the package from source, if necessary.

Walter Lapchynski (wxl) wrote :

@kyle-mallory unfortunately no. it got rejected upstream for lacking information. currently, i'm trying to figure out whether or not lightdm, lxsession or both are the problem.

what i can tell you so far is someone tried to do it with lxdm and got the same problem on a regular account. lxdm has its own issues, so i'm not sure what we can conclude from that, but it sort of suggests the problem lies with lxsession.

since you have found out about the shell script not being triggered, can you tell me what's trying to execute it?

dbp (dbpalan) wrote :

Confirmed error message box is produced by openbox. Exact error message can be reproduced when the same command (captured by 'ps') was executed in a shell after killing the openbox process.

----------------

root@host# ps auxw | grep openbox
guest-e+ 32332 0.2 0.0 276904 10544 ? Sl 15:07 0:00 openbox --config-file /tmp/guest-ei83jC/.config/openbox/lubuntu-rc.xml
root 32463 0.0 0.0 11984 920 pts/2 S+ 15:07 0:00 grep --color=auto openbox

root@host# su - guest-tXsFUi
guest-tXsFUi@host:~$ killall openbox

guest-tXsFUi@host:~$ DISPLAY=:0 openbox --config-file /tmp/guest-tXsFUi/.config/openbox/lubuntu-rc.xml
Obt-Message: Xinerama extension is not present on the server
Obt-Message: Failed to open an Input Method
Openbox-Message: X server does not support locale.
Openbox-Message: Cannot set locale modifiers for the X server.
Openbox-Message: Requested key "XF86Terminal" does not exist on the display

----------------

But still no idea how to fix

ambossarm (ambossarm) wrote :

http://ubuntuforums.org/showthread.php?t=2178645 but the file that should be edited is not present in 1404

The only thing I found in a logfile:
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
/var/log/lightdm/x-0-greeter.log (END)

MOZGIII (mozgiii) wrote :

To me it seems to only be happening with Lubuntu session, not with LXDE.
I mean:

With installed lubuntu-core package:
lxsession -s Lubuntu -e LXDE # has described bug

With installed lxde package:
lxsession -s LXDE -e LXDE # does not have described behavior

By "does not have described behavior" I mean the sessions starts up without any messages.
I run this stuff in lxc container with trusty on both host/guest.

Lyn Perrine (walterorlin) wrote :

I get the same behavior of not having this error message in a plain lxde session but still get the same behavior on up to date vivid build.

To do this I ran sudo apt-get install lxde in vivid and then switched user to the guest session and then tried launched a guest session and did not get the message in plain lxde.

Russell Harper (eurorusty) wrote :

Can confirm on Lubuntu 15.04, clean install, issue is still there.

While the error message is shown, it prevents running of the script that warns about all files being temporary. When you close the error message, you get this warning right after. This rapid double interruption of an error followed by a warning is intimidating for guest users who may not be tech savvy.

On a slower machine, you can see this sequence of events leading up to the error message.

- login background displayed
- small rectangle for error message displayed, but no text
- desktop icons displayed (loaded from /skel)
- rectangle for error message gets larger, maybe adding borders
- custom background displayed (loaded from /skel)
- full error message with text and OK button displayed

Don't know if the above helps any, but the error message appears to be one of the first things that happens during the boot process, with its rendering delayed by other background tasks.

agentcobra (agentcobra57) wrote :

Hello,
I have the same issue with a fresh install too

agentcobra

I had the same issues on a fresh 15.10 install.
I seem to have gaffer-tape-solved it by adding rights in apparmor.
IN:
/etc/apparmor.d/lightdm-guest-session:
ADD:
/etc/xdg/lxsession/Lubuntu/* cx,

Leon (lanospam-ubuntu) wrote :

THANKS! This "gaffer-tape" solution resolved the issue for me in 15.10 and AFAIK caused no adverse effects.

Gunnar Hjalmarsson (gunnarhj) wrote :

Nice solution (workaround?), Sverker. I have called the lightdm developer's attention to it via a merge proposal.

Changed in lightdm (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Triaged → In Progress
Changed in lightdm:
status: New → Fix Committed
milestone: none → 1.19.0
Changed in lightdm (Ubuntu):
status: In Progress → Fix Committed
Changed in lightdm (Ubuntu Xenial):
status: New → Fix Committed
importance: Undecided → Medium
Changed in lightdm:
importance: Undecided → Medium
Changed in lightdm:
status: Fix Committed → Fix Released
Gunnar Hjalmarsson (gunnarhj) wrote :

Fixed in lightdm 1.19.0-0ubuntu1

Changed in lightdm (Ubuntu):
status: Fix Committed → Fix Released
Gunnar Hjalmarsson (gunnarhj) wrote :

The rule in /etc/apparmor.d/lightdm-guest-session has proved to break AppArmor, and thus can't be added, so unfortunately this bug is still not fixed.

Changed in lightdm (Ubuntu):
assignee: Gunnar Hjalmarsson (gunnarhj) → nobody
status: Fix Released → Confirmed
Changed in lightdm (Ubuntu Xenial):
status: Fix Committed → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxsession (Ubuntu Xenial):
status: New → Confirmed
Changed in lightdm:
status: Fix Released → Triaged
milestone: 1.19.0 → none
Gunnar Hjalmarsson (gunnarhj) wrote :

I made a couple of observations which may or may not be useful.

When starting a guest session in Lubuntu, these lines show up in lightdm.log:

[+36.45s] DEBUG: Seat seat0 changes active session to
[+36.45s] CRITICAL: session_get_login1_session_id: assertion 'session != NULL' failed

They are not present when starting a guest session in Ubuntu. Please see attachment for context.

The "Seat seat0 changes active session to " message is written by login1_active_session_changed_cb() in src/lightdm.c. Apparently the session ID isn't passed correctly to that function.

Another thing I noticed is that the "no session for pid ..." message does not appear if I make this change:

--- /etc/apparmor.d/abstractions/lightdm.orig
+++ /etc/apparmor.d/abstractions/lightdm
@@ -54,7 +54,7 @@
   @{PROC}/ati rm,
   @{PROC}/ati/** rm,
   @{PROC}/sys/vm/overcommit_memory r,
- owner @{PROC}/** rm,
+ @{PROC}/** rm,
   # needed for gnome-keyring-daemon
   @{PROC}/*/status r,
   # needed for bamfdaemon and utilities such as ps and killall

But that would give the guest user access to everything in the /proc directory, also processes which are owned by other users. Probably not a good idea from a security POV.

George Hawkins (ubuntu-8n) wrote :

I have experienced this problem trying to start lxde using the TightVNC vncserver from systemd.

The process with the displayed PID is always lxsession.

I resolved it by adding PAMName=login to my unit file.

This suggestion came from https://bugs.archlinux.org/task/42425

Note: I did not have to specify "-fg" to vncserver, as also suggested in this bug (this option is anyway not supported by TightVNC).

Carlos Renê (slipttees) wrote :

Lubuntu 16.04.3 have same problem! :/

Markus Kwaśnicki (mrkskwsnck) wrote :

Sadly, I confirm this bug still exists in Lubuntu 18.04.1 :-(

Alex Barroso (nenillo) wrote :

Any workaround? Tried editing /etc/apparmor.d/lightdm-guest-session with the suggested change but doesn't work

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers