Add a menu item to dump terminal text mssage

Bug #1264034 reported by Yuan-Chen Cheng
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Humpolec project
Medium
Yuan-Chen Cheng

Bug Description

It's hard for users to do report bug unless he have a way to dump terminal text message and related system information.

It should have all terminal content and also some information for the application, like

1. device.
2. ROM version
3. apk version

Related branches

Changed in humpolec:
assignee: nobody → Yuan-Chen Cheng (ycheng-twn)
importance: Undecided → Medium
Changed in humpolec:
status: New → Fix Committed
Rex Tsai (chihchun)
Changed in humpolec:
milestone: none → m6-update
Revision history for this message
Ethan Chang (ethan.chang) wrote :

I check the location of log, it stored under "/storage/emulated/legacy/" , but UbuntuDuallboot shows that log is saving at "/storage/emulated/0/".

Changed in humpolec:
status: Fix Committed → Confirmed
Revision history for this message
Yuan-Chen Cheng (ycheng-twn) wrote :

There seems to be something we don't understand about how android handle directory.

But since the output file will be stored on the /sdcard directory (the code use getExternalDirectory
to find the location to store file) so I'll refine the message after code frozen due to milestone release.

Changed in humpolec:
status: Confirmed → In Progress
milestone: m6-update → none
Rex Tsai (chihchun)
Changed in humpolec:
milestone: none → m7-update
Changed in humpolec:
status: In Progress → Fix Committed
Revision history for this message
Ethan Chang (ethan.chang) wrote :

Verified in M7 image.

tags: added: cqa-verified
Changed in humpolec:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers