Bad LibreOffice systray quick start icon

Reported by Bruce Hohl on 2011-04-17
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
LibreOffice Productivity Suite
New
Undecided
Unassigned
human-icon-theme
Undecided
Unassigned
libreoffice (Ubuntu)
Low
Unassigned

Bug Description

The LibreOffice systray quick start icon (Gnome Classic session) includes a background and therefore fails to fit with user selected theme color. The icon is also is from an older theme used years ago. Ubuntu 11.04 + LibreOffice 3.3.2 (earlier versions as well).

Bruce Hohl (brucehohl) wrote :

Created attachment 46217
Screenshot

When starting LibreOffice 3.3.2 a small OpenOffice.org logo appears in the top left corner. It disappears again after a few seconds. There is no OpenOffice.org installation on my Kubuntu 11.04 netbook.

Found out when starting up Impress the logo stays there during the startup wizard.

Is this something specific to Ubuntu/Kubuntu?
If so, you might want to report the bug there?

Sorry, can't check, have only Kubuntu installed

@bjoern: Can you verify it please? Thank you!

Created attachment 46398
screenshot of double bug

All screens at startup show the OpenOffice.org logo, once fully active only LibreOffice logos appear.

Starting up *OpenOffice.org* on a Fedora machine the same thing happens, the "old" OO.o is during startup only replaced by the "new" one, also on all other startup screens.
This may help you looking where to find your solution, dunno.

Vish (vish) on 2011-05-15
affects: hundredpapercuts → libreoffice
affects: libreoffice → df-libreoffice

please notify me if the artwork has been updated for inclusion in the packages.

Changed in df-libreoffice:
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
importance: Undecided → Low
Vish (vish) wrote :

wrt to the icon /images_human/res/mainapp_16.png needs to be replaced with the attached one.

As for the background color, it is a known issue > Bug #403135 , needs fixing in LibO

Changed in human-icon-theme:
status: New → Invalid
Changed in libreoffice (Ubuntu):
importance: Undecided → Low
status: New → Triaged

In LibO artwork master the icon is already replaced with this one. Vish, shall I change it to the one you provided?

Vish (vish) wrote :

Yea, it needs to be replaced with the one I've posted above.
That icon you linked is the High-Contrast version, why was that done ?

Fixed upstream in commit 69f7ca485582e5daab0fe726f0f60475d9ab22be. Oxygen theme contained the same icon, updated it as well.

Changed in df-libreoffice:
status: New → Fix Committed
Changed in libreoffice (Ubuntu):
status: Triaged → Fix Committed

I'm out of the office until 1st August.

On 15 May 2011, at 09:48, Vish <email address hidden> wrote:

> ** Project changed: hundredpapercuts => libreoffice
>
> ** Also affects: libreoffice (Ubuntu)
>   Importance: Undecided
>       Status: New
>
> ** Project changed: libreoffice => df-libreoffice
>
> --
> You received this bug notification because you are a member of
> Papercutters, which is subscribed to One Hundred Paper Cuts.
> https://bugs.launchpad.net/bugs/763892
>
> Title:
>  Bad LibreOffice systray quick start icon
>
> Status in LibreOffice Productivity Suite:
>  New
> Status in “libreoffice” package in Ubuntu:
>  New
>
> Bug description:
>  The LibreOffice systray quick start icon (Gnome Classic session)
>  includes a background and therefore fails to fit with user selected
>  theme color.  The icon is also is from an older theme used years ago.
>  Ubuntu 11.04 + LibreOffice  3.3.2 (earlier versions as well).

Marcus Haslam (marcus-haslam) wrote :

I'm out of the office until 1st August.

On 17 Apr 2011, at 20:16, Bruce Hohl <email address hidden> wrote:

> ** Attachment added: "Screen shot of bad icon from 11.04 beta."
>   https://bugs.launchpad.net/bugs/763892/+attachment/2055767/+files/Screenshot.png
>
> --
> You received this bug notification because you are a member of
> Papercutters, which is subscribed to One Hundred Paper Cuts.
> https://bugs.launchpad.net/bugs/763892
>
> Title:
>  Bad LibreOffice systray quick start icon
>
> Status in One Hundred Paper Cuts:
>  New
>
> Bug description:
>  The LibreOffice systray quick start icon (Gnome Classic session)
>  includes a background and therefore fails to fit with user selected
>  theme color.  The icon is also is from an older theme used years ago.
>  Ubuntu 11.04 + LibreOffice  3.3.2 (earlier versions as well).

I'm out of the office until 1st August.

On 17 Apr 2011, at 20:16, Bruce Hohl <email address hidden> wrote:

> Public bug reported:
>
> The LibreOffice systray quick start icon (Gnome Classic session)
> includes a background and therefore fails to fit with user selected
> theme color.  The icon is also is from an older theme used years ago.
> Ubuntu 11.04 + LibreOffice  3.3.2 (earlier versions as well).
>
> ** Affects: hundredpapercuts
>     Importance: Undecided
>         Status: New
>
> --
> You received this bug notification because you are a member of
> Papercutters, which is subscribed to One Hundred Paper Cuts.
> https://bugs.launchpad.net/bugs/763892
>
> Title:
>  Bad LibreOffice systray quick start icon
>
> Status in One Hundred Paper Cuts:
>  New
>
> Bug description:
>  The LibreOffice systray quick start icon (Gnome Classic session)
>  includes a background and therefore fails to fit with user selected
>  theme color.  The icon is also is from an older theme used years ago.
>  Ubuntu 11.04 + LibreOffice  3.3.2 (earlier versions as well).

Is this still a problem with 3.4.2? There were several fixes on old OOo logos.

But here are some more left-overs:

default_images/svx/res/vendor01h.png
default_images/svx/res/vendor01.png
default_images/framework/res/logo.png

Just installed 3.4, same bug.

The default_images/svx/res stuff seems to be solved with fdo#33229, but

 default_images/framework/res/logo.png

is still there on master:

http://cgit.freedesktop.org/libreoffice/core/plain/default_images/framework/res/logo.png

Reassigning to Christoph, please reassign again to somebody on the design team to create (or find) a icon with our branding to commit the change.

No need to backport to 3.4 IMHO.

BTW: Cant reproduce with 3.4.3-3ubuntu2 on oneiric. Still the icon should be replaced anyway even if it does not show up as shown in the screenshot.

(In reply to comment #9)
> http://cgit.freedesktop.org/libreoffice/core/plain/default_images/framework/res/logo.png

> Reassigning to Christoph, please reassign again to somebody on the design team
> to create (or find) a icon with our branding to commit the change.

Will do, but before - any hint where this logo is actually used? Never saw it before ... According opengrok it seems to be a status bar image, defined here:
http://opengrok.libreoffice.org/xref/core/framework/source/classes/resource.src

Any further idea?

still open on kde

Changed in df-libreoffice:
assignee: Björn Michaelsen (bjoern-michaelsen) → nobody
importance: Low → Unknown
status: Fix Committed → Unknown
Changed in df-libreoffice:
importance: Unknown → Low
status: Unknown → Confirmed

removing link to upstream bug https://bugs.freedesktop.org/show_bug.cgi?id=36741 as this is a different icon:
ooo_custom_images/oxygen/res/mainapp_16.png
which is fixed in 3.5.0.

removing link to kde icon bug at fdo.

.

Changed in df-libreoffice:
importance: Low → Undecided
status: Confirmed → New

Is this bug fixed? Or there's something else that needs to be done?

fix released with 3.5.0 series.

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.