Icons of usb storage devices shoud be different from internal hdd icons

Reported by Jurgis Pralgauskis on 2008-07-31
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bisigi Project
Medium
François Vogelweith
Breathe Icons
Undecided
Unassigned
Humanity
Undecided
Unassigned
human-icon-theme
Undecided
Unassigned
breathe-icon-theme (Ubuntu)
Undecided
Andrew Starr-Bochicchio
gnome-icon-theme (Ubuntu)
Undecided
Unassigned
industrial-icon-theme (Ubuntu)
Undecided
Unassigned
tangerine-icon-theme (Baltix)
Undecided
Unassigned
tangerine-icon-theme (Ubuntu)
Undecided
Unassigned
tango-icon-theme (Baltix)
Undecided
Mantas Kriaučiūnas
tango-icon-theme (Ubuntu)
Undecided
Unassigned
xfce4-icon-theme (Ubuntu)
Undecided
Unassigned

Bug Description

usb disc icons shoud be different from ordinary hdd icons,

because it would be more easy to find usb when needing to unmount (or otherwise use) it on desktop/mycomputer/"Disk mounter applet"

why SD cards have their special icon, and usb discs - don't ?

Chris Coulson (chrisccoulson) wrote :

This isn't a bug against gnome-libs, so I'm marking that task as invalid. The disc icons are already different, but only if the icon set you are using contains the necessary icons (named correctly).

Which icon set are you using?

Thanks

Changed in gnome-libs:
status: New → Invalid
status: New → Incomplete
Chris Coulson (chrisccoulson) wrote :

FYI - The icon names used for USB drives are "drive-harddisk-usb" and "drive-removable-media-usb" depending on whether the media is mounted / unmounted or not.

If these icons do not exist, then the fall-back icons "drive-harddisk" and "drive-removable-media" are used, which are the standard hard-disk icons you see. It is the responsibility of the icon theme maintainers to ensure these icons exist and are named correctly.

If you are using an icon theme that is packaged by Ubuntu, then this bug report should be assigned to that theme. If not, then you should contact the developer of the icon theme.

Hope that helps

Mantas Kriaučiūnas (mantas) wrote :

Chris Coulson wrote on 2008-07-31:
> FYI - The icon names used for USB drives are "drive-harddisk-usb" and "drive-removable-media-usb"

Icons with these names exist only in Human icon theme :( All other icon themes I've checked doesn't have such icons, but has gnome-dev-harddisk-usb and gnome-dev-removable-usb. So, it seems majority of icon themes in Ubuntu are buggy, right?
Maybe we should simply create a symlinks to gnome-dev-harddisk-usb and gnome-dev-removable-usb with names "drive-harddisk-usb" and "drive-removable-media-usb" in each icon-theme packages?

Changed in gnome-libs:
assignee: nobody → mantas
status: Invalid → New
Rodney Dawes (dobey) wrote :

It really depends on what the usb "disk" is. For usb memory devices (not card readers), the appropriate naming scheme is media-flash-usb-$make-$model. For usb memory devices that are memory cards, the mounted icon names should be media-flash-$type-$make-$model (or simply media-flash-$type). And for usb devices that are actually hard disks, the drive-harddisk icon should be used (one could add the -usb classifier, but it's generally not important information for external hard disks that are usb. Sticking a usb icon on a harddisk isn't particularly useful information in the icon, from a usability perspective.

So really, this bug (and others like it) should probably be filed against whatever package is providing the drive-harddisk-usb icon name, for usb storage devices that aren't hard disks.

Changed in zgegball-themes:
assignee: nobody → ZgegBall (zgegball)
Mantas Kriaučiūnas (mantas) wrote :

Hi Rodney and oher GNOME developers,

Rodney Dawes wrote on 2009-02-21:
> For usb memory devices that are memory cards, the mounted icon names should be media-flash-$type-$make-$model (or simply media-flash-$type).

I've inserted SD MMC card in my computer and noticed, that GNOME always uses media-flash.svg icon instead of media-flash-mmc.svg, I also tried media-flash-sd_mmc.svg, media-flash-sdmmc.svg and media-flash-sd-mmc.svg but without success (I use Ubuntu 9.04). Could you tell me from where GNOME gets $type and what $type should be for SD MMC cards? I thought, that GNOME gets storage type from HAL, so, lshal command shows this info for my SD MMC card: storage.bus = 'mmc' and storage.drive_type = 'sd_mmc'

Also I've noticed, that in the majority of themes unmounted SD MMC card has the same icon as hard disk partition, I've added drive-removable-media-flash.svg and now GNOME uses this icon for all memory cards, could anybody tell me what exact names I should use for exact types of memory cards, for example CompactFlash, MemoryStick, SD MMC , etc?

Btw, it seems this bug is related to bug #436462 (have different icons for usb hardisks and pendrives).

Vish (vish) wrote :

humanity-unr is not a theme

Changed in humanity-unr:
status: New → Invalid
Vish (vish) wrote :

Humanity-dark is basically contains *only* panel icons.

Changed in humanitydark:
status: New → Invalid

Hmm... I wonder if maybe there is an issue in icon-naming-utils. For instance, Breathe has a gnome-dev-removable-usb but gnome-dev-harddisk-usb is a link to drive-harddisk generated by icon-naming-utils.

Either way, like Rodney said above, I think the root problem is whatever packages are providing the drive-harddisk-usb icon name, for usb storage devices that aren't hard disks.

Changed in breathe-icon-theme (Ubuntu):
status: New → Incomplete
Changed in breathe-icon-set:
status: New → Incomplete
summary: - usb disc icons shoud be different from ordinary hdd icons
+ Icons of usb storage devices shoud be different from internal hdd icons
Mantas Kriaučiūnas (mantas) wrote :

Andrew Starr-Bochicchio wrote on 2009-10-05:
> maybe there is an issue in icon-naming-utils. Breathe has a gnome-dev-removable-usb,
> but gnome-dev-harddisk-usb is a link to drive-harddisk generated by icon-naming-utils.

icon-naming-utils is a script for maintaining *backwards* compatibility with old desktop icon themes, while migrating to the names specified in the Icon Naming Specification. According to the Specification devices are named without gnome-dev-* , so, icon themes should use name drive-removable-media-usb instead of gnome-dev-removable-usb, media-flash-cf instead of gnome-dev-media-cf, etc, look at http://standards.freedesktop.org/icon-naming-spec/icon-naming-spec-latest.html#devices

icon-naming-utils are for generating legacy gnome-dev-* symlinks from standard icon names, listed in the Specification, but not for generating drive-removable* or media-flash* from legacy gnome-dev-*, see legacy-icon-mapping.xml (/usr/share/icon-naming-utils/legacy-icon-mapping.xml)

Finally I completely understood how to solve this big issue:
1. At first we need to fix icon themes to use standard icon names, listed at http://standards.freedesktop.org/icon-naming-spec/icon-naming-spec-latest.html#devices instead of legacy gnome-dev-* names ! Look at https://bugzilla.gnome.org/show_bug.cgi?id=506532#c6 for more info.
2. When icon themes will use standard names then we could fix second part of this issue - gvfs libraries, which use the drive-harddisk-usb icon name, for usb storage devices that aren't hard disks, see http://git.gnome.org./cgit/gvfs/tree/monitor/hal/ghaldrive.c and http://git.gnome.org./cgit/gvfs/tree/monitor/hal/ghalmount.c

Changed in breathe-icon-set:
status: Incomplete → New
Changed in breathe-icon-theme (Ubuntu):
status: Incomplete → New
Vish (vish) wrote :

This was already fixed in Humanity!

Changed in humanity:
status: New → Fix Released
Vish (vish) wrote :

In humanity 0.4.1-0ubuntu1 , you'll notice that the icons for usb storage devices and the internal drives are completely different

Vish (vish) wrote :

Chris coulson wrote:
> FYI - The icon names used for USB drives are "drive-harddisk-usb" and "drive-removable-media-usb" depending on whether the media is mounted / unmounted or not.

This is not true.

In jaunty :
drive-harddisk-usb , and all drive-* labels are used for unmounted drives
gnome-dev-harddisk-usb and all gnome-* > was used for mounted drives

I am very sure , of this [gnome-* and dev-* difference] since this was how it always worked for me in Jaunty.

But , In karmic:
drive-harddisk-usb > is used for external usb storage devices
drive-removable-media-usb > is used for pen drives

Now icons seem to be using only the drive-* labels , and there is no distinction between the mount and unmount states , also see bug > Bug #406377

Ideally, the gnome-dev-* icons need to be used for the mount states and the drive-* labels for the unmount states.

Mac_v, please don't tell lies and don't mess this bug with incorrect comments!

gnome-dev-* icons are not used at all since 2008 (and should not be used!),
these names are only for old GNOME 2.20 and other legacy software.
Please read the gvfs sources and Icon Naming specifications before writing
any comments to this bug. Also you can read https://bugzilla.gnome.org/show_bug.cgi?id=506532#c6
If you are testing some icon themes then please remove (or rename)
gnome-dev-* icons and symlinks before testing, it's too hard understand
when there is a symlink mess in theme...

On Wed, Oct 07, 2009 at 07:55:14AM -0000, mac_v told such lies:
> In jaunty :
> drive-harddisk-usb , and all drive-* labels are used for unmounted drives
> gnome-dev-harddisk-usb and all gnome-* > was used for mounted drives
[..]
> Ideally, the gnome-dev-* icons need to be used for the mount states and
> the drive-* labels for the unmount states.

--
Labanaktis/Good luck,
Mantas Kriaučiūnas Jabber ID: <email address hidden> GPG ID: 43535BD5
Public organization "Open Source for Lithuania" - www.akl.lt
Geriausios biuro programos verslui ir namams - http://openoffice.lt
Naudok Baltix GNU/Linux sistemą savo kompiuteryje - http://baltix.lt

Vish (vish) wrote :

On Wed, 2009-10-07 at 08:28 +0000, Mantas Kriaučiūnas wrote:
> Mac_v, please don't tell lies and don't mess this bug with incorrect
> comments!

Think twice before *you* comment!

I have no reason to lie! read my comment *carefully* ! i only said it
worked for me!

It worked for me using the gnome-* labels on a
- up till hardy
- and on fresh installed intrepid system and also when upgraded to
jaunty.

while my karmic is again a fresh install but uses the device-* label

The gnome-dev-* icon labels worked for me! and i can comment only on
that.

Vish (vish) wrote :

Ok, confirmed with Rodney Dawes :
 drive-* used for unmounted drives
 media-* used for mounted drives

except internal partitions , which use device-harddisk for both mounted and unmounted states.

Vish (vish) wrote :

correction> drive-harddisk for internal partitions

C.Kontros (coryisatm) on 2009-10-07
Changed in breathe-icon-theme (Ubuntu):
assignee: nobody → C.Kontros (coryisatm)
Rodney Dawes (dobey) wrote :

I can't even tell what this bug is about any more. It looks like someone decided to hijack it for something other than what the original reporter filed it for, and what the original reporter wanted has never been clarified.

Vish (vish) on 2009-10-08
Changed in breathe-icon-set:
assignee: nobody → mac_v (drkvi-a)
Vish (vish) wrote :

Fix committed in rev 128. [ lp:breathe-icon-set ]

Changed in breathe-icon-set:
assignee: mac_v (drkvi-a) → nobody
status: New → Fix Committed
Changed in zgegball-themes:
importance: Undecided → Medium
status: New → In Progress
Changed in breathe-icon-theme (Ubuntu):
assignee: C.Kontros (coryisatm) → Andrew Starr-Bochicchio (andrewsomething)
status: New → In Progress
Rodney Dawes (dobey) wrote :

Would be nice if the original reporter could comment. I don't remember what exactly the original report was against, but I'm inclined to mark them all Incomplete until the ORIGINAL REPORTER responds, and clarifies what the report is actually about.

Changed in tango-icon-theme (Ubuntu):
status: New → Incomplete
Rodney Dawes (dobey) wrote :

Also, please don't hijack bugs like was done here. It just adds confusion. If you experience a bug, file a new one! If it's the same bug, then one of the bugs will be marked as a duplicate of the other. This bug is incredibly hard to manage now, because there are so many (most likely) irrelevant comments, and it has had lots of projects/packages added to the also affects list, which apparently kills the LP ajaxification of the affects list area.

Changed in gnome-icon-theme (Ubuntu):
status: New → Invalid
Changed in xfce4-icon-theme (Ubuntu):
status: New → Invalid
Changed in tango-icon-theme (Baltix):
status: New → Incomplete
Rodney Dawes (dobey) on 2009-10-09
Changed in tangerine-icon-theme (Ubuntu):
status: New → Invalid
Changed in tangerine-icon-theme (Baltix):
status: New → Invalid
Changed in industrial-icon-theme (Ubuntu):
status: New → Invalid
Alessandro Ranaldi (ciaolo) wrote :

For breathe-icon-theme (that I am using).

I browsed the icons because I had a problem (now solved) and noticed that there is an icon with a pendrive. Why if i insert a pendrive its icon is a tablet with a usb symbol, and not that icon? It would be great if that icon was used, it is very well done!

Sorry for my english, I hope you understand my request.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package breathe-icon-theme - 0.51.1

---------------
breathe-icon-theme (0.51.1) karmic; urgency=low

  * debian/rules: Explicitly call dh_icons. (LP: #262723)
  * debian/links: Add symlink for for nm-no-connection (LP: #429449),
    drive-*-usb (LP: #253599), and media-flash-* (LP: #417294).

 -- Andrew Starr-Bochicchio <email address hidden> Sat, 10 Oct 2009 00:27:18 -0400

Changed in breathe-icon-theme (Ubuntu):
status: In Progress → Fix Released

On Sat, Oct 10, 2009 at 4:32 AM, Alessandro Ranaldi
<email address hidden> wrote:
> For breathe-icon-theme (that I am using).
>
> I browsed the icons because I had a problem (now solved) and noticed
> that there is an icon with a pendrive. Why if i insert a pendrive its
> icon is a tablet with a usb symbol, and not that icon? It would be great
> if that icon was used, it is very well done!

@ Alessandro

That was a different bug, but it was fixed in the same upload that
closed this one.

Alessandro Ranaldi (ciaolo) wrote :

Thank you, that's cool!

Also, there is problem with System -> Administration and System -> Preferences, icons not exist

C.Kontros (coryisatm) wrote :

@Sardorbek

That's a separate issue where Canonical have decided to turn off: /desktop/gnome/interface/menus_have_icons. (something i totally disagree with)

Going into gconf and ticking the checkbox turns them back on.

Vish (vish) wrote :

Sardorbek Pulatov > thats a different bug >Bug #407621

Fix for karmic version

Changed in zgegball-themes:
status: In Progress → Fix Released
Vish (vish) wrote :

This bug was fixed in the package breathe-icon-theme - 0.51.1

---------------
breathe-icon-theme (0.51.1) karmic; urgency=low

  * debian/rules: Explicitly call dh_icons. (LP: #262723)
  * debian/links: Add symlink for for nm-no-connection (LP: #429449),
    drive-*-usb (LP: #253599), and media-flash-* (LP: #417294).

 -- Andrew Starr-Bochicchio <email address hidden> Sat, 10 Oct 2009 00:27:18 -0400

Changed in breathe-icon-set:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.