Human (and gnome) theme have non-translatable emblem names.

Bug #172353 reported by Sergio Zanchetta on 2007-11-27
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Icon Theme
Expired
Medium
Ubuntu Translations
Low
Unassigned
human-icon-theme
Undecided
Unassigned
gnome-icon-theme (Ubuntu)
Undecided
Martin Pitt
human-icon-theme (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Icon emblem names (using theme human and gnome) in Nautilus (Right-click on a file,->Properties->Emblems and Edit->Backgrouns and emblems->Emblems in a folder) are not translated in Italian language.

In rosetta there is a translation package for gnome-icon-theme
https://translations.launchpad.net/ubuntu/gutsy/+source/gnome-icon-theme/+pots/gnome-icon-theme/it/+translate?start=0
and it works for Gnome theme and Tango theme, but there is no pot files for human-icon-theme in Rosetta itself.

Paolo Naldini (hattory) on 2007-11-27
Changed in rosetta:
status: New → Confirmed
Changed in gnome-icon-theme:
status: New → Confirmed
Sergio Zanchetta (primes2h) wrote :

Could someone give a feedback if it happens with other languages?

Thanks.

Thank you for your bug. What version of Ubuntu do you use?

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete

Gutsy, fully updated, but this problem occours since Dapper (If I correctly
remember).

And it is still present in Hardy updated today.

2008/3/18, Sebastien Bacher <email address hidden>:
>
> Thank you for your bug. What version of Ubuntu do you use?
>
> ** Changed in: nautilus (Ubuntu)
> Importance: Undecided => Low
> Assignee: (unassigned) => Ubuntu Desktop Bugs (desktop-bugs)
> Status: New => Incomplete
>
>
> --
> Non-translatable emblem names.
> https://bugs.launchpad.net/bugs/172353
> You received this bug notification because you are a direct subscriber
> of the bug.
>

not due to the gio changes then

Changed in nautilus:
status: Incomplete → Confirmed
Sergio Zanchetta (primes2h) wrote :

In Hardy emblems are now accessible by Edit->Background and emblems (maybe symbols)->Emblems.
They are still not translated, except for the last one, "Erase", that is translated "Cancella" correctly.

Sergio Zanchetta (primes2h) wrote :

UPDATE:
There is another one correctly translated.
It's "Downloaded"->"Scaricati"

Others are still in English.

Maurizio Moriconi (bugman) wrote :

With new LangPack in Hardy simbols are translated in italian correctly.

For hardy the bug is fixed with new langpack (2008-06-28)

Can someone testing with Gusty?

Maurizio Moriconi (bugman) wrote :

Sorry.

The new langpack tested is on a ppa repository and not come in hardy-updates.

Attending that new langpack coming to hardy (last is in 2008-05)

Maurizio Moriconi (bugman) wrote :
Aldo Latino (aldolat) wrote :

Yes, this repository do not update the translation.

Sergio Zanchetta (primes2h) wrote :

It doesn't work for me too.
I updated langpack from repository provided by Maurizio but no luck, emblems are still in english.
I tried with 2 different PC.

Sergio Zanchetta (primes2h) wrote :

Ok, I think that Maurizio and I probably found out where the bug is.

1) emblems translated strings are in gnome-icon-theme.
2) with human-icon-theme these strings remain untranslated.
3) installing tango-icon-theme, strings are correctly translated indipendently from which set of icons is selected, and emblem icons are the tango one.

so, probably human-icon-theme doesn't point to gnome-icon-theme strings correctly.

Not a nautilus bug, I change it with human-icon-theme

Changed in rosetta:
status: Confirmed → Invalid
Sergio Zanchetta (primes2h) wrote :

I think I found out where the problem is.

human-icon-theme package is not set up for translation of its icons.
gnome-icon-theme instead is internally structured to be translated.

tango-icon-theme and others doesn't have any problems because they fallback to gnome icons and then to its emblems translation.
(human-icon-theme has its icons set instead)

So this bug should also appear with other languages.

May someone give some feedback about it?
Thanks.

Sergio Zanchetta (primes2h) wrote :

I confirm it on Intrepid.
Emblems are still not translated.

AlfaOmega08 (alfaomega08) wrote :

2008-08-26 on my Hardy setup emblems are partially translated (money, danger, art, photo...)

Sergio Zanchetta (primes2h) wrote :

Which of them are translated exactly?

Sergio Zanchetta (primes2h) wrote :

@ AlfaOmega08

Which of them are translated exactly?

What set of icons are you using?

description: updated

Attached human-icon-theme debdiff for Jaunty.

There is just one emblem 'default' left, but it comes from gnome-icon-theme that need to be patched.

Martin Pitt (pitti) on 2009-01-26
Changed in human-icon-theme:
status: New → Invalid
Changed in gnome-icon-theme:
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package human-icon-theme - 0.31

---------------
human-icon-theme (0.31) jaunty; urgency=low

  [ Sergio Zanchetta ]
  * Setting up emblems translations to fix LP: #172353
  * scalable/emblems/ and 48x48/emblems/: Added *.icon.in files
    to make emblems translatable
  * scalable/emblems/Makefile.am and
    48x48/emblems/Makefile.am (icon_in_files): Added *.icon.in files
  * po/POTFILES.in: added *.icon.in file links to update .po files

  [ Martin Pitt ]
  * debian/control: Update libmagick9-dev -> libmagickcore-dev build
    dependency.
  * debian/control.in: Fix Section.
  * debian/control.in: Update Standards-Version (no changes
    necessary).
  * Drop superfluous debian/watch, this is a native package.

 -- Martin Pitt <email address hidden> Mon, 26 Jan 2009 10:41:03 +0100

Changed in human-icon-theme:
status: Confirmed → Fix Released
Sergio Zanchetta (primes2h) wrote :

@Martin
I reopen this because there is an non-translatable emblem left in nautilus that comes from gnome-icon-theme.

It's "default" and it is shown along with "Downloads" and "Erase" even using human theme.

But while the last two are translatable, "default" doesn't. (Note it's not in capital letter).

I'm preparing a debdiff for gnome-icon-theme to fix this, and I'll upload it to upstream too. (I'll open a bug upstream ASAP)

Changed in gnome-icon-theme:
status: Invalid → New
Sergio Zanchetta (primes2h) wrote :

gnome-icon-theme debdiff for Jaunty

Changed in gnome-icon-theme:
assignee: nobody → pitti
Martin Pitt (pitti) wrote :

Ugh, that took me a while to reduce the 2.9 MB debdiff with lots of build-time stuff to the root changes (16 kB).

Attached, I hope I got it alright. At least the package builds fine and produces/installs proper .icon files.

Can you please forward this upstream, too?

Martin Pitt (pitti) wrote :

Uploaded.

Changed in gnome-icon-theme:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-icon-theme - 2.24.0-0ubuntu2

---------------
gnome-icon-theme (2.24.0-0ubuntu2) jaunty; urgency=low

  * Add 03-update-translatable-emblems.patch: Made some emblems
    translatable (LP: #172353):
    - scalable/emblems/: Added .icon.in files for 'default' and
      'system' emblems
    - 32x32/emblems/: Added *.icon.in files
    - scalable/emblems/Makefile.am and 32x32/emblems/Makefile.am
      (icon_in_files): Added *.icon.in files
    - po/POTFILES.in: added *.icon.in file links to update .po files

 -- Sergio Zanchetta <email address hidden> Wed, 04 Feb 2009 12:08:18 +0100

Changed in gnome-icon-theme:
status: Fix Committed → Fix Released
Sergio Zanchetta (primes2h) wrote :

I forwarded the patch upstream.

Thank you very much. :-)

description: updated
Changed in gnome-icon-theme:
status: Unknown → New
Sergio Zanchetta (primes2h) wrote :

There are still two emblem (System and Default) not translatable due to gnome-icon-them not patched upstream (and so po are not updated).

BTW, In Lucid there is also a Videos emblem not translated.

David Planella (dpm) on 2010-01-29
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Low
Changed in gnome-icon-theme:
importance: Unknown → Medium
Gabor Kelemen (kelemeng) on 2011-07-10
Changed in ubuntu-translations:
status: Triaged → Fix Released
Curtis Hovey (sinzui) on 2011-11-11
no longer affects: launchpad
Changed in gnome-icon-theme:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.