Stitch fails when '&' character in Windows user name

Bug #791677 reported by Dick Holford on 2011-06-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Hugin
Low
Unassigned

Bug Description

Trying to use freshly installed Hugin 2011 under Win7 Home for stitching scanned images. My 'user' is "Anne & me". Something in Hugin is trying to use this in a path and failing. Tried installing all data down in C:/hugin, but the error persists!

Dick Holford (dholford) wrote :
Bruno Postle (brunopostle) wrote :

Hi, it seems that Hugin is having a problem with '&' in the folder path (though this shouldn't happen).

On Windows, the default temporary folder is in your user folder, can you try changing the temporary folder for Hugin files to something elsewhere and see if that makes any difference:

  Preferences -> General -> Temporary dir

Dick Holford (dholford) wrote :

I see in the Wiki that Make's dislike of '&' is a well-known problem. It persisted with me because it was being used as part of the path for temporary files. Changing the hugin preference, as Bruno suggests, didn't help - maybe I should change the bug description to reflect that! To fix it I had to dig into the W7 system and change the user Environment SET for TMP to C:\temp. Changing my user name was not an option - too much chance of collateral damage! Anyway, the problem is solved via this work-around, but I do think that Make needs updating.

Yuv (yuv) wrote :

Hi,

Would you kindly add a description of the symptoms and workaround to the Hugin FAQ at http://wiki.panotools.org/Hugin_FAQ

Frankly, this case ('&' in the user name) is quite unusual, although '&' in the path happens relatively frequently.

What do you mean with 'make needs updating'? Is there a better version of make for Windows that can be used / shipped with Hugin that you know of? Please be specific.

summary: - Stitcher aborts with path error message
+ Stitch fails when '&' character in Windows user name
Changed in hugin:
status: New → Confirmed
importance: Undecided → Low

Hi Yiv,
I'm not sure how to proceed since the Wiki specifically asks for no more
comments on hugin's dislike of '&' in a path. On the other hand, when it's in a
Win7 user-name things do get more complicated as all user data paths start with
C:\users\Anne & Dick\..... , including the default TEMP and TMP definitions.

I think I did uncover a related bug, in that even changing the hugin preference for
'Temporary dir' didn't help. Make, or whichever module is causing the problem,
seems to ignore this. I picked on Make because that seemed to be suggested in
the Wiki FAQ, and the error occurs before Make actually starts running. 'Make'
also appears in the error log. I'm using the Make supplied with hugin - I did have
another one on my computer but that wasn't involved.
Regards, Dick H.

Date sent: Sat, 04 Jun 2011 16:26:17 +0000
From: Yuv <email address hidden>
To: <email address hidden>
Send reply to: Bug 791677 <email address hidden>
Subject: [Bug 791677] Re: Stitcher aborts with path error message

> Hi,
>
> Would you kindly add a description of the symptoms and workaround to
> the
> Hugin FAQ at http://wiki.panotools.org/Hugin_FAQ
>
> Frankly, this case ('&' in the user name) is quite unusual, although
> '&'
> in the path happens relatively frequently.
>
> What do you mean with 'make needs updating'? Is there a better
> version
> of make for Windows that can be used / shipped with Hugin that you
> know
> of? Please be specific.
>
> ** Summary changed:
>
> - Stitcher aborts with path error message
> + Stitch fails when '&' character in Windows user name
>
> ** Changed in: hugin
> Status: New => Confirmed
>
> ** Changed in: hugin
> Importance: Undecided => Low
>
> --
> You received this bug notification because you are a direct
> subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/791677
>
> Title:
> Stitch fails when '&' character in Windows user name
>
> Status in Hugin - Panorama Tools GUI:
> Confirmed
>
> Bug description:
> Trying to use freshly installed Hugin 2011 under Win7 Home for
> stitching scanned images. My 'user' is "Anne & me". Something
> in
> Hugin is trying to use this in a path and failing. Tried
> installing
> all data down in C:/hugin, but the error persists!
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/hugin/+bug/791677/+subscribe

tmodes (tmodes) wrote :

Made make aware of Hugins temp dir. So this should be more easier to be solved by setting Hugin tempDir in preferences to a path without &

Changed in hugin:
status: Confirmed → Fix Committed
tmodes (tmodes) on 2013-03-05
Changed in hugin:
milestone: none → 2013.0beta1
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments