Hugin - Panorama Tools GUI

crash opening image files with 'open project'

Reported by Bruno Postle on 2011-04-03
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Hugin
High
Unassigned
Fedora
Unknown
Unknown

Bug Description

This was reported in the fedora bugzilla by Robert Kief: https://bugzilla.redhat.com/show_bug.cgi?id=693111

Steps to reproduce:

Select File -> Open.
Change the pattern match at the bottom to 'All files (*).
Select a TIFF or JPEG file.
Click Open.
crash_function: HuginBase::PanoramaMemento::loadPTScript

onomou (onomou) wrote :

Hi, I made a patch that checks the input file for bad (binary file type) characters before letting the program proceed. It keeps it from crashing from image files.

onomou (onomou) on 2011-04-22
Changed in hugin:
assignee: nobody → onomou (onomou)
status: New → Fix Committed
onomou (onomou) on 2011-04-22
Changed in hugin:
status: Fix Committed → In Progress
tmodes (tmodes) wrote :

Your patch rejects too much characters.
Hugin is capable to work with filenames with nearly all characters. But your patch rejects all advanced characters e.g. äöüß from german, but other language are also affected. On unix Hugin works with filenames with characters from nearly the whole UTF-8 and hugin is multi lingual. This should the code respect.

onomou (onomou) wrote :

Sure enough. I was thinking in ASCII and not Unicode. I'll read up on this format and resubmit soon.

Yuv (yuv) wrote :

any new on the resubmission?

onomou (onomou) wrote :

Not a complete fix I think, but I can't reproduce the errors after this patch. Seems one culprit was the v line parser - very outdated and hammer-ish. Hopefully this is headed in the right direction...

Changed in hugin:
status: In Progress → New
Yuv (yuv) on 2011-07-03
Changed in hugin:
importance: Low → High
tmodes (tmodes) wrote :

The new v line parser does not parse correctly if translation parameters (TrX, TrY, TrZ) are in the v lines. These are skipped with the new v line parser/ they does not appear correctly in the gui and it is not possible to optimize the translation parameters on the command line (autooptimiser).

onomou (onomou) wrote :

You are right. But where is the documentation for this? The most complete that I've found is up on CPAN:
http://search.cpan.org/dist/Panotools-Script/lib/Panotools/Script/Line/Variable.pm
and mentions nothing about having those parameters. Translation should be in the i lines (see http://search.cpan.org/dist/Panotools-Script/lib/Panotools/Script/Line/Image.pm). If we should not be going off the standards on CPAN, we need a centralized source for our implementation. Where is it? I couldn't find it on the panotools wiki nor in the built-in documentation of hugin. Maybe it's there, but not easy to find. I'd be happy if you could point me in the right direction.

I'll take a look at the code to make sure it is parsing everything the way I understood it should. Please let me know if you have any suggestions - the old code was buggy and incomplete, and I felt it required a rewrite.

Yuv (yuv) on 2011-07-19
Changed in hugin:
status: New → In Progress
tmodes (tmodes) wrote :

Default branch (changeset d5a36b26e4af) shows now a warning when trying to load an image instead of project file.

Changed in hugin:
assignee: onomou (onomou) → nobody
status: In Progress → Fix Committed
tmodes (tmodes) on 2011-11-05
Changed in hugin:
milestone: none → 2011.4beta1
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.