Auto Crop bug

Bug #702135 reported by Vladimir Nadvornik on 2011-01-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Hugin
Undecided
Unassigned

Bug Description

Auto crop sometimes gives wrong results. It can be reproduced on images that are slightly rotated, see the attached pto file. The problem is that the algorithm starts with some initial area which then can only grow. It does not detect that a little shrink in one direction would allow more growth in the other.

This patch fixes it, but maybe there is some better fix.

tmodes (tmodes) wrote :

Thanks for patch, committed to default branch as rev bbf8b0748de1

Changed in hugin:
status: New → Fix Committed
Yuv (yuv) on 2011-07-17
Changed in hugin:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments