hugin seg faults at launch

Bug #679427 reported by n3tllama on 2010-01-28
This bug affects 4 people
Affects Status Importance Assigned to Milestone

Bug Description

I'm running Fedora12-i686. Attempts to launch hugin (either the version included with F12 (2009.2) or the version in the bugbear repo (2009.4) result in an immediate segfault. If I delete ~/.hugin, then it runs giving me the 'Top of the day' popup, and as soon as I click 'Close' it segfaults. The only output that I see when running hugin is:
$ hugin
Segmentation fault

n3tllama (n3tllama) wrote :

If I run hugin inside of gdb, I get the following:
Starting program: /usr/bin/hugin
warning: .dynamic section for "/usr/lib/" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
warning: .dynamic section for "/usr/lib/" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
[Thread debugging using libthread_db enabled]
Detaching after fork from child process 5348.
Detaching after fork from child process 5350.
Detaching after fork from child process 5351.
warning: .dynamic section for "/lib/" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations

Program received signal SIGSEGV, Segmentation fault.
0x05e75751 in wxWindow::DoSetSize(int, int, int, int, int) ()
   from /usr/lib/
(gdb) bt
#0 0x05e75751 in wxWindow::DoSetSize(int, int, int, int, int) ()
   from /usr/lib/
#1 0x05f6fa0c in wxSizerItem::SetDimension(wxPoint const&, wxSize const&) ()
   from /usr/lib/
#2 0x05f703fb in wxGridSizer::SetItemBounds(wxSizerItem*, int, int, int, int) ()
   from /usr/lib/
#3 0x05f7170e in wxFlexGridSizer::RecalcSizes() () from /usr/lib/
#4 0x05f6f756 in wxSizer::Layout() () from /usr/lib/
#5 0x05f6f88a in wxSizer::SetDimension(int, int, int, int) ()
   from /usr/lib/
#6 0x05f6fa51 in wxSizerItem::SetDimension(wxPoint const&, wxSize const&) ()
   from /usr/lib/
#7 0x05f709a2 in wxBoxSizer::RecalcSizes() () from /usr/lib/
#8 0x05f6f756 in wxSizer::Layout() () from /usr/lib/
#9 0x08153b4e in GLPreviewFrame::panoramaChanged(PT::Panorama&) ()
#10 0x080adef8 in PT::PanoramaObserver::panoramaChanged(HuginBase::PanoramaData&) ()
#11 0x007b5328 in HuginBase::Panorama::changeFinished(bool) () from /usr/lib/
#12 0x080a43d3 in huginApp::OnInit() ()
#13 0x0545c8b1 in wxEntry(int&, wchar_t**) () from /usr/lib/
#14 0x0545cab8 in wxEntry(int&, char**) () from /usr/lib/
#15 0x080a12dc in main ()

Bruno Postle (brunopostle) wrote :

Hi, there is an identical bug report in fedora bugzilla:

I've just tested on a clean install of F12, the default hugin-2009.2.0 works for me.

On F11 I had problems with the ATI graphics drivers. If you are using the binary-only nvidia drivers I would like to exclude this as the problem, can you switch to the default xorg-x11-drv-nouveau driver and see if this fixes it?

n3tllama (n3tllama) wrote :

Using nouveau does not have any impact.

Bruno Postle (brunopostle) wrote :

Switching to nouveau helped the other bug reporter in fedora bugzilla, though this doesn't help track down the problem - Hugin should work with nvidia drivers, in fact the nona-gpu stuff currently doesn't work with nouveau.

Can you think of anything else about your system that may be responsible? Do you have multiple monitors?

n3tllama (n3tllama) wrote :

Yes, I've got two monitors in use on this system, however that was the case when I was running Fedora11 with hugin, and I never had any issues.

Is the backtrace that I provided not useful? Is there a different/debug build that I should try using?

Bruno Postle (brunopostle) wrote :

I'm no expert with reading backtraces, but it does seem to crash while it is deciding where and what size to draw the main window.

Hugin-2009.2.0 introduced some code to prevent Hugin starting with a screen location off the side of the monitor - This was to help laptop users who were constantly switching desktop sizes and getting an inaccessible Hugin. It is possible this code breaks with your dual monitor situation.

timetre (timetre) wrote :

Hi everyone,
I'm also facing the same crash of hugin since recently ... I've also contributed to the bug filed for the F12 package but after searching on the web, I've seen this bug being described on other platforms such as Debian or Ubuntu so I believe it's not platform specific ...

I've run hugin in gdb and it does segfautl on the
wxWindow::DoSetSize (this=0xfd6370, x=10, y=79, width=0, height=0, sizeFlags=4) at src/gtk/window.cpp:2763

line 2763 is
if (m_parent->m_wxwindow == NULL) // i.e. wxNotebook

I debugged step by step and the reason for the segfault is that the m_parent is null ...
(gdb) print m_parent
$2 = (wxWindow *) 0x0

So we have to figure out why this m_parent is null ... this DoSetSize method gets called hundreds of times successfully when hugin starts, so why is it crashing just that one time ...

mindspringdude (mindspringdude) wrote :

I'm new to Hugin - just downloaded and installed - and I seem to be having this problem as well. Hugin starts, displays "Tip of the Day", I click OK, and the program ends with a segfault.

Jun 27 10:45:19 nforce kernel: [ 107.875084] hugin[1967]: segfault at 118 ip 048c10af sp bf957fe0 error 4 in[4774000+330000]

I'm not clear on the solution - if there is one.

I followed the references to other "related" bugs and have found no solution. One even stated that it is a minor issue. Doesn't seem minor to me if I can't use Hugin because of it. :-(

Is this something I'll need to wait for a bugfix? Can I download a previous version? Is there another alternative? I'm considering using the command line interface, but I'm new to Hugin and would prefer to use the GUI.

I'm running Ubuntu 9.10:

mike@nforce:/var/log$ uname -a
Linux nforce.bytered.home 2.6.32-22-generic #36-Ubuntu SMP Thu Jun 3 22:02:19 UTC 2010 i686 GNU/Linux

Thanks to anyone who can help.


Bruno Postle (brunopostle) wrote :

Hi there have been a similar series of bug reports in fedora bugzilla. There are two issues that cause this instant crash with Hugin:

1. proprietary nvidia drivers, switching to the default nv or nouveau driver fixes it. Though soe people have no problem.
2. Compiz, switching off desktop effects fixes it. My understanding is that you DRI2 drivers to use OpenGL applications at the same time as desktop effects.

The same thing here as mindspringdude. Running: Ubuntu Lucid 10.04, uname:
2.6.32-26-generic #47-Ubuntu SMP Wed Nov 17 15:58:05 UTC 2010 x86_64 GNU/Linux
Up to date on 2010-11-24.

Yuv (yuv) wrote :

I had an Ubuntu 10.4 system with discrete video (ATI). I build my own Hugin from source. I built when using the free driver installed and with that driver everything works well. When I install ATI's proprietary driver, Hugin segfaults on start.

Can those reporting this error please:
1. report what video card and what driver you are using
2. where you got Hugin from?
3. what version of Hugin you are running?


Yuv (yuv) on 2010-11-27
Changed in hugin:
status: New → Confirmed

I do not have compiz, or proprietary drivers running, BTW.

I'm running it remotely though, using x2go, so no display info. I thought that might be useful.

It seems to be a problem with the display. I was successful in running the application remotely, on the same computer that failed before by ssh -X into it. HTH.

rew (r-e-wolff) on 2011-01-15
tags: added: ati crash video
Eugene (roginovicci) wrote :

Hugin crashes all the time at startup. I'm using open radeon driver.

Yuv (yuv) on 2011-01-30
Changed in hugin:
importance: Critical → High
Gerry Patterson (gpatters) wrote :


I ran into this on my laptop which has an ATI chipset. More to the point, it has a:

Radeon X600, M24 chipset.
Kubutu 10.4 32-bit

I compiled Hugin with the debug version of the wxWidgets libraries and a few extra dialogs popped up (specific to wx) before it crashes. These pop ups complained about certain members being NULL which seems in line with what has been mentioned in this thread. This seems to trigger when a sizer is added to a either the m_GLPreview or the m_GLOverview in GLPreviewFrame.cpp near line 414.

I had previously been ignoring the other messages that were in the console, specifically:

Xlib: extension "GLX" missing on display ":0.0"

As this seemed to be GL related I started checking things out and found that I had nvidia libraires on my laptop even though I didn't have an nvidia chipset. Checking the xorg.log in /var/log I could see references to loading these nvidia libraries. I also found that "glxgears" would also crash. So, I worked through removing them (sudo apt-get remove --purge nvidia*) and then re-installed the open source ATI driver ( I then restarted the X server and checked to see that I did not have any more references to the nvidia libraries in xorg.log.

I was then able to run glxgears without issue. More importantly, I was also able to start and run Hugin without issue.

In my case, it seems hugin died with a broken GLX install. Perhaps something can be checked in Hugin and a proper error message displayed however my GL coding experience non existent.

To others experiencing this issue, check and see if "glxgears" also dies. If so, check your xorg.log file in /var/log and see if Nvidia libraries are also being used.

Hope this helps!

- Gerry

Yuv (yuv) wrote :

Thank for the complete analysis, Gerry.

Added an FAQ:

The question is whether there is some diagnostic (or even better: self-healing) code around to determine if the video driver is broken; and if such diagnostic code exist whether it makes sense to integrate it at startup.

Changed in hugin:
importance: High → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.