EXIF-data mangles layout of Images Tab

Bug #679338 reported by Yuv on 2009-10-12
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Hugin
Critical
Unassigned

Bug Description

see attached image

Yuv (yuv) wrote :

The file exif_layout.jpg was added: None

Changed in hugin:
status: New → Confirmed
Yuv (yuv) on 2010-12-25
Changed in hugin:
importance: Medium → Critical
rew (r-e-wolff) on 2010-12-27
tags: added: images layout tab

Current hugin impossible to make a reasonable screenshot of or actually use at screenwidth below 1200.

The Cp-detector list control element takes up lots of horizontal space ("Hugins CPFind + Celeste (slower but more accurate, no cps on clouds)") and the [Create control points] button is placed beside it. Moving [Create control points] a little bit down (to the right of Points of Overlap) would improve thing a lot.

Yuv (yuv) on 2011-01-30
Changed in hugin:
importance: Critical → High
Yuv (yuv) on 2011-02-24
tags: added: display
Yuv (yuv) on 2011-02-24
Changed in hugin:
importance: High → Critical
Lajos Höss (cqhl-freemail) wrote :

Hugin 2011.0.0 beta 3 on UHU-Linux 2.1. My display 1280x800 pixel. Current version of Hugin layout better than older, but problem exist. The control point generators drop down menu names only available in english. My hungarian translations 100% complete. See the attachment picture.

Yuv (yuv) wrote :

Thanks for the screenshot, Lajos.

The CP generators drop down displays the names of the settings. You can add/remove/edit them in the Preference window, Control Point Detectors tab.

These are *names* and as such I am not sure if it is a good idea to make them translatable?

Lajos Höss (cqhl-freemail) wrote :

Thanks the help. I modify drop down list messages to short. Now the window more better. Why use extra long default message "Hugins CPFind + Celeste (slower but more accurate, no cps on clouds)"? My idea "CPFind + Celeste" or "Hugins CPFind + Celeste".

Another quick helper, move the "RESET" button left and donw (near link check box)

If both method use, lots of free space available to draw exif data and picture. This quick method i think not the best, but working.

The controll point detector drop down list i think is useful for translate. Of course, not the name "cpfind" or "Panomatic", but multirow/stacked or fisheye? If i reset the controll point setting with load the default i think useful to translate with current language.

tmodes (tmodes) wrote :

Hopefully fixed with overhauled GUI.

Changed in hugin:
status: Confirmed → Fix Committed
tduell (tduell-iinet) wrote :

If it is any help, it seems to be working OK here (2012.1.0:340c9efef7ea) on Fedora 17 x86_64

tmodes (tmodes) on 2013-03-05
Changed in hugin:
milestone: none → 2013.0beta1
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers