PTBatcherGUI does not work with $ in filename

Bug #1819773 reported by Frederic Da Vitoria on 2019-03-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Hugin
Undecided
Unassigned

Bug Description

Windows 10, Hugin 2019.0 Beta 2

I have pictures in the directory c:\Users\FDV_Common\Downloads\$\$$. I optimized my pictures and saved the pto as Pano.pto in the same directoty, but when I try to assemble, I get the following error:
Could not open project file:c:\Users\FDV_Common\Downloads$$$\Pano.pto

Note that the "\" before the $ seem to have been removed.

Using Hugin_sttch_project, the panorama gets assembled correctly

tmodes (tmodes) wrote :

Fixed in repository.

(If you think you covered all special characters, the next user finds the next characters which breaks something ...)

summary: - Batch processor "could not open project file"
+ PTBatcherGUI does not work with $ in filename
Changed in hugin:
milestone: none → 2019.0rc1
status: New → Fix Committed
Frederic Da Vitoria (davitofrg) wrote :

Just for the record, I tried with a folder named &'(-_)=²°+~#{[`^@]}$£%µ,;!§ (those are on the French keyboard) and PTBatcherGUI worked perfectly. So maybe the next character isn't sp close...

tmodes (tmodes) on 2019-03-23
Changed in hugin:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers