Help window opens outside of the screen area

Bug #1744316 reported by zarl on 2018-01-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Hugin
Undecided
Unassigned

Bug Description

tested on OS X 10.11 / Hugin 2018.0.0 rc1

The Help window opens outside of the screen area both when opening the help window from the menu and also when clicking on the question mark button inside the enblend options dialog.

Opening Help from the menu shows the window with the title bar at a position with negative y coordinates, thus the standard close button of OS X can't be reached with the mouse. Mac OS X 10.11 doesn't allow such a window to be dragged to another position other than using the upper title bar of the window. So it should be tested that a new window opens with the upper left corner inside the screens field of view.

As a test I have created a shortcut (using a third party macro editor) to manually reposition the front most window's top left corner to x=50 / y = 50. That actually works and now I tested if I had accidentally dragged one such window to this wrong coordinates and that position was later stored by my system prefs. So I closed the correctly repositioned window and tried opening it again: it still opens at a too high position.

Also the help window can't be closed using the standard shortcut on Mac OS X: Cmd+W

BTW the 'about' window is opened in the center of the screen.

Now when the help window is front most and I try to quit Hugin (Cmd+Q) Hugin will crash this way:
A dialog opens
"atos needs to take control of another process for debugging to continue. Type the name and password of a user in the 'Developer Tools' group to allow this."
username:
password:
[Cancel] [Continue]

There is no such group defined on my system and no matter what user/pw I try or click 'Cancel' the program will crash.

tmodes (tmodes) wrote :

The help system for Mac OS was updated already in 2017.0 (no changes in 2018.0).
The help is displayed by wxWidgets (Hugin has currently no access to the internal of this window.) - so it can behave a little bit different for the initial position than other Hugin windows.
So can somebody reproduce the issue?

Niklas Mischkulnig (mischnic) wrote :

I can reproduce the Cmd+W-"Problem" and the crash. 'atos' seems to be some kind of debugger, did you start Hugin normally (double clicking Hugin.app)? The dialog would give the debugger permission to analyze Hugin *after* it crashed.

I am however not able to reproduce that the help window opens halfway outside the screen.

(macOS 10.12.6)

Niklas Mischkulnig (mischnic) wrote :

The crash is fixed, will be included in Hugin 2018.0 RC2.

Regarding the window position: please delete the following files/folders and check if the issue persists
- ~/Library/Saved Application State/net.sourceforge.hugin.PTBatcherGUI.savedState
- ~/Library/Preferences/net.sourceforge.Hugin.plist
- ~/Library/Preferences/hugin Preferences
(You can press Shift+Cmd+G in Finder and paste a path to navigate to it)

Niklas

tmodes (tmodes) wrote :

I added an additional check for the windows position of the help window in changeset 5abfb4de7961.

Changed in hugin:
milestone: none → 2018.0rc2
status: New → Fix Committed
tmodes (tmodes) on 2018-01-27
Changed in hugin:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers