Save in search results [Windows 10]

Bug #1740042 reported by Abri Pix on 2017-12-25
This bug affects 1 person
Affects Status Importance Assigned to Milestone

Bug Description

When Windows 10 search box was used to find an image, the Assistant tries to save in search results instead of the folder with images. This is a new bug in v. 2018.0 beta 1.

tmodes (tmodes) wrote :

This is not new. The dialog is provided from Windows directly.
When you try to save in a search folder, you get a message box when you click save. The message box states that you can't save here and the dialog stays open. So you can't save there.

Changed in hugin:
status: New → Invalid
Abri Pix (abrimaal) wrote :

Yes, a message box is displayed that files cannot be saved there, but this is a new bug in 2018 beta.
It did not happen in the previous versions of Hugin.

Please compare the screenshots. Especially the locations displayed in the side panel.
In the version 2017 the location to save is drive F where the images are stored.
The 2018 beta version points at "quick access" a pseudo-location where files cannot be saved.

tmodes (tmodes) wrote :

Not reproducible. The save project file dialog opens always in the folder of first image. It make no difference if I used "search" in the add images dialog or not.

tmodes (tmodes) wrote :

Okay, now I can reproduce the issue. You have probably entered an own filename template in the preferences which starts with <space>\. So the solution is to remove the space and backslash (or slash) in the preferences.

Changed in hugin:
status: Invalid → Won't Fix
Abri Pix (abrimaal) wrote :

It may be strange, there are no spaces in the search input window. There may be spaces in folder names, but not always. There are no special characters in the folder and filenames. Only 0-9, A-Z, a-z, "-", "_" and sometimes spaces.
I have noticed, the problem refers to only one drive F. What may be the difference? All drives are formatted in NTFS, they may be compressed by Windows (or not).
I tested other SATA and USB drives. The searched image, after automatic Align (straightening) is saved to the proper folder. Everywhere but the drive F where Windows or Hugin tries to save in search results. What may be the cause?

tmodes (tmodes) wrote :

I did not talk from the search box. I was referring to the filename template in the preferences of Hugin.

Abri Pix (abrimaal) wrote :

The filename template is
The project name template is
There are no spaces. I will try different template names and to copy some of the problematic folders to a different location.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers