Hugin unable to generate output even with tutorial images

Bug #1719789 reported by Amit Maitra on 2017-09-27

This bug report will be marked for expiration in 33 days if no further activity occurs. (find out why)

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Hugin
Undecided
Unassigned

Bug Description

============================================
Stitching panorama…
============================================

Platform: Mac OS X (Darwin 16.7.0 x86_64)
Version: 2017.0.0.eac5e8cc546e built by Niklas Mischkulnig
Working directory: /Users/admin/Documents/Pictures/Tut-1
Output prefix: merge

Blender: enblend 4.2.1-f0304648cc0f
ExifTool version: 10.50

Number of active images: 2
Output exposure value: 13.5
Canvas size: 800x622
ROI: (0, 0) - (800, 622)
FOV: 36x28
Projection: Equirectangular(2)
Using GPU for remapping: true

Panorama Outputs:
* Exposure corrected, low dynamic range

First input image
Number: 0
Filename: /Users/admin/Documents/Pictures/Tut-1/974-1.jpg
Size: 800x600
Projection: Normal (rectilinear)
Response type: custom (EMoR)
HFOV: 35
Exposure value: 13.5

Remapping LDR images…
nona: using graphics card: Intel Inc. Intel HD Graphics 4000 OpenGL Engine
Multiple images output
loading 974-1.jpg
remapping 974-1.jpg
saving merge0000.tif
loading 975-1.jpg
remapping 975-1.jpg
saving merge0001.tif

tmodes (tmodes) wrote :

1.) The log is incomplete. The call of enblend is missing.
2.) A minimum of information would be nice, not only the log.
3.) Deactivate GPU stitching in the preferences (This is experimental and does not work on all machines.)

Changed in hugin:
status: New → Incomplete
Amit Maitra (amaitra-l) wrote :

Thanks for replying.

Not sure what else to include - and how to get them. This gives all the system and release information.

I removed the GPU acceleration. Thanks! This is a generic MacBook Pro - circa 2012 though.

Then I started Hugin from a terminal session (mentioned in some places). Then not use PTBatcherGUI - used the internal one. then the simple introductory tutorial with 2 images worked ok. But I had to load the images again - not sure why because the control point etc were there.

Then I tried one with my own images - very simple ones - open field - unfortunately not too many details to share across images (though there is 30% overlap). It did not work out at all. Almost 180 field of view - taken on tripod but with no pano heads. Some variation in the exposure (though all manually focussed aperture priority f/11 images).

I will get some better images with matchable details in the foreground.

Any plans to fix the matter of GPU?

Amit Maitra (amaitra-l) wrote :

Works somewhat but if I use PTBatcherGUI - this is what I get. I have reinstalled etc. Any appropriate workaround for that? Is the inbuilt one "same" as PTBatcherGUI?

Process: PTBatcherGUI [866]
Path: /Applications/PTBatcherGUI.app/Contents/MacOS/PTBatcherGUI
Identifier: PTBatcherGUI
Version: 2013.0.0 (e9df4bb31222)
Code Type: X86-64 (Native)
Parent Process: Hugin [835]
Responsible: PTBatcherGUI [866]
User ID: 501

Date/Time: 2017-09-27 22:47:03.176 -0700
OS Version: Mac OS X 10.12.6 (16G29)
Report Version: 12
Anonymous UUID: 4421961F-2B66-83A1-A3E7-8F29DBE82032

Time Awake Since Boot: 6400 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Reason: DYLD, [0x1] Library missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: @executable_path/../Frameworks/libbase_wx-2013.0.dylib
  Referenced from: /Applications/PTBatcherGUI.app/Contents/MacOS/PTBatcherGUI
  Reason: image not found

Binary Images:
       0x100000000 - 0x10005afff +net.sourceforge.hugin.PTBatcherGUI (2013.0.0 - e9df4bb31222) <B63D1A34-4F96-35BD-8C22-7AE6E3312A0B> /Applications/PTBatcherGUI.app/Contents/MacOS/PTBatcherGUI
       0x108e3a000 - 0x108e77dc7 dyld (433.5) <322C06B7-8878-311D-888C-C8FD2CA96FF3> /usr/lib/dyld
    0x7fffb2f0f000 - 0x7fffb33a2fff com.apple.CoreFoundation (6.9 - 1349.8) <36385A3A-60D3-32DB-BF55-C6D8931A7AA6> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation

Model: MacBookPro9,2, BootROM MBP91.00D3.B22, 2 processors, Intel Core i5, 2.5 GHz, 8 GB, SMC 2.2f44
Graphics: Intel HD Graphics 4000, Intel HD Graphics 4000, Built-In
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1600 MHz, 0x80CE, 0x4D34373142353237334348302D594B302020
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1600 MHz, 0x80CE, 0x4D34373142353237334348302D594B302020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xF5), Broadcom BCM43xx 1.0 (7.21.171.130.1a1)
Bluetooth: Version 5.0.5f1, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: TOSHIBA MK5065GSXF, 500.11 GB
Serial ATA Device: HL-DT-ST DVDRW GS31N
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: Hub
USB Device: Apple Internal Keyboard / Trackpad
USB Device: IR Receiver
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: FaceTime HD Camera (Built-in)
USB Device: USB 3.0 Bus
Thunderbolt Bus: MacBook Pro, Apple Inc., 25.1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers