hugin won't start: "invalid window dc"

Bug #1682974 reported by clepsdyrae on 2017-04-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Hugin
Undecided
Unassigned

Bug Description

Hi -- Kubuntu 16.10, added the nightly repo which appears to have last been updated 2017-04-10 (2016.3.0.84a397fa5e9a).

Running hugin, I see a splash screen and an immediate failed assertion:

ASSERT INFO:
../src/gtk/dcclient.cpp(1520): assert "IsOk()" failed in Clear(): invalid window dc

BACKTRACE:
[1] wxWindowDCImpl::Clear()
[2] ImagesTreeCtrl::SetOptimizerMode()
[3] OptimizePanel::Init(HuginBase::Panorama*)
[4] MainFrame::MainFrame(wxWindow*, HuginBase::Panorama&)
[5] huginApp::OnInit()
[6] wxEntry(int&, wchar_t**)
[7] main
[8] __libc_start_main
[9] _start

If I click "Continue" many times, the program appears to start and work (though I haven't fully tested.)

System info:

Operating System: Linux 4.8.0-46-generic x86_64
Architecture: 64 bit
Free memory: 5107772 kiB

Hugin
Version: 2016.3.0.84a397fa5e9a
Path to resources: /usr/share/hugin/xrc/
Path to data: /usr/share/hugin/data/
Hugins camera and lens database: /home/casey/.hugindata/camlens.db
Multi-threading using C++11 std::thread and OpenMP

Libraries
wxWidgets: wxWidgets 3.0.2
wxWidgets Library (wxGTK port)
Version 3.0.2 (Unicode: wchar_t, debug level: 1),
Runtime version of toolkit used is 2.24.
Compile-time GTK+ version is 2.24.30.

libpano13: 2.9.19
Boost: 1.61.0
Exiv2: 0.25
SQLite3: 3.14.1
Vigra: 1.11.0
LittleCMS2: 2.7

tmodes (tmodes) wrote :

I can't reproduce the issue on Fedora.
Trying a blind fix in changeset 282b5e7ba8f0. This breaks at least for me nothing.

clepsdyrae (myopenid) wrote :

Thanks! I'll try it when it comes to the nightly ppa.

In case it helps: I click "Continue" 12 times to get the program to start.

Also: the version in the standard ubuntu repo did not have this issue.

clepsdyrae (myopenid) wrote :

Also, just FYI, from the CLI invocation of hugin:

-----

(hugin:3292): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width 0 and height -32

(hugin:3292): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 18

(hugin:3292): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'height >= -1' failed

(hugin:3292): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'height >= -1' failed

(hugin:3292): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'height >= -1' failed

(hugin:3292): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width 179 and height -32

(hugin:3292): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'height >= -1' failed

(hugin:3292): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width 360 and height -32

(hugin:3292): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'height >= -1' failed

(hugin:3292): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'height >= -1' failed

(hugin:3292): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width 360 and height -32

(hugin:3292): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'height >= -1' failed

(hugin:3292): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width 559 and height -11

clepsdyrae (myopenid) wrote :

Latest nightly works without issue! Thanks!

clepsdyrae (myopenid) on 2017-04-17
Changed in hugin:
status: New → Fix Committed
tmodes (tmodes) on 2017-04-17
Changed in hugin:
milestone: none → 2017.0beta1
tmodes (tmodes) on 2017-05-06
Changed in hugin:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers