Fails to stitch in mktemp -d directory with ptbatcher

Bug #1227813 reported by Andreas Metzler on 2013-09-19
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Hugin
Undecided
Unassigned

Bug Description

Hello,

hugin fails to stitch images in a directory generated with mktemp -d if PTBatcherGUI is used.

How to reproduce (starting without ~/.hugin):

8X----------------------------------
surfonly@argenau:~$ mktemp -d
/tmp/tmp.GWy5J6KUny
surfonly@argenau:~$ cp /tmp/*JPG /tmp/tmp.GWy5J6KUny
surfonly@argenau:~$ ls -la /tmp/tmp.GWy5J6KUny
total 5692
drwx------ 2 surfonly surfonly 4096 Sep 19 19:04 .
drwxrwxrwt 11 root root 20480 Sep 19 19:04 ..
-rw-r--r-- 1 surfonly surfonly 2850496 Sep 19 19:04 IMG_2459.JPG
-rw-r--r-- 1 surfonly surfonly 2952114 Sep 19 19:04 IMG_2460.JPG
surfonly@argenau:~$ printenv | grep -i tmp
surfonly@argenau:~$ pwd
/home/surfonly
surfonly@argenau:~$ hugin
----------------

hugin starts (with interface simple), I dismiss the tip of the day.
On the assistant-tab I use Load images to add the two images, followed
by 2. Align and 3. Create panorama (keeping all defaults, in this case
exposure fused from stacks). I am asked about saving for PTbatcher and
again the default filename.

The stitch fails with this error:

===========================================================================
*************** Panorama makefile generated by Hugin ***************
===========================================================================
System information
===========================================================================
Operating system: GNU/Linux
Release: 3.2.0-4-amd64
Kernel version: #1 SMP Debian 3.2.46-1+deb7u1
Machine: x86_64
Disc usage
Filesystem Size Used Avail Use% Mounted on
rootfs 296G 214G 67G 77% /
udev 10M 0 10M 0% /dev
tmpfs 396M 316K 396M 1% /run
/dev/disk/by-uuid/4f566dee-9acc-4629-9ea1-97e32a5da5f3 296G 214G 67G 77% /
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 792M 0 792M 0% /run/shm
/dev/sda5 68G 11G 58G 15% /media/win
/dev/sda1 204G 66G 138G 33% /media/xpsystem
/dev/disk/by-uuid/4f566dee-9acc-4629-9ea1-97e32a5da5f3 296G 214G 67G 77% /chroots/sid/tmp
tmpfs 792M 0 792M 0% /chroots/sid/run/shm
/dev/disk/by-uuid/4f566dee-9acc-4629-9ea1-97e32a5da5f3 296G 214G 67G 77% /chroots/sid-amd64/tmp
/dev/disk/by-uuid/4f566dee-9acc-4629-9ea1-97e32a5da5f3 296G 214G 67G 77% /chroots/etch/tmp
/dev/disk/by-uuid/4f566dee-9acc-4629-9ea1-97e32a5da5f3 296G 214G 67G 77% /chroots/amd64-wheezy/tmp
/dev/disk/by-uuid/4f566dee-9acc-4629-9ea1-97e32a5da5f3 296G 214G 67G 77% /chroots/amd64-jessie/tmp
/dev/disk/by-uuid/4f566dee-9acc-4629-9ea1-97e32a5da5f3 296G 214G 67G 77% /chroots/lenny/tmp
/dev/disk/by-uuid/4f566dee-9acc-4629-9ea1-97e32a5da5f3 296G 214G 67G 77% /chroots/squeeze/tmp
/dev/disk/by-uuid/4f566dee-9acc-4629-9ea1-97e32a5da5f3 296G 214G 67G 77% /chroots/wheezy/tmp
/dev/disk/by-uuid/4f566dee-9acc-4629-9ea1-97e32a5da5f3 296G 214G 67G 77% /chroots/sq-amd/tmp
Memory usage
             total used free shared buffers cached
Mem: 3956 2156 1799 0 458 557
-/+ buffers/cache: 1139 2816
Swap: 8191 0 8191
===========================================================================
Output options
===========================================================================
Hugin Version: 2013.0.0.76c3df493921
Project file: /tmp/huginpto_wGDDGb
Output prefix: IMG_2459 - IMG_2460
Projection: Rectilinear (0)
Field of view: 63 x 42
Canvas dimensions: 2453 x 1518
Crop area: (57,44) - (2423,1462)
Output exposure value: 13.66
Output stacks minimum overlap: 0.700
Output layers maximum Ev difference: 0.50
Selected outputs
Exposure fusion
* Fused and blended panorama
===========================================================================
Input images
===========================================================================
Number of images in project file: 2
Number of active images: 2
Image 0: /tmp/tmp.GWy5J6KUny/tmp.GWy5J6KUny/IMG_2459.JPG
Image 0: Size 2592x1944, Exposure: 13.61
Image 1: /tmp/tmp.GWy5J6KUny/tmp.GWy5J6KUny/IMG_2460.JPG
Image 1: Size 2592x1944, Exposure: 13.71
===========================================================================
Testing programs
===========================================================================
Checking nona...[OK]
Checking enblend...[OK]
Checking enfuse...[OK]
Checking hugin_hdrmerge...[OK]
Checking exiftool...[OK]
===========================================================================
Stitching panorama
===========================================================================
make: *** No rule to make target `/tmp/tmp.GWy5J6KUny/tmp.GWy5J6KUny/IMG_2459.JPG', needed by `IMG_2459 - IMG_2460_exposure_layers_0000.tif'. Stop.
8X----------------------------------

If I use "hugin stitch project" the stitch succeeds, I assume because it sttches from a temporary pto file in /tmp, which is why the relative patch tmp.GWy5J6KUny/IMG_2459.JPG works.

This is present at least 2011.4.0 and 2013.0.0rc1.

The issue was originally reported by Paul Seyfert in the Debian BTS.

cu Andreas

tmodes (tmodes) wrote :

Fixed in changeset c77adaff99c5.

Changed in hugin:
status: New → Fix Committed
tmodes (tmodes) on 2013-12-31
Changed in hugin:
milestone: none → 2014.0beta1
tmodes (tmodes) on 2014-01-01
Changed in hugin:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments