'add images' forgets last load path

Bug #1041702 reported by tduell on 2012-08-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Hugin
Undecided
Unassigned

Bug Description

Hugin 5969:6655fe3b8b0f (default branch), built on Fedora 17 x86_64.
Open Fast Preview Window, select 'load images', the 'add images' window opens in my home directory, even after having just loaded an image.
This is changed behaviour from recent builds, which, if I recall correctly, always remembered the path of the last image loaded.

I haven't gone back to test previous builds to be sure when the changed behaviour first appeared, but I 'think' 5967:6571549ff779 was OK.

tduell (tduell-iinet) wrote :

I have just built and tested hugin-2012.0.0_beta1, and it exhibits the same behaviour as I reported above.
Either I have an incorrect memory of previous behaviour, or possibly, some changes in Fedora 17 updates are causing this.
Not sure.

tmodes (tmodes) wrote :

This worked, and it works on Windows. It seems to be bug in GTK, see e.g.
http://trac.wxwidgets.org/ticket/14525
https://bugzilla.redhat.com/show_bug.cgi?id=849692
I committed a workaround (changeset 7727ca723ada) to correctly remember the last path. I hope it works and there are no more place which needs the fix.

Changed in hugin:
status: New → Fix Committed
tduell (tduell-iinet) wrote :

Hello Thomas,
The current default branch (5973:9004d683a94d) now behaves correctly when loading images.
Hopefully the source of the problem in GTK will be fixed soon.
Thanks for your help.

tmodes (tmodes) on 2013-03-05
Changed in hugin:
milestone: none → 2013.0beta1
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.