Some test_hud tests fail on trusty desktop

Bug #1244704 reported by Łukasz Zemczak on 2013-10-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Christopher Townsend
Unity HUD
Invalid
Critical
Unassigned
unity (Ubuntu)
Critical
Christopher Townsend

Bug Description

Last daily release run revealed several autopilot failures in the HUD stack, high above our threshold. Those are blocking the release of the HUD stack. The failures are as follows:

    unity.tests.test_hud.HudBehaviorTests.test_closes_then_focuses_window_on_mouse_down
    unity.tests.test_hud.HudBehaviorTests.test_no_initial_values
    unity.tests.test_hud.HudLauncherInteractionsTests.test_multiple_hud_reveal_does_not_break_launcher(Monitor 1,Launcher autohide)
    unity.tests.test_hud.HudVisualTests.test_hud_icon_shows_the_focused_application_emblem(Monitor 0,Launcher autohide,Launcher on primary monitor)
    unity.tests.test_hud.HudVisualTests.test_hud_icon_is_shown(Monitor 1,Launcher autohide,Launcher on all monitors)
    unity.tests.test_hud.HudBehaviorTests.test_mouse_changes_selected_hud_button
    unity.tests.test_hud.HudBehaviorTests.test_keyboard_steals_focus_from_mouse
    unity.tests.test_search.HudFuzzySearchTests.test_hud_fuzzy_search(transposition)
    unity.tests.test_search.HudFuzzySearchTests.test_hud_fuzzy_search(duplication)
    unity.tests.test_search.HudFuzzySearchTests.test_hud_fuzzy_search(insertion)
    unity.tests.test_search.HudFuzzySearchTests.test_hud_fuzzy_search(deletion)
    unity.tests.test_search.HudSearchTests.test_hud_search(basic)
    unity.tests.test_search.HudSearchTests.test_hud_search(lowercase)
    unity.tests.test_search.HudSearchTests.test_hud_search(uppercase)
    unity.tests.test_search.HudSearchTests.test_hud_search(partial)
    unity.tests.test_hud.HudBehaviorTests.test_no_initial_values
    unity.tests.test_hud.HudLauncherInteractionsTests.test_multiple_hud_reveal_does_not_break_launcher(Single Monitor,Launcher never hide)
    unity.tests.test_search.HudFuzzySearchTests.test_hud_fuzzy_search(transposition)
    unity.tests.test_search.HudFuzzySearchTests.test_hud_fuzzy_search(duplication)
    unity.tests.test_search.HudFuzzySearchTests.test_hud_fuzzy_search(insertion)
    unity.tests.test_search.HudFuzzySearchTests.test_hud_fuzzy_search(deletion)
    unity.tests.test_search.HudSearchTests.test_hud_search(basic)
    unity.tests.test_search.HudSearchTests.test_hud_search(lowercase)
    unity.tests.test_search.HudSearchTests.test_hud_search(uppercase)
    unity.tests.test_search.HudSearchTests.test_hud_search(partial)

Not all happened on both machines at once. Some tests might be flacky on trusty right now. It is unrelated to autopilot 1.4 as we are still using autopilot 1.3 for this run.

No public jenkins instance available yet:
http://10.97.0.1:8080/job/autopilot-trusty-daily_release/104/

Related branches

Ted Gould (ted) wrote :

Looks to me like an autopilot issue. When looking at this video:

http://10.97.0.1:8080/job/autopilot-trusty-daily_release/104/label=autopilot-nvidia/artifact/results/autopilot/videos/unity.tests.test_hud.HudBehaviorTests.test_no_initial_values.ogv

It seems the HUD is appearing, very quickly, with the proper values, but then disappearing. Not sure if autopilot is not seeing it?

Changed in hud:
status: New → Incomplete
Changed in unity:
importance: Undecided → Critical
Christopher Townsend (townsend) wrote :

I don't think this is an issue any more, is it?

Changed in unity:
status: New → Incomplete
Timo Jyrinki (timo-jyrinki) wrote :

The latest build still seems to have similar errors on each of the three autopilot machines:
http://q-jenkins.ubuntu-ci:8080/job/autopilot-trusty-daily_release/550/#showFailuresLink

Changed in unity:
status: Incomplete → Confirmed
Changed in hud:
status: Incomplete → Confirmed
Christopher Townsend (townsend) wrote :

I'll take a look at this on the Unity side.

Changed in unity:
assignee: nobody → Christopher Townsend (townsend)
status: Confirmed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.2.0

Changed in unity:
status: In Progress → Fix Committed
Changed in hud:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Christopher Townsend (townsend)
Timo Jyrinki (timo-jyrinki) wrote :

Kicked a new daily build of the unity stack. After that, rerunning the HUD stack's tests could yield the results.

Christopher Townsend (townsend) wrote :

FYI, Unity will fail to build until we can get https://code.launchpad.net/~townsend/unity/fix-gtk-build-error/+merge/198611 merged, but armhf builds are failing due to bug #1260068 (a Mesa issue), hence automerges are blocked.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.2.0

Timo Jyrinki (timo-jyrinki) wrote :

This seems improved now. I filed a new bug of the remaining/new autopilot failures in cu2d in bug #1276569

Launchpad Janitor (janitor) wrote :
Download full text (18.5 KiB)

This bug was fixed in the package unity - 7.1.2+14.04.20140214.1-0ubuntu1

---------------
unity (7.1.2+14.04.20140214.1-0ubuntu1) trusty; urgency=low

  [ Sebastien Bacher ]
  * use unity-control-center by default.
  * lists keybinding in unity-control-center. (LP: #1271710)

  [ Brandon Schaefer ]
  * Bump to new libnux from this branch:
    https://code.launchpad.net/~brandontschaefer/nux/xim-preedit-
    support.
  * Adds Super+L to lock the screen, while keeping the older shortcut
    around in g-s-d (Ctrl+Alt+L). (LP: #830709)
  * Do not open the dash/hud on a monitor with a top most window that is
    fullscreen. (LP: #1267210)
  * Implement an EMConveter. This way with default settings such that
    DPI = 96.0f, and font_size = system font size. We can get the
    correct EM value for any pixel size. Once we have the correct EM
    value for any pixel size, the DPI value can be adjusted to the
    current logical one. From here, you can now get the correct pixel
    size based from of the EM value for the logical DPI of the screen.
  * Refactor EMConverter API. Now all thats needed is int
    ConvertPixels(int pixel); This will calculate the correct pixel size
    based on the DPI and font size.
  * Testing that the ibus anthy tests could possibly be causing strange
    issues on the nvidia machine. So skipping them to test if tihs is
    the source of the error.
  * Add Pt to Px function to em converter.
  * Move EMConverter over to unity settings.
  * Add multi monitor support for EMConverter in unity settings. Now you
    can grab a specific converter per monitor.
  * Simple RawPixel class. It adds 2 define literals, ex: 10_em,
    10.0_em. From there it turns them into raw pixels. RawPixels have CP
    (CovertPixel) function which takes in an EMConverter that allows you
    to use a converter specific to a monitor to convert the raw pixel to
    the correct value.

  [ Marco Trevisan (Treviño) ]
  * Don't re-present all of our windows on every frame. Only do that if
    damage intersects it. Use the new APIs exposed by compiz and nux to
    intelligently determine which windows need to be presented per-frame
    and only register damage for those windows. This fixes two things:
    1. BaseWindows being redrawn from scratch every time damage was
    registered over them. That was incorrect and should only be done in
    the case of background blurs. 2. BaseWindows being drawn to the
    screen on every frame, regardless of whether or not they needed to
    be. Now they will only be drawn if some damage intersects beneath
    them. Note that unity will expand the damage region to accomadate
    the base window since nux does not support geometry clipping. So if
    there is a partial intersection of the launcher for example, the
    area of the screen which contains the launcher will be re-painted
    (but the launcher itself won't be redrawn, just its texture) (LP:
    #1080947). (LP: #1080947)
  * Convert compiz regions / rects to nux::Geometry's and back easily.
  * UnityScreen: remove the useless and expensive gl{Push,Pop}Attrib
    calls For some reasons this code was copied by the opengl plugin as
    a workaround to fix the s...

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2014-04-03
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers