HP LaserJet CP1025 and CP1025nw blurry print 3.11.[7 & 10 & 12] & 3.12.2

Bug #889306 reported by Jonathan
54
This bug affects 8 people
Affects Status Importance Assigned to Milestone
HPLIP
Fix Released
Undecided
Sanjay Kumar

Bug Description

Black text, lines, Images are blurry. tested with 3.11.7 & 3.11.10.
For similar see:
https://answers.launchpad.net/hplip/+question/176428

I'm posting to requested info from above link. Printer Prints fine from Mac OS X & iOS.

Revision history for this message
Jonathan (jeisom) wrote :
Revision history for this message
Jonathan (jeisom) wrote :
Revision history for this message
Jonathan (jeisom) wrote :
Revision history for this message
Jonathan (jeisom) wrote :
Revision history for this message
Jonathan (jeisom) wrote :
Revision history for this message
Jonathan (jeisom) wrote :
Revision history for this message
Jonathan (jeisom) wrote :

Compress with xz. 88 megabyte file otherwise

Revision history for this message
Jonathan (jeisom) wrote :

600dpi scan of output.

Changed in hplip:
assignee: nobody → Sanjay Kumar (sanjay-kumar14)
Revision history for this message
Jonathan (jeisom) wrote :

Attached contrasting Blue and Black image

Changed in hplip:
status: New → Confirmed
status: Confirmed → In Progress
Revision history for this message
WalterNicholls (walter-nic) wrote :

Same behaviour for me. Kubuntu Oneiric / hplip 3.11.10.; Printer is HP CP1025nw - brand new. Have upgraded printer firmware to latest as per instructions from HP.

For example printing a PDF from Okular get fuzzy text, very glossy looking .. if I print in colour mode. If I print in greyscale mode everything looks clean and crisp (and black).
On my wife's computer (Kubuntu Natty) printing from Libreoffice 3.3 she got some black text black, and some black text came out blue and fuzzy! (it may not be related, but when she sets greyscale output nothing comes out of the printer at all); Version 3.11.1.

Our old printer (HP Laserjet 2550L) was absolutely fine.

Revision history for this message
Lark (florent-g) wrote :

Same issue with my CP1025 (not nw)

Revision history for this message
Marcus S. (martux76) wrote :

Hello!
I have just received my CP1025 (not nw) today and have the same issue with ALL 3.11 versions from 3.11.1 to 3.11.10. Grayscale printing works perfect, but in color mode black is extremely blurry.
I really need to know if this is fixed anytime soon, as I need that device badly. Additionally I am really fed up with Linux printing issues, as this is the second device I bought. The samsung device I got, had such a crappy driver that I immediately returned it.
So, please, what is the status on this. Is it worth waiting or can I just repack it and send back to Amazon?
I mean this is a serious, important issue. That printer just doesn't work.
Oh I want to mention that this issue seems not to have to do with PDF-Iso standard or anything. The hp-testpage is also blurry, so are pure OOO-documents and so on. For what it is worth, I am not on *buntu but on ~amd64 gentoo-linux. Regards.

Revision history for this message
Jonathan (jeisom) wrote :

Hi Marcus
  Also using ~amd64 gentoo. I posted a workaround @
<https://answers.launchpad.net/hplip/+question/176428>
It involves using the eprint feature of the printer to email a
pdf to the printer. Sanjkay is there any progress on this?

Revision history for this message
Marcus S. (martux76) wrote :

I only have the LaserJet CP1025 color, a very basic model which I think doesn't even has eprint :(
Well, a short message from package maintainer would be nice, if this is even recognized as bug and adressed?
Jonathan: Your "solution" is really an *evil* hack :)

Revision history for this message
Geb (gebhard-moser) wrote :

I have the LaserJet CP1025 and the black color is blurry, like there is too much black applied with the laser...
It worked already fine with an earlier installation that was manually applied on Linux Mint 11, I'm not sure, probably it was hplip 3.11.1.
Please check and fix, printer is not usable so far !

btw, to apply the plugin, sudo hp-plugin needs to be applied to prevent failure, seems like "normal" user rights are not sufficient ...

Revision history for this message
Geb (gebhard-moser) wrote :

sorry, didn't mention in my posting a minute ago, currentyl Mint12 is in use with hplip 3.11.7

Revision history for this message
Pelusa (pelusawoman) wrote :

Add me to the list. Blurry, over-saturated, unusable prints on CP1025nw. Hplip 3.11.10 on Fedora 16, AMD 64.

Lark (florent-g)
summary: - HP LaserJet CP1025nw blurry print 3.11.[7 & 10]
+ HP LaserJet CP1025 and CP1025nw blurry print 3.11.[7 & 10]
Revision history for this message
Marcus S. (martux76) wrote : Re: HP LaserJet CP1025 and CP1025nw blurry print 3.11.[7 & 10]

Question, is there any version of hplip working with the CP1025? I installed an old ebuild of the 3.11.1 and it didn't print at all. With all versions from .5 to .11 I have this blurry issue.

Revision history for this message
Geb (gebhard-moser) wrote :

Yes, there was a version where it definately worked.
Might be 3.11.1, but I'm not sure, as the running equipment got newly installed in meanwhile.
Maybe it's just an issue about some configuration setting or the plugin.
Anyway, if this doesn't get fixed, I have to return the printer as a result of warranty claim, as I don't have it for longer than 6 months (EU consumer law)...

Revision history for this message
Marcus S. (martux76) wrote :

The 3.11.1 doesn't do anything here at all :( So basically I have a brand new printer and cannot print at all. Not everyone wants to install Windows. Half a year? In Germany it is two weeks after purchase. Good luck explaining to your merchant!

Revision history for this message
Geb (gebhard-moser) wrote :

:-(
bought mine in September and also don't have windof at home, but due to EU wide policy, there is the "Gewährleistung" that in the first 6 months it's the duty of the seller (or producer) to ensure functionality ("Beweislast beim Verkäufer"), following that 6 months, this turns into the other direction ("Beweislastumkehr"), that the buyer has to evidence malefunction, this ends finally after 2 years of buying (more precise: delivery or picking up, "Warenübergang").
It is not stated clearly that the printer works under Linux, though you can return the printer as unusable with a printout as evidence.
Then as stated above within the 6 months, it's comparably easy to stick on the duty of the seller, that the device works...
everything clear ?
Anyway, hope someone can fix this soon, that complaints and returns don't need to take place !

Revision history for this message
Marcus S. (martux76) wrote :

Alles klar, thank you :)
Well, I also hope that this doesn't have to happen. I just want to print and bought an HP for two reasons:
a) I made very decent experience under Linux with my old one and
b) research suggested that this model is working with hplip.
So let's hope they fix it!
Did you see the "also affects me" link on top of the page? The more people sign in there, the better.
Regards!

Revision history for this message
Marcus S. (martux76) wrote :

Today 3.11.12 was released, and NO, it didn't fix the bug. Oh the disappointment. This is ridiculous.

Revision history for this message
Lark (florent-g) wrote :

Any news from the HPLIP team ?
Please consider this is a major (event critical) bug since CP1025(nw) is basically unusable for now (no decent color print is possible).
Could we hope this issue to be fixed shortly ?

Thank you in advance for any informations about the fixing of this issue
Regards

Revision history for this message
Geb (gebhard-moser) wrote :

thanks for the new version.
@Marcus: thanks for information

very positive is that they fixed some bugs that I considered in the past.

if logs or something else is needed, please state here.

Revision history for this message
goutam kodu (goutam-hplip) wrote :

Hi,

We are working on this issue. We will be back on this soon.

Sorry of the late response and inconvenience

Thanks,
Goutam kodu

Revision history for this message
goutam kodu (goutam-hplip) wrote :

Hi All,

Just to update;

While analysing this issue we came across couple of items.

 = > Printing the pdf file with Adobe Reader prints blurry. The filter chain that it takes to generate the raster is pstopdf,pdftopdf ,pdftoraster and hpcups . Basically adobe reader generates the ps file and passes it down to cups filters.

=> Printing the pdf file with Document Viewer app prints fine and no blurry. The filter chain that it takes to generate the raster is pdftopdf , pdftoraster and hpcups. Basically Document viewer generates the pdf file and passes it down to cups filters.

=> To check whether the pstopdf filter has the corruption . I generated the ps file from the document viewer and printed it via using hp-print toolbox and the filter chain that it took to generate the raster file is pstopdf, pdftopdf, pdftoraster and hpcups and that got printed fine without blurry.

=> This makes sure that the ps file generated by the Adobe Reader might have some corruption or problem which need to be analysed further.

=>What happens in hpcups filter is that it separates the color plane and k (black) plane from the raster file generated by the cups filters for RGBW cupsColorSpace. This separation happens for the raster file generated with printing with Document Viewer and where as that separation does not happen for the raster file generated with printing with Adobe Reader or Okular.
And the black data in the document gets printed as color and which appear as blurry and color data in the document prints fine.

We are analysing the issue and will get back on the same.
Please use Document viewer application or hp-print utility for printing the PDF or other documents for time being.

Sorry for causing the inconvenience

Thanks & Regards,
Goutam Kodu

Revision history for this message
goutam kodu (goutam-hplip) wrote :

Hi All,

Printing with Adobe Reader by default manages the color space and generates the ps file.
 Well, there is an Advance option button at the below of the Print utility toolbox of Adobe reader. Click on it and check the option "Let printer determine the color" and give a print job. This will print fine without blurry.
Please try this option to resolve the burry printing problem with these application on these printers.

This does not look to be the problem with respect to print filters (hpcups or cups). It is just the advance printing option settings in your applications.

Please check this let me know on the same.

Thanks,
Goutam Kodu

Changed in hplip:
assignee: Sanjay Kumar (sanjay-kumar14) → goutamkk (goutam-hplip)
Revision history for this message
Geb (gebhard-moser) wrote :

Dear Goutam,

maybe there is a misunderstanding, this thread doesn't just belong to printing from pdf.
I have an evidence that I tried printing out the hplip startpage, which doesn't have some relationship with pdf (afaik).

anyway, have a newly installed Linux Mint 12 64 bit (which is based on Ubuntu 11.10) and tried to gather some information that might be helpfully for you.
the steps that I made have been (slightly simplified):

- installed hplip-gui (3.11.7)
- printer connected the first time (USB)
- printer got added
- started to print test-page
- message appeared the printer needs to be shared
- shared the printer (by calling system-config-printer, as gnome 3 doesn't offer that anymore)
- started to print test-page
- print error appeared
- checked diagnose button
- copied the error log to errorlog.txt
- copied the diagnostic output to diagnostic.txt
- reconnected the printer and restarted the hplip-toolbox
- device communication error 5012 appeared
- quit the hplip-toolbox
- power-off and on of the printer
- now information about the printer like toner level and that plugin is required is visible (was not before) !
- chose installation of required plugin and agreed terms of conditions
- message "plugin install failed" appeared...
- downloaded it manually from http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-3.11.7-plugin.run
- also didn't work with that file, same message appeared

so unfortunately this time I was not able to print out anything...

hope this explains also the suffer with the plugin...

Revision history for this message
Jonathan (jeisom) wrote :

 goutamkk
    If you print in greyscale the black is fine(appears to be default in hp-print). In color mode is when the black is bad. Hp-print is also affected by this bug.

Thanks

Jonathan

Revision history for this message
goutam kodu (goutam-hplip) wrote :

Hi Geb,

Please install the latest 3.11.12 version of the HPLIP from hplip-3.11.12.tar.gz source file. You can find the download link and installation instructions in the below link
http://hplipopensource.com/hplip-web/install/manual/distros/linuxmint.html

The instruction are updated till LinuxMint 11. But they will work on LinuxMint 12 too.

Please install the latest and check if you can able to see the same issue.

Let us know on the same.

Thanks & Regards,
Goutam Kodu

Revision history for this message
goutam kodu (goutam-hplip) wrote :

Hi Jonathan,

My analysis on this blurry printing issue was on Ubuntu 11.10 and i was able to check that it was happening only on certain applications and this was because of not setting certain attributes in the application which i had mentioned in my comment #27.

I believe you are using Gentoo OS . Which i have to still work on. Will analyse this issue on this distro and give you an update on this.

Sorry for getting delayed on this.

Thanks & Regards,
Goutam Kodu

Revision history for this message
Marcus S. (martux76) wrote :

It doesn't work on Gentoo with 3.11.12. I believe if this is fixed on Ubuntu it will also work on Gentoo or any other distribution.

Revision history for this message
Geb (gebhard-moser) wrote :

Thanks Goutam,

- installed the version 3.11.12 without problems
- tried to install the plugin with "download and install", message "download of the digital signature file failed..." appeared, installed it anyway
- printing out the hplip homepage results in the same failure as before, black color ist blurry (like too much black applied)
- printing out the same in greyscale resulted in perfect black/grey printing

looks to me like there is an issue with the parameter applying the black colour in the print mode colour....

Revision history for this message
Geb (gebhard-moser) wrote :

attached a scanned image from the print-out that shows pretty well the problem,
esp. when you look at the written text and compare the blue and magenta letters with the black beside....

Revision history for this message
goutam kodu (goutam-hplip) wrote :

Hi Geb,

Will look on this and provide you an update.

Thanks,
Goutam

Revision history for this message
Lark (florent-g) wrote :

Hi Goutam,

First of all happy new year.

In your posts #27 and #32 you say the issue is "happening only on certain applications" on Ubuntu 11.10 (you mentioned Adobe Reader).
I am running under Ubuntu 11.10, and I experience this issue on every print, from any application (including Document Viewer, print test page, Open Office...).

Since I don't use Adobe Reader I can't test the workaround your described in post #28. The "Advanced" button seems not to exist in print dialogs on other applications.

As Geb said on post #29, I'm afraid this bug is not linked to one particular application - but is more general -, even under Ubuntu 11.10.

I've opened a similar ticket as your team requested a few weeks ago : https://bugs.launchpad.net/hplip/+bug/903391. You can find there some logs and files that may help you.

Thanks in advance for your feedback.
Sincerely

Revision history for this message
DSF (felejteni) wrote :

Hi folks,

I've been having the very same issue whith HPLIP and an "HP LaserJet Pro CP1025", blame the propietary plugin.

As I could not help in any way to the solution other than make some fuss about it, I've been searching for an alternative driver... and good news! There is an open source driver:

http://foo2zjs.rkkda.com/

The blur is gone!

Revision history for this message
Jonathan (jeisom) wrote :

Thanks DSF.

  Worked like a charm on my cp1025nw. And it is included in my distro's reposotory.

Revision history for this message
Geb (gebhard-moser) wrote :

@DSF: thanks for the hint !

@Jonathan:
I found it with standard repositories of my Mint 12 already installed, with version of August from last year.
Did you somehow activate it or did you follow the steps described for installation (make...)?

@Goutam:
I would definately prefer NOT to hack my computers at home, most propably it's "just" about to correct one parameter, the saturation of the black color...

Revision history for this message
Jonathan (jeisom) wrote :

Hi Geb
   I use gentoo which in this case downloads the latest version and installs all the printers it supports. I then just had to add printer in cups. I did do as suggested on the site and that was add one for b/w and one for color though. From the changelog you'll need the latest though.

HTH

Revision history for this message
Lark (florent-g) wrote :

@DSF : thanks for this tip. It worked like a charm on my CP1025 under ubuntu 11.10.

Geb (gebhard-moser)
summary: - HP LaserJet CP1025 and CP1025nw blurry print 3.11.[7 & 10]
+ HP LaserJet CP1025 and CP1025nw blurry print 3.11.[7 & 10 & 12]
Revision history for this message
Sirolf10 (florismartijnjansen) wrote : Re: HP LaserJet CP1025 and CP1025nw blurry print 3.11.[7 & 10 & 12]

For me, installing hpijs (sudo apt-get install hpijs) and then using the cups interface (http://localhost:631/ > Printers > select your printer > dropdown-menu which says 'Administration', select 'Modify' > click continue till you see the screen in the attachment) selecting the 'HP Laserjet cp1025nw hpijs, 3.11.7, requires proprietary plugin (en)' as model, worked.

Good luck!

Revision history for this message
Geb (gebhard-moser) wrote :

thanks for the hint !
I tried some things:
removed printer, added new one manually from different entries (I have already fragments of 3.11.7 till 3.11.12 on my laptop),
but unfortunately it didn't work (missing filter...),
anyway, a bit too complicated for me :-P

hope we get this solved in next version...

Revision history for this message
Geb (gebhard-moser) wrote :

Installed the new version of hplip (3.12.2):
Installation procedure went fine without having troubles, but unfortunately still the same printing result... :-(

summary: - HP LaserJet CP1025 and CP1025nw blurry print 3.11.[7 & 10 & 12]
+ HP LaserJet CP1025 and CP1025nw blurry print 3.11.[7 & 10 & 12] & 3.12.2
Revision history for this message
Marcus S. (martux76) wrote :

This is ridiculous. You know what HP? I sold this crap and will *never* ever buy another HP device again. Also none of my friends as I am in charge of administering their computers. They listen to me. HP sold this device with Linux support, I bought it for exactly that reason *only*. Not even 1 single driver version is working, so there is no support on Linux. It sucks. Thank you for wasting my time and money HP.

Revision history for this message
Bernhard Weller (bernhardweller) wrote :

I'm encountering this issue on a completely different printer, namely a Konica Minolta / QMS Magicolor 2300 DL. What both these printers have in common is that they use the same ZJStream protocol (from my understanding that is).
I'm not entirely sure, but the maintainer of foo2zjs has pointed out that there is a bug in ghostscript (which is used inside the printing process) which messes up the printing result when colour printing is used.

In the INSTALL file of the foo2zjs there is a sort of workaround detailed which worked fine for me (that is, installing a ghostscript version which is not buggy) - taken from the INSTALL file by Rick Richardson:
* ghostscript 8.64 is broken w.r.t. color. Don't use!

    * ghostscript 9.00 is broken w.r.t. fonts in landscape mode.

    * ghostscript 9.+ is broken w.r.t. color. Don't use

    * Well Tempered Screening (WTS) works with ghostscript 8.54 thru 8.70+.
      So if you want BEST COLORS, you'll have to install gs 8.54 or better
      if you don't have it.

 $ gs --version
 8.15.2

 $ wget "http://mirror.cs.wisc.edu/pub/mirrors/ghost/GPL/gs871/ghostscript-8.71.tar.gz"
 $ tar zxf ghostscript-8.71.tar.gz
 $ cd ghostscript-8.71
 $ ./autogen.sh
 $ make
 $ su OR $ sudo cp bin/gs /usr/bin/gs.foo
 # cp bin/gs /usr/bin/gs.foo

 (Optional)
 # make install OR $ sudo make install

 $ gs.foo --version
 8.71

      If that doesn't compile (e.g. Ubuntu 11.10+), try this:
 $ cd ghostscript-8.71
 $ ./configure --without-jbig2dec
 $ make CFLAGS+="-DHAVE_SYS_TIME_H=1"

Maybe someone having the same issue with the HP printer can try this and see if it fixes the issue, if yes, then probably not the driver itself is at fault but probably ghostscript (well I'd very much like to see some kind of warning message and pointing to a fix instead of searching for this solution by myself, so maybe a version blacklist of ghostscript could be incorporated somehow into the driver...)

Revision history for this message
DSF (felejteni) wrote :

Hi Bernhard,

Well I'm certain ghostscript is not the issue here, as I used the same ghostscript version with both drivers, and while foo2zjs works, HPLIP does not.

I believe the problem has to do with the black plane separation, but I don't know much about printers... I leant a bit about it with all of this, so I should thank HP for giving me the oportunity.

So long.

Revision history for this message
Kyrylo Bohdanenko (kyrboh) wrote :

Hello everyone,
It seems like I've found a 'workaround' of some kind.

There's an issue with printer 'profile': when I'm configuring USB printer via 'hp-setup' ubuntu creates another one (which works fine and has default name, e.g: HP_LaserJet_CP1025nw) and when using original created 'profile' the printing output is blurred.

I'm using (k)ubuntu 11.10 and HPLIP 3.12.2.

See 'diff -u ${original_created_ppd} ${ubuntu_created_ppd}' in /etc/cups/ppd in attachments.

Any doubts?

Revision history for this message
Kyrylo Bohdanenko (kyrboh) wrote :

Oh, I've found that ubutntu-generated ppd file can do the trick (just say 'Use ppd file' when configuring priner).

See attachment.

Revision history for this message
Geb (gebhard-moser) wrote :

@Kirill: thanks for that solution ! !
(you should get rewarded from HP)

@Goutam: as you are assigned to that bug, please take your responsibility and verify and update that file in the next release, that a manual workaround is no longer needed !
Please consider that this comparable small correction needed external input and several months to be solved...

Revision history for this message
DSF (felejteni) wrote :

Um... Geb, take a good look at the PPD. It does not make use of HPLIP... (sic).

Revision history for this message
Geb (gebhard-moser) wrote :

yes, you might be right.
But this is definitely the easiest solution for me (just to install the ppd file), as it works with that.
May the solution is not to make use of the HPLIP ?
Is there a reason not to apply that workaround ?

Revision history for this message
DSF (felejteni) wrote :

@Geb: No, no, just fix your setup, but keep in mind this is not just a file patch. The PPD requires the foo2zjs driver.

HP claims to support this device and keeps users confused about it. They should either fix it for good or stop claiming so, making people upset.

Or maybe they should just support foo2zjs! I'd rather prefer it that way, as I hate the proprietary bit. It reminds me of a Samsung printer that I used to have, that also claimed linux support.

Cheers.

Revision history for this message
Geb (gebhard-moser) wrote :

thx for information !
I agree, the support is not sufficient for that product line.
As I couldn't use that HP printer all the months now, I bought an old an used Kyocera Laser Printer (very cheap for sure).

This is really plug and play, no download of whatever crazy ppd or plugin or something weird, just connect and print and perfect print quality !

What brands would you recommend?

Revision history for this message
DSF (felejteni) wrote :

Ha, ha, no... I'm really not that much into printers!

Good point!

Revision history for this message
Haluk (vahabo) wrote :

Hello everybody,
Here is my solution with the "blurry text -in black- problem of HP cp1025" in Ubuntu 11.10.
I first of all installed hpijs packages from the synaptics. Secondly changed hpcups option with hpijs in the printer drivers option. Simply opened "printer properties" by a right-click on the printer (in system-config-printer) , selected Make and Model change, selected HP and Lazerjet cp1025 and on the right window selected hpijs.

Hope this will work for others.

Revision history for this message
Geb (gebhard-moser) wrote :

thanks for the input !

is there someone from hplip taking care about this issue ??

the printer is still marked as fully functional and recommended, although it is well known that this is not the case.
(http://hplipopensource.com/hplip-web/models/laserjet/hp_laserjet_cp1025.html)

maybe this is new HP strategy to present their products and to take care about customers...

Revision history for this message
Sanjay Kumar (sanjay-kumar14) wrote :

Hello Geb /All ,

Sorry for the late response and all the inconvenience caused because of this issue. We are looking into this issue. Just wanted to provide you the update.

On hplip 3.12.2 on Ubuntu 11.10 64 bit machine
ghostscript 8.71 => Prints fine
ghostscript 9.04 => Blurry Printing
ghostscript 9.05 => Blurry Printing

We will find the root cause of the issue and fix it ASAP.

Thanks,
Sanjay

Changed in hplip:
assignee: goutamkk (goutam-hplip) → Sanjay Kumar (sanjay-kumar14)
Revision history for this message
Sanjay Kumar (sanjay-kumar14) wrote :

Hello All,

Please find the fix/patch for the issue in the attachment. Below are the steps to apply the patch.

Steps to apply Patch:
---------------------------
1) Follow Step 1 and Step 2 from http://hplipopensource.com/hplip-web/install/install/index.html

2) Apply attached patch to file(prnt/hpcups/HPCupsFilter.cpp) inside the extracted directory "hplip-3.12.2" present in the same directory where hplip-3.12.2.run is present.
(Either apply changes or replace the whole function from diff )

3) cd hplip-3.12.2

4) python install.py

5) Follow remaining steps (from step 3 to Last step from http://hplipopensource.com/hplip-web/install/install/index.html)

6) Try to print Now.

Sorry for the inconvenience caused.

Thanks,
Sanjay

Changed in hplip:
status: In Progress → Fix Committed
Revision history for this message
DSF (felejteni) wrote :

Hi Sanjay,

You are on to something, but not quite yet.

At first the patch didn't apply because of DOS line endings in "HPCupsFilter.cpp", I had to remove them first (search for "^M in vim"), but then all went as expected (sort of).

The blur has disappeared, in fact, but now black text appears as dim gray instead.

Well, keep up the good work!

Revision history for this message
Sanjay Kumar (sanjay-kumar14) wrote :

Hi,

Thanks for the update. Actually there was a small mistake because of which black color printing was failing.
Please change following things inside my changes.

kVal = pixel_value[k]; to kVal |= pixel_value[k];

and

kVal = 0; to kVal |= 0;

I am attaching the corrected patch as well.

Thanks,
Sanjay

Revision history for this message
DSF (felejteni) wrote :

Yes, that finally made it, thanks, Sanjay!

Perfect print. :)

Revision history for this message
dusoft (dusoft-staznosti) wrote :

I have tried to reinstall with the patch used, but it comes out even more blurry then when using hplips here.

Revision history for this message
dusoft (dusoft-staznosti) wrote :

Any news? Still a huge blurry problem!

Revision history for this message
Sanjay Kumar (sanjay-kumar14) wrote :

Hi,

Many people have confirmed that the issue is fixed for them. May be you are missing something to do. Please wait for some some more time as HPLIP next release (hplip-3.12.4) is scheduled within a few days or so. Installing that should fix the problem for you.

Or else please follow the below mentioned steps so that I can analyze the issue .
 a)Open /etc/cups/cupsd.conf in root mode and replace

        LogLevel warn

          with

       LogLevel debug
       hpLogLevel 15

    b) Open Terminal and run following commands:
       => su
       => /etc/init.d/cups restart
                  or
          service cups restart

       => rm /tmp/*.out /tmp/*.bmp
       => cat /dev/null > /var/log/cups/error_log
       => cat /dev/null > /var/log/messages
       => cat /dev/null > /var/log/syslog
       => hp-check -t > /tmp/hpcheck.log

    c) Try to print any document and then please send following files
          => /var/log/syslog (if present),
          => /var/log/messages (if present),
          => /var/log/cups/error_log
          => /tmp/*.bmp
          => /tmp/*.out
          => /tmp/hpcheck.log
          => document used for printing
         => gs -v (output of this command)

Revision history for this message
Sanjay Kumar (sanjay-kumar14) wrote :

Fix is now available for the issue in HPLIP-3.12.4 release.
http://sourceforge.net/projects/hplip/files/hplip/3.12.4/hplip-3.12.4.run/download

Changed in hplip:
status: Fix Committed → Fix Released
Revision history for this message
Patrick (plgs) wrote :

Sanjay, updating to hplip-3.12.4 did not fix the problem for me: still get blurred black text (graphics seem OK).
I also went through your suggestions in comment 66, but that didn't fix it for me either.
Any other suggestions?

HP Color LaserJet CP1215
Fedora 15

Thanks,
Patrick.

Revision history for this message
Sanjay Kumar (sanjay-kumar14) wrote :

Hi,

Thanks for the update. To help us understand and analyze the issue please follow following things.

=> Download and install the latest HPLIP release from http://hplipopensource.com/hplip-web/install/install/index.html:
=> Reconfigure print queue with the commands mentioned below.
       =>system-config-printer (remove all print queues)
                     or
         Go to system ->Administration -> printing (then remove all print queues)
       =>hp-setup (for adding print queue)

=>Enable/Clear Logs as mentioned below

    a)Open /etc/cups/cupsd.conf in root mode and replace

        LogLevel warn

          with

       LogLevel debug
       hpLogLevel 15

    b) Open Terminal and run following commands:
       => su
       => /etc/init.d/cups restart
                  or
          service cups restart

       => rm /tmp/*.out /tmp/*.bmp
       => cat /dev/null > /var/log/cups/error_log
       => cat /dev/null > /var/log/messages
       => cat /dev/null > /var/log/syslog
       => hp-check -t > /tmp/hpcheck.log
       => gs -v > /tmp/gs.log

    c) Try to print any document and If issue is not resolved then please send following files
          => /var/log/syslog (if present),
          => /var/log/messages (if present),
          => /var/log/cups/error_log
          => /tmp/*.bmp
          => /tmp/*.out
          => /tmp/hpcheck.log
          =>/tmp/gs.log
          => document used for printing

    d) Please let me know the application used for testing.

Revision history for this message
Patrick (plgs) wrote :

Thanks for your prompt response Sanjay.

I hadn't removed and re-setup the existing print-queue. So I just now did the following:
- removed existing print queue;
- re-installed the hplip-3.12.4 driver (following the instructions on the website you mentioned); and
- re-added the print queue (in fact, the installer added this for me).

I confirm that once I had gone through those steps, the problem is resolved for me, ie, text is back to laser quality.

This is a huge relief - many thanks again.

Best regards,
Patrick.

Revision history for this message
Geb (gebhard-moser) wrote :

I used a freshly installed Linux Mint 12 64bit to verify:
- downloaded the hplip-3.12.4 image
- started the automatic installation procedure with the default choices
- after around 25 minutes the installation finished.

printing a page that previously failed succeeded now !

only one small issue just came to my attention, that there were two printers finally to select, one with the extension _2 (like HP_Laserjet_CP1025_2), maybe this occured as I probably didn't connect exactly the right time during installation process.

finally thanks to Sanjay for solving this !

(would be great if this package is part of Ubuntu 12.04, hopefully I'm not too optimistic)

Revision history for this message
Daniel (dananay) wrote :

FIXED!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Hey plox, FYI, I happened to fix the problem on my Ubuntu (12.04 build)
Go to settings after clicking on the HP toolbox icon

(by the way I have 2 printers, no idea how, though.... awesome)

Set the printer to print in greyscale only.
Go to LibreOffice and simply print the docs wihtout selecting greyscale, just go with the usual printer setup.
It will print in color mode but with perfect sharp edges :)

(I have a CP1025 printer)

I hope that you all will find this post helpful, good luck, guys!

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.