Comment 2 for bug 864656

Sanjay,

Thanks for your response. I tried to do what you said.

HP toolbox comes up with two error boxes in corner;
        HPLIP Device Status; Officejet_4500_G510a-f Printer(CN....); Device communication error(5012)
    and the same for FAX.

The console message is:

HP Linux Imaging and Printing System (ver. 3.11.3a)
HP Device Manager ver. 15.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: Reportlab not installed. Fax coverpages disabled.
warning: Please install version 2.0+ of Reportlab for coverpage support.

I selected Officejet on the left but saw nothing about a print queue.

When I went to printer control and tried to select as default printer, the console message was:

error:  Set printer queue as default operation fails. Could not connect to CUPS Server  Is user added to "lp" group(s)

This is pretty complicated. Any suggestion would help.

===Bob Armstrong===

________________________________
From: Sanjay Kumar <email address hidden>
To: <email address hidden>
Sent: Sunday, October 2, 2011 10:10 PM
Subject: [Bug 864656] Re: HP-SETUP does not detect Officejet_4500_G510a

Hi,

Thanks for reporting the bug. Can you try following things?

1) Open terminal and run "hp-toolbox" command.
2) On left hand side please select Officejet..  print queue.
3) Go to "Printer control " Tab and then press "Set as Default"
4) Now you can run "lpr textfile" command for printing.

Thanks,
Sanjay

** Changed in: hplip
    Assignee: (unassigned) => Sanjay Kumar (sanjay-kumar14)

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/864656

Title:
  HP-SETUP does not detect Officejet_4500_G510a

Status in HP Linux Imaging and Printing:
  New

Bug description:
  Use Slackware 13.37. Had a Deskjet 1000 which broke.  Deskjet remains
  default printer. "lpr -P Officejet... textfile" prints to Officejet.
  HPLIP (ver.3.11.3a) detects both Deskjet and "Officejet 4500 G510a-f",
  printer and FAX. hp-setup says it finds no devices. If HPLIP finds it,
  why cannot hp-setup? (And question: how get rid of Deskjet 1000 as
  default printer?)

To manage notifications about this bug go to:
https://bugs.launchpad.net/hplip/+bug/864656/+subscriptions