HPLIP only works with python version 2.* and should call "python2" instead of "python"

Bug #718069 reported by Rémy Oudompheng on 2011-02-13
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
hplip (Arch Linux)
New
Undecided
Unassigned

Bug Description

The HPLIP software cannot run with python 3.x, but no check is performed in the configure script and most scripts are executed by calling the "python" command which may refer to python 3.x.

Calling the "python2" command is unambiguous and should work everywhere. The Archlinux distribution is affected by this problem.

I attached a patch with the changes I would see included.

WebDawg (webdawg) wrote :

It should really do this. 1 year later and it is still pulling python3 in archlinux.

Jonas Platte (jplatte) wrote :

This bug really is annoying and there even is a patch for it, why hasn't this been resolved years ago?

goutam kodu (goutam-hplip) wrote :

Hi Johas,

Porting hplip to work in python 3 environment is in progress we will be releasing the package very soon.

Rgds,
Goutam

Changed in hplip:
status: New → Fix Committed
Sanjay Kumar (sanjay-kumar14) wrote :

Changing status to "Fix released" as Python3 support is now available in HPLIP-3.15.2 version.

Changed in hplip:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers