No way to disable HP Smart Install under Linux

Bug #672134 reported by Josselin Mouette on 2010-11-07
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Sanjay Kumar

Bug Description

I just bought a LaserJet P1102, because the HPLIP site states it has “full support” under Linux, and it is even part of the recommended models.

However without a Windows installation, it is just a brick. Thanks to HP Smart Install, it shows up as a fake USB cdrom drive. Of course hp-setup doesn’t manage to communicate with it in this state, and it doesn’t feature a way to switch it back to being a printer.

The driver CD contains a Windows executable to disable this “feature”, named SIUtility.exe. Please provide the sources for this tool, or at least the technical specifications of HP Smart Install, so that it can be disabled automatically using the existing usb_modeswitch utility.

Yash (yashwant-k-sahu) wrote :

Yes this is true that in Linux we do not provide tool similar to windows SIUtility tool. Sorry for Inconvenience. We may take this for future enhancement.

Thanks and Regards

Changed in hplip:
status: New → Confirmed
dudinea (dudinea) wrote :

I had the same problem with my P1102. I did some USB sniffing and managed monitoring I've managed to disable the Smart Install 'feature' using the usb_modeswitch utility instead of the windows SIUtility.exe tool. After issuing the command you need to power cycle the printer, usb reset isn't enough.

usb_modeswitch -m 2 -r 2 -v 0x03f0 -p 0x002a -M 505554202F6465762F666561747572655374617475732E786D6C20485454502F312E310D0A434F4E54454E542D4C454E4754483A203232320D0A555345522D4147454E543A68702050726F78792F332E300D0A484F53543A6C6F63616C686F73743A333931300D0A0D0A3C3F786D6C2076657273696F6E3D22312E302220656E636F64696E673D225554462D38223F3E0D0A3C6665617475726553746174757320786D6C6E733A7873693D22687474703A2F2F7777772E77332E6F72672F323030312F584D4C536368656D612D696E7374616E636522207873693A6E6F4E616D657370616365536368656D614C6F636174696F6E3D22666561747572655374617475732E787364223E0D0A20203C736D617274496E7374616C6C3E64697361626C65643C2F736D617274496E7374616C6C3E0D0A3C2F666561747572655374617475733E0D0A0D0A -n -2 474554202F6465762F666561747572655374617475732E786D6C20485454502F312E310D0A434F4E54454E542D4C454E4754483A20300D0A555345522D4147454E543A68702050726F78792F332E300D0A484F53543A6C6F63616C686F73743A333931300D0A0D0A -n -R

Reverse operation is possible as well:
usb_modeswitch -m 2 -r 2 -v 0x03f0 -p 0x002a -M 505554202F6465762F666561747572655374617475732E786D6C20485454502F312E310D0A434F4E54454E542D4C454E4754483A203232310D0A555345522D4147454E543A68702050726F78792F332E300D0A484F53543A6C6F63616C686F73743A333931300D0A0D0A3C3F786D6C2076657273696F6E3D22312E302220656E636F64696E673D225554462D38223F3E0D0A3C6665617475726553746174757320786D6C6E733A7873693D22687474703A2F2F7777772E77332E6F72672F323030312F584D4C536368656D612D696E7374616E636522207873693A6E6F4E616D657370616365536368656D614C6F636174696F6E3D22666561747572655374617475732E787364223E0D0A20203C736D617274496E7374616C6C3E656E61626C65643C2F736D617274496E7374616C6C3E0D0A3C2F666561747572655374617475733E0D0A0D0A -n -2 474554202F6465762F666561747572655374617475732E786D6C20485454502F312E310D0A434F4E54454E542D4C454E4754483A20300D0A555345522D4147454E543A68702050726F78792F332E300D0A484F53543A6C6F63616C686F73743A333931300D0A0D0A -n -R

Still haven't figured out how to make the fake CD go away automatically, as the windows driver does.

Manjul Apratim (manzdagratiano) wrote :


I had this problem with an HP Laserjet P1606dn - I searched for a solution for months to no avail, but this looked promising... The printer is indeed registered as a CDROM upon plugging in, and all methods to make hplip communicate with it had been to no avail.

I tried to use SIUtility.exe, to no avail, since it woud not recognize the printer and there seemed to be no option to browse for it. I tried the usb_modeswitch, and though it initially segfaulted on me, I discovered that the switches `-m 2 -r 2` are optional, and that messages and response end points are determined by the device itself (sure enough, they were different). I assumed that aside from the vendor/product ids, the HEX strings should be the same, since this SmartInstall utility is universal for the newer HP printers.

I am now happily printing on the machine!

Sanjay Kumar (sanjay-kumar14) wrote :

Working on supporting smart install disable from Linux.

Changed in hplip:
assignee: nobody → Sanjay Kumar (sanjay-kumar14)
status: Confirmed → In Progress
deew (dee-wykoff) wrote :

Sanjay, hope you come up with a fix for this. I have a cp1525nw color laserbrick that is affected by this bug. Thanks.

dq (dpquinton) wrote :

we REALLY need a solution -Linux-based- PLEASE SANJAY !

hard-writing over the autorun file? can/should that be done??

dq (dpquinton) wrote :

OK that's worked for me DUDINEA's post and MANJUL's post about leaving out the switches.

I've never heard of such a program for Linux. This solution is in short a miracle for me. (My heart was racing while I tried Test page!)

Great stuff. Thanks guys for posting the solution.

Marcos (gimenezmax) wrote :

Hello. I solved doing printer off, turn on printer, and then begin installing the drivers. I could do direct installation via USB. Saludos

Chris (fabricator4) wrote :

Is there still no solution for this? I do not have a Windows machine to run SIUtility to turn autoinstall off.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers