Hplip No devices found on bus: usb

Bug #535056 reported by jena on 2010-03-09
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned

Bug Description

Hello!!!
I bought a new hp photosmart q8433b (b109a) that like you can see on hplip site http://hplipopensource.com/hplip-web/models/photosmart/photosmart_b109a_series.html is supported.
The printer is correctly power on and connected to the computer like you can see:

Bus 001 Device 003: ID 03f0:7a11 Hewlett-Packard
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 046d:c517 Logitech, Inc. LX710 Cordless Desktop Laser
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

But when i try to install with hp-setup i receive the error No devices found on bus: usb:

HP Linux Imaging and Printing System (ver. 3.10.2)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Searching... (bus=usb, search=(None), desc=0)
error: No devices found on bus: usb

Done.

If i run hp-check i receive the errore that the printer is not supported:

HP Linux Imaging and Printing System (ver. 3.10.2)
Dependency/Version Check Utility ver. 14.3

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and run-time dependencies).

Saving output in log file: hp-check.log

Initializing. Please wait...

---------------
| SYSTEM INFO |
---------------

Basic system information:
Linux alex 2.6.28-15-generic #52-Ubuntu SMP Wed Sep 9 10:49:34 UTC 2009 i686 GNU/Linux

Distribution:
ubuntu 9.04

Checking Python version...
OK, version 2.6.2 installed

Checking PyQt 4.x version...
OK, version 4.4.4 installed.

Checking for CUPS...
Status: la stampa programmata è in esecuzione
Version: 1.3.9
error_log is set to level: warn

Checking for dbus/python-dbus...
dbus daemon is running.
python-dbus version: 0.83.0

------------------------------------
| COMPILE AND RUNTIME DEPENDENCIES |
------------------------------------

note: To check for compile-time only dependencies, re-run hp-check with the -c parameter (ie, hp-check -c).
note: To check for run-time only dependencies, re-run hp-check with the -r parameter (ie, hp-check -r).

Checking for dependency: CUPS - Common Unix Printing System...
OK, found.

Checking for dependency: CUPS devel- Common Unix Printing System development files...
OK, found.

Checking for dependency: CUPS image - CUPS image development files...
OK, found.

Checking for dependency: DBus - Message bus system...
OK, found.

Checking for dependency: gcc - GNU Project C and C++ Compiler...
OK, found.

Checking for dependency: GhostScript - PostScript and PDF language interpreter and previewer...
OK, found.

Checking for dependency: libcrypto - OpenSSL cryptographic library...
OK, found.

Checking for dependency: libjpeg - JPEG library...
OK, found.

Checking for dependency: libnetsnmp-devel - SNMP networking library development files...
OK, found.

Checking for dependency: libpthread - POSIX threads library...
OK, found.

Checking for dependency: libtool - Library building support services...
OK, found.

Checking for dependency: libusb - USB library...
OK, found.

Checking for dependency: make - GNU make utility to maintain groups of programs...
OK, found.

Checking for dependency: PIL - Python Imaging Library (required for commandline scanning with hp-scan)...
OK, found.

Checking for dependency: PolicyKit - Administrative policy framework...
OK, found.

Checking for dependency: PyQt 4 DBus - DBus Support for PyQt4...
OK, found.

Checking for dependency: Python DBus - Python bindings for DBus...
OK, found.

Checking for dependency: Python devel - Python development files...
OK, found.

Checking for dependency: Python libnotify - Python bindings for the libnotify Desktop notifications...
OK, found.

Checking for dependency: Python XML libraries...
OK, found.

Checking for dependency: Python 2.3 or greater - Required for fax functionality...
OK, found.

Checking for dependency: Python 2.2 or greater - Python programming language...
OK, found.

Checking for dependency: Reportlab - PDF library for Python...
OK, found.

Checking for dependency: SANE - Scanning library...
OK, found.

Checking for dependency: SANE - Scanning library development files...
OK, found.

Checking for dependency: scanimage - Shell scanning program...
OK, found.

Checking for dependency: xsane - Graphical scanner frontend for SANE...
OK, found.

----------------------
| HPLIP INSTALLATION |
----------------------

Currently installed HPLIP version...
HPLIP 3.10.2 currently installed in '/usr/share/hplip'.

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.10.2

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.10.2
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp

# Following values are determined at configure time and cannot be changed.
[configure]
network-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=no
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.10.2rc1.9
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
policy-kit=yes
hpijs-only-build=no
lite-build=no
udev-acl-rules=no
hpcups-only-build=no
hpijs-only-build=no

Current contents of '/var/lib/hp/hplip.state' file:
# hplip.state - HPLIP runtime persistent variables.

[plugin]
installed=0
eula=0

Current contents of '~/.hplip/hplip.conf' file:
[installation]
version = 3.10.2rc1.9
date_time = 09/03/2010 14:43:34

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

q8433
-----
Type: Printer
Device URI: hp:/usb/Photosmart_B109a-m?serial=CN998750W905C7
PPD: /etc/cups/ppd/q8433.ppd
PPD Description: HP Photosmart b109a Series, hpcups 3.10.2
Printer status: la stampante q8433 è in attesa. Abilitata da mar 09 mar 2010 14:37:11 CET

HP Linux Imaging and Printing System (ver. 3.10.2)
System Tray Status Service ver. 2.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: Unsupported model: Photosmart_B109a-m
error: Communication status: Failed

----------------------
| SANE CONFIGURATION |
----------------------

'hpaio' in '/etc/sane.d/dll.conf'...
OK, found. SANE backend 'hpaio' is properly set up.

Checking output of 'scanimage -L'...

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

---------------------
| PYTHON EXTENSIONS |
---------------------

Checking 'cupsext' CUPS extension...
OK, found.

Checking 'pcardext' Photocard extension...
OK, found.

Checking 'hpmudext' I/O extension...
OK, found.

Checking 'scanext' SANE scanning extension...
OK, found.

-----------------
| USB I/O SETUP |
-----------------

Checking for permissions of USB attached printers...

HP Device 0x7a11 at 001:003:
    Device URI: hp:/usb/Photosmart_B109a-m?serial=CN998750W905C7
error: Unsupported model: Photosmart_B109a-m

---------------
| USER GROUPS |
---------------

alex adm lp dialout cdrom plugdev lpadmin admin sambashare

-----------
| SUMMARY |
-----------

error: 1 error or warning.

Please refer to the installation instructions at:
http://hplip.sourceforge.net/install/index.html

Done.

I run ubuntu 9.04 and hp lip versione is 3.10.2 but i had same problem on antoher computer with debian lenny and the same versione of hplip.
The printer work with no problem with cups...
Thank you!!!

Szabolcs Seláf (selu) wrote :

I had similar issue with my Photosmart Premium C309g on Ubuntu 9.10
it can be fixed by adding the following line to /etc/udev/rules.d/40-hplip.rules

ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="7d11", GROUP="lp", ENV{ID_HPLIP}="1"

maybe using "??11" for idProduct can solve this issue for other Photosmart AIOs, too.

Andreas Pürzer (pue) wrote :

Unfortunately, Selus Answer didnt help me...
But the answer from Mubeen Jukaku in Question 104400 did!
https://answers.launchpad.net/hplip/+question/104400
Let me quote:
Open /usr/share/hplip/data/models/models.dat as root(sudo)
replace photosmart_b109a_series with photosmart_b109a-m

connect your printer through USB.
run "lsusb" command

note bus id and device id of printer.
then, run "hp-setup bus-id:device:id"

Post the output here,

Thanks!
Naga Samrat Chowdary, Narla.

connect your printer through USB.
run "lsusb" command

note bus id and device id of printer.
then, run "hp-setup -g bus-id:device:id"

Post the output here,

Thanks!
Naga Samrat Chowdary, Narla.

Hello,

Same issue on Fedora 12 with hplip 3.10.5
comment #2 fixed the issue thank you very much !

What is strange is that it worked perfectly a few months ago. I suspect a regression here ...

Is there any chance we get a patch for this ?

As per comment #4 here are the requested info :

lsusb :
Bus 002 Device 002: ID 046d:08d7 Logitech, Inc. QuickCam Communicate STX
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 03f0:7a11 Hewlett-Packard
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

[root@grogro ~]# hp-setup -g 001:003

HP Linux Imaging and Printing System (ver. 3.10.5)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

hp-setup[3001]: debug: param=001:003
Searching for device...
hp-setup[3001]: debug: Trying USB with bus=001 dev=003...
hp-setup[3001]: debug: Found: hp:/usb/Photosmart_B109a-m?serial=MY98H410TZ05C7
hp-setup[3001]: debug: hp:/usb/Photosmart_B109a-m?serial=MY98H410TZ05C7: back_end:hp is_hp:True bus:usb model:Photosmart_B109a-m serial:MY98H410TZ05C7 dev_file: host: zc: port:1
hp-setup[3001]: debug: Cache miss: photosmart_b109a-m
hp-setup[3001]: debug: Reading file: /usr/share/hplip/data/models/models.dat
hp-setup[3001]: debug: Searching for section [photosmart_b109a-m] in file /usr/share/hplip/data/models/models.dat
error: Device not found. Please make sure your printer is properly connected and powered-on.
hp-setup[3001]: debug: Starting GUI loop...

Done.

As per comment #2 and above error the issue is clearly with missing [photosmart_b109a-m] section in /usr/share/hplip/data/models/models.dat

description: updated

40-hplip.rules file has an entry to check for Photosmart_B109a-m printer.

Thanks!
Naga Samrat Chowdary, Narla.

Changed in hplip:
status: New → Triaged
status: Triaged → Fix Committed

Thanks a lot for the quick integration !

I have a quick question : is hplip source code repository available somewhere ? I have only found the source code of each release, not development snapshots.

I would like to make a patch with this fix and rebuild the corresponding package on my favorite distro ...

Thank you very much again,
Cheers,

Chicha

Valerio Accot (glorfindel) wrote :
Download full text (8.2 KiB)

Hi,

I have a problem in getting working my Photosmart b109a printer through hplip.
I think I have a problem with usb bus in recognizing the printer, I think.

I post the make uri and hp ckeck.
------------------------------------------------------------
seph@Laptop:~$ hp-makeuri -g 005:003

HP Linux Imaging and Printing System (ver. 3.10.5)
Device URI Creation Utility ver. 5.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

hp-makeuri[8384]: debug: Trying USB with bus=005 dev=003...
hp-makeuri[8384]: debug: Not found.
hp-makeuri[8384]: debug: Trying serial number 005:003
hp-makeuri[8384]: debug: Probing bus: usb
hp-makeuri[8384]: debug: Probing bus: par
error: Device not found
-------------------------------------------------------------------------------

seph@Laptop:~$ hp-check

HP Linux Imaging and Printing System (ver. 3.10.5)
Dependency/Version Check Utility ver. 14.3

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if the proper
dependencies are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and run-time dependencies).

Saving output in log file: hp-check.log

Initializing. Please wait...

---------------
| SYSTEM INFO |
---------------

Basic system information:
Linux Laptop 2.6.26-2-486 #1 Mon Jun 21 05:12:58 UTC 2010 i686 GNU/Linux

Distribution:
debian 5.0.5

Checking Python version...
OK, version 2.5.2 installed

Checking PyQt 4.x version...
OK, version 4.4.2 installed.

Checking for CUPS...
Status: la stampa programmata è in esecuzione
Version: 1.3.8
error_log is set to level: warn

Checking for dbus/python-dbus...
dbus daemon is running.
python-dbus version: 0.82.4

------------------------------------
| COMPILE AND RUNTIME DEPENDENCIES |
------------------------------------

note: To check for compile-time only dependencies, re-run hp-check with the -c parameter (ie, hp-check -c).
note: To check for run-time only dependencies, re-run hp-check with the -r parameter (ie, hp-check -r).

Checking for dependency: CUPS - Common Unix Printing System...
OK, found.

Checking for dependency: CUPS devel- Common Unix Printing System development files...
OK, found...

Read more...

Can you please download latest release of HPLIP 3.10.6 and install.

Thanks,
Naga Samrat Chowdary, Narla

Changed in hplip:
status: Fix Committed → Fix Released
Valerio Accot (glorfindel) wrote :

Thank you for your reply,

I have installed the 3.10.6 hplip, and now when I type "hp-setup" the GUI HP setup interface appears, but the problem is still there and it seems that there are no printers connected via USB even if my printer is powered on and USB connected. So there are no devices suggested in the GUI of hp-setup and the installation blocks.

I attach make-uri setup and hp-check -t.

Thanks a lot.

Valerio

Valerio Accot (glorfindel) wrote :

This is the output of "hp-check -t".

Thanks,

Valerio

Valerio Accot (glorfindel) wrote :

Any idea? Thanx a lot.

Currently we are supporting upto Debian 5.0.4.

Looks like we need to configure HPLIP on your system please go to HPLIP 3.10.6 directory. and configure as follows
1. make clean
2. su -c "make uninstall"
3. /configure --prefix=/usr
4. make
5. su -c "make install"

Hope this Helps,
Naga Samrat Chowdary, Narla

Valerio Accot (glorfindel) wrote :

Thank you very much for your help.

I did whay you told.
Unfortunately that didn't solve the problem as Debian still cannot recognize any USB printer attached onto the USB bus.

Any other idea or will I have to wait that Debian 5.0.5 will be supported?

Thx a lot,

V

looks like user is not yet part of "lp" group.
I hope you have restarted your machine after installation.

1. Attach your printer
2. run lsusb command
3. find bus-id and device-id
4. please run "hpset -g bus-id:device-id" and post the output.

Thanks,
Naga Samrat Chowdary, Narla

Valerio Accot (glorfindel) wrote :

I have added "user" to the "lp" group. As you suggested, I wasn't in the lp group..

After reboot, my printer was able to print the printer test page!

Thank you very very much for your big help and kindness, :)

Valerio

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers