hp photosmart 7960 locks up in 64-bit fedora 12 and ubuntu 9.10

Bug #517324 reported by paul trader
This bug affects 2 people
Affects Status Importance Assigned to Milestone

Bug Description

In both 64-bit versions of fedora 12 and ubuntu 9.10, after hot-plugging the photosmart 7960 in a USB port, the printer is correctly recognized and configured. However, when attempting to print a document, or even a test page, the print dialog hangs, then indicates there was an error. Using the printing troubleshooter, the result is "Queue not enabled" due to the printer being "unplugged or turned off". When going back to the printer dialog, the enabled box is unchecked. The printer then becomes locked up, and must be unplugged in order to power back up. I have confirmed this behavior in both the 64-bit versions of Fedora 12 and Ubuntu 9.10. In Fedora 12, I've tried the latest rpm releases, and also the "test" releases:


The motherboard is Asus P7P55-LX w/ 4GB DDR3 RAM and Intel i5-750 LGA1156 2.66GHz CPU.

I recently upgraded from an older computer running Fedora 10 32-bit and this printer worked just fine in that release.

Revision history for this message
paul trader (fliptop) wrote :

I dug my old LaserJet 1022 out and it's working fine using the Foomatic/foo2xqx driver. Using the Admin utility, this driver is not available for the Photosmart.

Revision history for this message
Shakil (shakilk-deactivatedaccount) wrote :

Hi Paul,

Foomatic drivers are old and might not be available. Can you try downloading and installing the latest version of HPLIP from http://hplipopensource.com/hplip-web/index.html

You can look at the instruction found in link http://hplipopensource.com/hplip-web/install/manual/distros/ubuntu.html for 64-bit installation.


Revision history for this message
paul trader (fliptop) wrote :

Hi Shakil - OK, I tried what you suggested. With a stock install of Ubuntu 9.10, you'll need the following packages in order to make and build the drivers:


After following the instructions to make and install the drivers, I tried printing a test page. The results were the same. The printer hangs, the status changes to "Stopped - Unplugged or turned off" and the printer must be power cycled to get it to respond.

Regards, Paul

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.