HP Linux Imaging and Printing

packaging: udev rules should be in /lib/udev/rules.d

Reported by Olivier Mengué on 2009-12-24
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
Gentoo Linux
Fix Released
Medium
hplip (Ubuntu)
Undecided
Unassigned

Bug Description

The udev rules installed by hplip 3.9.8-1ubuntu2 are installed in /etc/udev/rules.d:
-rwxr-xr-- 1 root root 792 2009-12-11 13:57 86-hpmud-hp_laserjet_1000.rules
-rwxr-xr-- 1 root root 722 2009-12-11 13:57 86-hpmud-hp_laserjet_1005_series.rules
-rwxr-xr-- 1 root root 722 2009-12-11 13:57 86-hpmud-hp_laserjet_1018.rules
-rwxr-xr-- 1 root root 722 2009-12-11 13:57 86-hpmud-hp_laserjet_1020.rules
-rwxr-xr-- 1 root root 726 2009-12-11 13:57 86-hpmud-hp_laserjet_p1005.rules
-rwxr-xr-- 1 root root 726 2009-12-11 13:57 86-hpmud-hp_laserjet_p1006.rules
-rwxr-xr-- 1 root root 726 2009-12-11 13:57 86-hpmud-hp_laserjet_p1007.rules
-rwxr-xr-- 1 root root 726 2009-12-11 13:57 86-hpmud-hp_laserjet_p1008.rules
-rwxr-xr-- 1 root root 726 2009-12-11 13:57 86-hpmud-hp_laserjet_p1505.rules

According to /lib/udev/rules.d, /lib should be the right place for static rules installed by a package instead of /etc.
Also the rules are not recorded in dpkg.

Olivier Mengué (dolmen) wrote :

According to /lib/udev/rules.d/README

Daniel T Chen (crimsun) wrote :

Lucid has this fixed in a different manner.

Changed in hplip (Ubuntu):
status: New → Fix Released
Till Kamppeter (till-kamppeter) wrote :

The shown rules are not from the hplip package which Ubuntu ships but from the proprietary plug-in which gets installed when running the hp-plugin utility.

Changed in hplip (Ubuntu):
status: Fix Released → Invalid
Till Kamppeter (till-kamppeter) wrote :

As the plug-in is not shipped with Ubuntu it is an upstream-only bug.

Daniel T Chen, you did not see the bug in Lucid, as you most probably did not have the plugin installed.

Ben Sagal (bensagal) wrote :

in upstream 40-hplip.rules (or 55-hpmud.rules) and 56-hpmud_support.rules are also installed incorrectly in /etc/udev/rules.d/

Changed in gentoo:
status: Unknown → Confirmed

Is it possible to add a ./configure option for this path? On my platform udev is an optional package and the rules must be written to /opt/etc/udev/rules.d

Ben Sagal (bensagal) wrote :

I see that there is no fix in v3.11.1.

Is there any chance that there will be a fix in the next version of hplip, or at least a ./configure option.
It should be very easy to fix

Till Kamppeter (till-kamppeter) wrote :

Note that this is not a bug of the HPLIP core package (what comes with your distribution or what you download from the HPLIP web site). The files mentioned in the initial posting are all part of the proprietary plug-in (which you download via the commands hp-plugin or hp-setup). The plug-in is neither a Debian nor an RPM package, it is simply a bunch of files copied into the system after the download. The fix must be done by upstream as the plug-in is not shipped by the distributions.

Ben Sagal (bensagal) wrote :

if you look a comment 5, i said that 40-hplip.rules and 56-hpmud_support are installed incorrectly in /etc/udev/rules.d/ and this happens when installing from source, so it is a bug in the HPLIP core package.

Should I open a septate bug as i was referring to different files to the original reporter?

thanks

Changed in gentoo:
status: Confirmed → Fix Released
Changed in gentoo:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.