HP Linux Imaging and Printing

In Lucid, sysfs[] declarations need to be removed from 56-hpmud_support.rules

Reported by Michael Marley on 2009-12-02
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
hplip (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hplip

Since the latest udev upgrade in Lucid, udev has been complaining about the sysfs[] declarations in this file. They need to be removed.

Related branches

summary: - In Karmic, sysfs[] declarations need to be removed from
+ In Lucid, sysfs[] declarations need to be removed from
56-hpmud_support.rules
description: updated
Per Ångström (autark) wrote :

I see this warning every time I boot Lucid. It distracts me from spotting more important issues and is thus harmful to the testing process.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.9.12-2ubuntu2

---------------
hplip (3.9.12-2ubuntu2) lucid; urgency=low

  * debian/patches/udev-rules-use-attrs-not-sysfs.dpatch: Don't use
    deprecated syntax (LP: #491346)
 -- Daniel T Chen <email address hidden> Fri, 01 Jan 2010 16:23:37 -0500

Changed in hplip (Ubuntu):
status: New → Fix Released
Jano (jkotuc) wrote :

I doubt it's completely fixed. I'm running Lucid (upgraded from Karmic) with hplip 3.10.2-2ubuntu2 and almost all of the files in /etc/udev/rules.d use SYSFS, thus causing the distracting error messages at boot time.

An example from file 86-hpmud-hp_laserjet_1020.rules:

# hp_laserjet_1020
SUBSYSTEM=="usb_device", SYSFS{idVendor}=="03f0", SYSFS{idProduct}=="2b17", PROGRAM="/bin/sh -c 'X=%k; X=$${X#usbdev}; B=$${X%%%%.*}; D=$${X#*.}; logger -p user.info loading hp_laserjet_1020 firmware $$B $$D; printf %%03i:%%03i $$B $$D'", RUN+="/bin/sh -c '/usr/bin/hp-firmware -y3 -s%c &'"

Changed in hplip (Ubuntu):
status: Fix Released → Incomplete
Till Kamppeter (till-kamppeter) wrote :

The files in /etc/udev/rules.d com from HP's proprietary plugin, not from the HPLIP package itself, so this is a pure upstream bug, the Ubuntu package is OK.

Can someone at HP fix the proprietary plugin? Thanks.

Changed in hplip (Ubuntu):
status: Incomplete → Invalid
Changed in hplip:
status: New → Confirmed

@HP:
As of the next udev release (174) the SYSFS key will no longer work. The replacement ATTRS key has worked since udev-098 released in August 2006. It would be nice if this fix could go upstream so we could stop patching in the different distros.

Hi Tom E. Gundersen,

Thank you for providing detailed information. We will incorporate these changes in HPLIP from next release on wards.

Thanks & Regards,
Amarnath

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers