printing of A3 format impossible on Business Inkjet 2800

Bug #449581 reported by c_ellesley on 2009-10-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned

Bug Description

i tried
HP Business Inkjet 2800 pcl3, hpcups 3.9.8

The printr accepts the job, but prints only the A4 part of the page (when printing Portrait) or
when printing landscape, it prints the lower 2/3 of the paper with graphical elements missing

anup (osta6161) wrote :

Please run hp-check -t and post it here.

Thanks,

A

c_ellesley (archelegraph) wrote :

I noticed that the hplip-gui-tools didn't work - but i don't need to use them.
I installed hplip via packet-manager - why are not all dependencies installed?

printing results via postcript are not as good as those with pcl3 - thin lines which are not vertical or horizontal are thicker than they ought to be, this is very annoying since 45degrees hatch-lines should usually be thinner than other lines...

anup (osta6161) wrote :

From the log it looks the network support package is missing thus resulting into communication failure. Please search for this package and install. Below command will be useful to install the same.

sudo aptitude install --assume-yes libsnmp-dev

Thanks,

A

c_ellesley (archelegraph) wrote :

installed libsensors-dev libsnmp-dev libsnmp-perl libssl-dev libwrap0-dev
activated snmp v1/v2 read only on the printer
hp-check no reports communication:good
postcript-printing works fine without snmp - pcl-printing shouldn't need snmp for mere printing, or am I mistaken?
greetings, c

c_ellesley (archelegraph) wrote :

in #4 it should read hp-check now reports communication:good
sorry

anup (osta6161) wrote :

Below link can help you out in understanding the packages needed by hplip.

http://hplipopensource.com/hplip-web/install/manual/distros/other.html

hplip 3.9.10 release is now available. It will be good if you can install and let me know if that works for you.

Thanks for the support to hplip!

A

c_ellesley (archelegraph) wrote :

hplip 3.9.10 checks for package cups-ddk. this package doesn't exist. the package cupsddk is transitional. checking for it is obsolete anyway since cups ddk ist included in cups since ver 1.4

thus installed manually using:
./configure --with-hpppddir=/usr/share/ppd/HP --prefix=/usr --enable-udev-acl-rules --enable-qt4 --disable-doc-build --enable-cups-ppd-install --enable-foomatic-drv-install --enable-foomatic-ppd-install --enable-hpijs-install --enable-policykit --enable-cups-drv-install --enable-hpcups-install --enable-network-build --enable-dbus-build --disable-scan-build --disable-fax-build

on the BusinessInkjet2800 A4 via postscript works and testpage is centered, printing A4 via hplip/pcl3 works, but page is off-center: 2,5mm too far left and 1,8mm too far to the top,
printing A3 still does not work, only the A4 part in the upper left corner is printed, rest of the page is blank (centering is OK though)
all this was printed via
Device URI: dnssd://HP%20Business%20Inkjet%202800%20(00306EFB66D2)._pdl-datastream._tcp.local/
the printer didn't react to anything via
Device URI: hp:/net/HP_Business_Inkjet_2800?zc=NPIFB66D2

I have another A3-printer CP1700, it wouldn't install via hplip-gui, worked via ubuntu-printer-config as
hp:/usb/HP_Color_Inkjet_CP1700?serial=SG1BD2110H0T
hplip driver works on my CP1700 printer, but only A4 paper is possible (testpage is not centered, 2,5mm too far to the left)!
This is an A3 printer but there is no A3 papersize!

hp-check says to all printers with hp:/ URI:
error: Unable to communicate with device (code=12): hp:/net/HP_Business_Inkjet_2800?zc=NPIFB66D2
error: unable to open channel
error: Communication status: Failed

not on the sideline: hp-setup-gui installs the postscript-driver by default (maybe because this one works?)

VERY annoying: hplip starts sane if I plug in the CP1700 via usb - this is a bug too! (didn't i disable the sane-option?)

I might try other combinations (hpjis, foomatic) later, but 2 hours are enough for today - hope this helps
C

c_ellesley (archelegraph) wrote :
c_ellesley (archelegraph) wrote :

hello,
to advance things I installed 3.9.12 but the
bug is still there, only A4-portion of an A3-paper being printed.
thank you

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers