HP Linux Imaging and Printing

"hpcups" driver of HPLIP has broken margins

Reported by José Alburquerque on 2009-07-27
92
This bug affects 14 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
cups (Ubuntu)
Undecided
Martin Pitt
Nominated for Dapper by Mark Hedges
Nominated for Hardy by Mark Hedges
Nominated for Jaunty by Mark Hedges
Nominated for Karmic by Mark Hedges
Nominated for Lucid by Mark Hedges
Nominated for Maverick by Mark Hedges
hplip (Debian)
Fix Released
Unknown
hplip (Ubuntu)
High
Unassigned
Nominated for Dapper by Mark Hedges
Nominated for Hardy by Mark Hedges
Nominated for Jaunty by Mark Hedges
Nominated for Karmic by Mark Hedges
Nominated for Lucid by Mark Hedges
Nominated for Maverick by Mark Hedges

Bug Description

Binary package hint: hplip

Hi. I have an HP DeskJet D2600 connected via USB. When I turned the printer on, a default configuration named Deskjet-D2600-series (using the "HP Deskjet d2600 Series [en]" driver) was generated that I can see in the gnome printer configuration window. When I print a test page the contents has a big margin at the top and the bottom is cut off.

In the printer configuration if I change the driver to "HP Deksjet d2600 Series hpijs [en]" or "HP Deksjet d2600 Series hpijs 3.9.6b.4 [en]" the margin problem is corrected, but now black contents is printed in what looks like a combination of colors that appears black but looks more like dark brown.

What I'm hoping for is that the margins for the default driver are corrected. I can provide any information that might be needed. Thanks.

ProblemType: Bug
Architecture: amd64
Date: Sun Jul 26 23:03:14 2009
DistroRelease: Ubuntu 9.10
Lpstat: device for Deskjet-D2600-series: hp:/usb/Deskjet_D2600_series?serial=TH94M140BG05C9
Package: hpijs-ppds 3.9.6b-1ubuntu4
PackageArchitecture: all
Papersize: letter
PpdFiles: Deskjet-D2600-series: HP Deskjet d2600 Series, hpcups 3.9.6b
ProcCmdLine: root=UUID=06e1c48d-56bd-443b-8324-1975f908d414 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-4.22-generic
SourcePackage: hplip
Uname: Linux 2.6.31-4-generic x86_64
dmi.bios.date: 05/17/2006
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: AV8 (VIA K8T800P-8237)
dmi.board.vendor: http://www.abit.com.tw/
dmi.board.version: 1.x
dmi.chassis.type: 3
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd05/17/2006:svn:pn:pvr:rvnhttp//www.abit.com.tw/:rnAV8(VIAK8T800P-8237):rvr1.x:cvn:ct3:cvr:

Changed in hplip:
status: New → Confirmed
Changed in hplip (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Till Kamppeter (till-kamppeter) wrote :

I have observed this problem with several other HP printers. Since the introduction of the CUPS Raster driver "hpcups" the margins of the printouts are not correct any more. This is easiest to see with the Ubuntu test page which gets printed from system-config-printer. This is an upstream bug of HPLIP.

To the developers at HP:

It is possible that it is caused by my last fixes on the "cups" output device of Ghostscript to add support for new PPD keywords and fix the margin handling (Ghostscript SVN revisions 9691, 9701, 9702, 9712, 9713, 9721, 9746 in April/May this year). These changes appear as patch inm Karmic's Ghostscript and will be in the officially released Ghostscript from version 8.65 on which is due next week. If you can fix this only in a way that it breaks for Ghostscript 8.64 and older, add a "--with-gs865" option to ./configure, so that one can choose the adjustment for either the old buggy "cups" output device or the new fixed one.

So please test with Ubuntu Karmic.

summary: - HP Deskjet d2600 Series default ppd file has wrong margins
+ "hpcups" driver of HPLIP has broken margins
Tim Waugh (twaugh) wrote :

Till, any idea how to fix this? Nothing I change in hplip seems to make the slightest bit of difference.

Till Kamppeter (till-kamppeter) wrote :

Tim, can you retry with HPLIP 3.9.8? Can you also make sure to select the correct one of the three flavors of the page size (normal, duplex, borederless)? With duplex of you get the standard mode by choosing a normal page size and the borderless mode by choosing a borderless page size. With duplex on you must use a duplex page size.

If it still does not work, print tyhje same jobs with the HPIJS driver of the same HPLIP version. Attach scans for comparing.

I've encountered the same problem on Gentoo[1] with an Officejet 5610.
Using the old hpijs (foomatic) PPD works fine, but the new hpcups PPD has broken margins. I will paste the important differences in the PPDs:

# hplip-3.9.4b-r1:
CustomMedia "A4/A4 210x297mm" 595.00 842.00 10.00 36.00 10.00 9.00
HWMargins 18.00 36.00 18.00 36.00

# hplip-3.9.8-r2:
CustomMedia "A4/A4 210x297mm" 595.44 841.68 18.00 36.00 18.00 9.00
HWMargins 9.00 36.00 9.00 36.00

# hplip-3.9.8-r2 *FIXED*:
CustomMedia "A4/A4 210x297mm" 595.44 841.68 9.00 36.00 9.00 36.00
HWMargins 9.00 36.00 9.00 36.00

The fixed one works fine. For more information see comment 7 at [1].

[1] http://bugs.gentoo.org/show_bug.cgi?id=288751

Till Kamppeter (till-kamppeter) wrote :

Closing the Ubuntu HPLIP package task as we provide a workaround now. The "hpijs" binary package migrates all hpcups-based print queues to hpijs when getting installed or updated. There is no fix for the hpcups regressions in the HPLIP package of Ubuntu.

tags: added: hpcups
Changed in hplip (Ubuntu):
status: Confirmed → Fix Released
Oldřich Jedlička (oldium-pro) wrote :

I've just encountered the margin problem with 3.9.10 (1cm off), version 3.9.8 worked fine on my Gentoo. Would it be possible to fix this in next release (it looks like an easy bug)? Thanks.

Oldřich Jedlička (oldium-pro) wrote :

Update: 3.9.12's test page has correct horizontal ruler (width matches), but the vertical one is still 1cm off. Does anybody know what is wrong with the automatically generated ppd file (attached) now? It looks like it has everything mentioned above (see the *FIXED* version), only the Imageable area is different (but I don't know the units and usage...).

*PageSize A4/A4 210x297mm: "<</PageSize[595.44 841.68]/ImagingBBox null>>setpagedevice"
*PageRegion A4/A4 210x297mm: "<</cupsInteger0 26/PageSize[595.44 841.68]/ImagingBBox null>>setpagedevice"
*ImageableArea A4/A4 210x297mm: "9.720000267029 36 585.720002174377 832.679992675781"
*PaperDimension A4/A4 210x297mm: "595.440002441406 841.679992675781"

I've made only one modification to use also the black cartridge for printing, but this should not do anything.

Oldřich Jedlička (oldium-pro) wrote :

Any hplip developper here? I'm nervous about no reaction. It is not possible to use the printer reasonably with the margins problem, so I'm wondering what to do. Thanks.

Jonathan (jeisom) wrote :
Download full text (8.3 KiB)

I have a HP OfficeJet J4580. 3.9.8 appears to cut off a half cm at the top and bottom and 3.9.12 cuts 1cm at the top.
I'm on gentoo amd64. output of hp-check:

HP Linux Imaging and Printing System (ver. 3.9.8)
Dependency/Version Check Utility ver. 14.3

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball
(.tar.gz or .run) to determine if the proper dependencies are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm,
etc) or an already built HPLIP supplied tarball has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above
cases (both compile- and run-time dependencies).

Saving output in log file: hp-check.log

Initializing. Please wait...

---------------
| SYSTEM INFO |
---------------

Basic system information:
Linux ravage 2.6.31.5 #2 SMP Sat Oct 24 14:03:29 CDT 2009 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 6000+ AuthenticAMD GNU/Linux

Distribution:
gentoo 0.0

Checking Python version...
OK, version 2.6.4 installed

Checking PyQt 4.x version...
OK, version 4.6.1 installed.

Checking for CUPS...
Status: scheduler is running
Version: 1.3.11
error_log is set to level: info

Checking for dbus/python-dbus...
dbus daemon is running.
python-dbus version: 0.83.0

------------------------------------
| COMPILE AND RUNTIME DEPENDENCIES |
------------------------------------

Checking for dependency: CUPS - Common Unix Printing System...
OK, found.

Checking for dependency: CUPS DDK - CUPS driver development kit...
OK, found.

Checking for dependency: CUPS devel- Common Unix Printing System development files...
OK, found.

Checking for dependency: CUPS image - CUPS image development files...
OK, found.

Checking for dependency: DBus - Message bus system...
OK, found.

Checking for dependency: gcc - GNU Project C and C++ Compiler...
OK, found.

Checking for dependency: GhostScript - PostScript and PDF language interpreter and previewer...
OK, found.

Checking for dependency: libcrypto - OpenSSL cryptographic library...
OK, found.

Checking for dependency: libjpeg - JPEG library...
OK, found.

Checking for dependency: libnetsnmp-devel - SNMP networking library development files...

Checking for dependency: libpthread - POSIX threads library...
OK, found.

Checking for dependency: libtool - Library building support services...
OK, found.

Checking for dependency: libusb - USB library...
OK, found.

Checking for dependency: make - GNU make utility to maintain groups of programs...
OK, found.

Checking for dependency: PIL - Python Imaging Library (required for commandline scanning with hp-scan)...
OK, found.

Checking for dependency: PolicyKit - Ad...

Read more...

It looks like hplip-3.10.2 has correct margins - at least on my HP DeskJet 3650. For me this is fixed. Can anyone confirm?

I cannot confirm this. I have an HP Deskjet 2600 and I print from a vmware embedded Windows system. I've been trying to create some CD labels with glabels and the margins were off about 1/4'' lower than the same pdf printed in the Windows system. This entire printing thing (margins and colors) is terrible.

The wrong PDF print margins could be a different problem (caused by the software that tries to print the PDF). I would recommend to use "Print Test Page" from the HP Device Manager. In this way you can tell how much HPLIP is wrong without any other software involved - the test page has horizontal and vertical rulers with millimeters/inches that start counting from the bottom-left paper margin.

Sorry for the complaint. In lucid, I used evince to print the glabels generated PDF. In Windows, I used Adobe acrobat reader. I did print a test page to be sure. I also printed another test page from an Ubuntu 9.10 system and the test pages are identical. The bottom lines are cut off from the pages. I'm pretty sure this should not be happening. I'm also sure that the lucid system is using the 3.10.2 drivers.

That's ok. If you have the test pages from HP Device Manager printed wrong, then I think you can be sure that there is something wrong in the HPLIP package and not in the PDF printing software. Whenever I discover something wrong, I try to eliminate any other possible problem sources - in this case the HP Device Manager's test page verified what I saw from the other printing. Now it is fixed for my HP DeskJet 3650.

Now it's HPLIP developers turn. I don't know how they work, because I didn't see any message from them for a long time; but they fix something from time to time :-)

Mark Purcell (msp) on 2010-08-01
Changed in hplip (Ubuntu):
status: Fix Released → Confirmed
Changed in hplip (Debian):
status: Unknown → Confirmed

This is rumored to be fixed in gentoo (http://bugs.gentoo.org/show_bug.cgi?id=288751) using hplip-3.9.12-r1 and ghostscript-gpl-8.71.

However, in Debian Squeeze I use hplip 3.10.6-1 and 8.71~dfsg2-6, and it is still broken. I tried deleting the printer and restarting cups, but it is still broken. Simple test page at http://www.scriptdolphin.com/test-portrait.pdf . I have a D2660 using hp-deskjet_d2600_series.ppd.

https://bugs.launchpad.net/debian/+source/hplip/+bug/334900 is marked duplicate of this bug. It is assigned to Aaron Albright, but he reports via Facebook:

> Aaron Albright September 16 at 9:39am Report
> Hey Mark!
>
> I am no longer on the HPLIP team, sadly. HP moved the project to another team overseas.
>
> The best place to get help is from:
>
> https://answers.launchpad.net/hplip
>
> They should be able to follow up with you on the issue. Sorry about that!
>
> Aaron

Any chance one of you new overseas developers wants to take this bug and fix it?

Mark

It looks it works for me on Gentoo, using hplip-3.10.6 on HP DeskJet 3650. But as I understand it each printer could have it's own margin problems...

Mark, the new developers continue to follow bugs here. So I hope that they will fix this problem soon.

Oldřich, for me it also looks like that only some printers are affected. Otherwise we had many more bug reports about this problem.

The problem is really restricted to only a few models. The following printers are reported to have problems here or in the Debian bug:

- DeskJet D2600
- DeskJet 5550

These printers work (I have tested them with A4 paper, normal, duplex, and borderless or they are reported to work in this bug report):

- PSC 1200
- OfficeJet H470
- PhotoSmart C8100
- PhotoSmart C5200
- PhotoSmart Premium C309g-m
- DeskJet 3650

If you have problems with the margins of your printout, can you try the following:

Edit the PPD file for your print queue, /etc/cups/ppd/<queue name>.ppd. Look for a line beginning with "*HPMechOffset:" and modify the number in it, for example change

*HPMechOffset: "70"

to

*HPMechOffset: "50"

Then restart CUPS:

sudo service cups restart

or

sudo restart cups

and print again. Did the printout move on the paper? Did it move closer to the expected position? Repeat the steps with other numbers for "*HPMechOffset:",

If you succeed to correct the problem this way, tell us which printer you have and which value was best. Tell us also if you did not succedd and also for that case which printer you have.

I forgot to follow up, but I no longer have been experiencing margin problems with the HP Deskjet 2600 I have. I'll need to look at what version of the driver is being used, etc., but I'm away from my desktop for another 2 weeks. I'll check and report my configuration then.

I can confirm, that this issue appears with the Deskjet 5550.

JoergAtHPLIP, please follow my instructions in comment #21. Thanks.

Hello Till,

I tried this setting, I saw a small difference on the bottom which is always cut off. The higher the value of HPMechOffset, the smaller is the part cut off but even, if I set it to much higher values (I tried 1000) there is still a part cut off. It seems to work only in a limited range.

Best Regards,
Jörg

Matt Zimmerman (mdz) wrote :

I have a similar problem with an HP DeskJet 3050 J610 and hplip 3.10.9 backported to 10.04. I noticed that the media limits are different on the test pages (I printed one with hpijs and one with hpcups):

hpcups: 3 x 14 to 207 x 295 millimeters
hpijs: 3 x 13 to 206 x 294 millimeters

The hpcups page is cut off on the left margin. The hpijs page is cut off on the bottom margin. So, neither is quite correct in my case.

Is this due to the same issue or should I file a separate bug?

Thomas Hallgren (thomas-tada) wrote :

I'm using hplip/hpcups 3.11.1 with Cups 1.4.6, and ghostscript 8.71-16 on a HP Photosmart 7600 printer. I'm experiencing the same problem. The last 15mm or so are cut off when I'm printing on A4.

I've tried every possible tip that I've found when googling for a solution but so far, everything has been in vain.

Can someone at HP have a look into this? Models currently having problems seem to be: DeskJet 5550, DeskJet 3050 J610, and Photosmart 7600.

Srikanth (srikanth-lokare) wrote :

This problem still exists with HP DeskJet D2600 and hplip 3.11.1 on Ubuntu 10.10.

The hpcups page is cut off at the bottom of the page.

Matt Zimmerman (mdz) wrote :

Possibly related? https://bugzilla.redhat.com/show_bug.cgi?id=518756

(that bug references this one)

Matt, thanks for the link. This seems to be the solution. I will apply it to Natty's HPLIP.

To the HPLIP developers at HP: Please apply the fix of https://bugzilla.redhat.com/show_bug.cgi?id=518756 to the upstream HPLIP package. Thanks.

Changed in hplip (Ubuntu):
status: Confirmed → Triaged
Changed in hplip (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.11.1-2ubuntu1

---------------
hplip (3.11.1-2ubuntu1) natty; urgency=low

  * debian/rules: Modified PPD generator for hpcups so that the PostScript
    code for the "PageSize" option also sets the PCL paper size
    ("/cupsInteger0 XX") and not only PageRegion (Closes: #518227,
    LP: #405116, Red Hat bug #518756).
  * debian/control, debian/rules, debian/local/pyppd: Use external pyppd
    package for the compression of the PostScript PPDs.
 -- Till Kamppeter <email address hidden> Thu, 10 Mar 2010 12:41:18 +0100

Changed in hplip (Ubuntu):
status: In Progress → Fix Released

I have a fix ready now, but I have to wait for bug #732638 to get fixed so that I can upload it.

Or if you want to try already, run the following command lines:

perl -e 'my $content = join("", <>); while($content =~ s:^(\s*CustomMedia.*?<<)(/PageSize.*?>>.*?\n?.*?<<)(\/cupsInteger0\s+\d+)(.*>>.*)$:\1\3\2\3\4:smgi) {}; print $content' /usr/share/cups/drv/hpcups.drv > hpcups.drv.new
sudo mv -f hpcups.drv.new /usr/share/cups/drv/hpcups.drv

Then remove and recreate your print queue.

For the HPLIP upstream developers at HP: The Perl magic above adds the "/cupsInteger0 <PCL page size number>" also to the PostScript commands of the PageSize option of the hpcups driver (not only PageRegion). Please apply this change also to the upstream source code. Thanks.

Though I got errors on my upload attempts the package made it to the server. So you will also get the fix applied fully automatically if you update as usual in some hours.

On Thu, Mar 10, 2011 at 08:06:35PM -0000, Till Kamppeter wrote:
> Though I got errors on my upload attempts the package made it to the
> server. So you will also get the fix applied fully automatically if you
> update as usual in some hours.

Thanks, Till!

--
 - mdz

Adding CUPS task as the pdftopdf filter does not respect the RequiresPageRegion attribute in the PPDs. The next CUPS package in Natty will add upstream fixes for the PDF filters including this one.

Changed in cups (Ubuntu):
milestone: none → ubuntu-11.04-beta-1
status: New → In Progress
Changed in cups (Ubuntu):
status: In Progress → Fix Committed
Changed in cups (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 1.4.6-3

---------------
cups (1.4.6-3) unstable; urgency=low

  [ Till Kamppeter ]
  * debian/local/filters/pdf-filters/filter/pdftoraster.cxx: Latest bug fixes
    from upstream:
     o Respect the "*RequiresPageRegion" attribute of the PPD files in the
       same way as pstops does (LP: #405116).
     o Change default rendering intent to PERCEPTUAL.
     o Use external ICC color profile also with CMYK color space.
  * debian/local/filters/pdf-filters/pdftopdf/pdftopdf.cxx: Latest bug fixes
    from upstream:
     o Support ipp-attribute-fidelity option and MirrorPrint choice. This is
       needed that appropriate options in printing dialogs and printer setup
       tools are respected.

  [ Martin Pitt ]
  * debian/control: Downgrade smbclient to Recommends. (Closes: #618545)
 -- Martin Pitt <email address hidden> Thu, 17 Mar 2011 10:49:04 +0100

Changed in cups (Ubuntu):
status: Fix Committed → Fix Released

Fixed upstream in HPLIP 3.11.5.

Changed in hplip:
status: Confirmed → Fix Released
Changed in hplip (Debian):
status: Confirmed → Fix Released
Roger (rogerx-oss) wrote :

HP M1522NF using hplip's hp-laserjet_m1522nf_mfp-pcl3.ppd file.

I get unusually high top and bottom margins when printing from abiword, but printing the test page with wupcs seems fine.

net-print/cups-1.4.8-r1
app-office/abiword-2.8.6-r1
app-text/ghostscript-gpl-8.7.1-r6
net-print/hplip-3.11.7

Roger, note that I have done a lot of fixes and improvements on the Ubuntu package of which did not (yet) get adopted by HPLIP upstream. So these fixes are most probably not in the Gentoo package of HPLIP. Please report bugs in the bug tracking system of Gentoo and ask them to adopt these fixes for the Gentoo package.

Roger (rogerx-oss) wrote :
Download full text (5.4 KiB)

> On Fri, Sep 23, 2011 at 06:31:25PM -0000, Till Kamppeter wrote:
>Roger, note that I have done a lot of fixes and improvements on the
>Ubuntu package of which did not (yet) get adopted by HPLIP upstream. So
>these fixes are most probably not in the Gentoo package of HPLIP. Please
>report bugs in the bug tracking system of Gentoo and ask them to adopt
>these fixes for the Gentoo package.

I spent the whole day trying to get the Ubuntu Live CD
(oneiric-desktop-i386.iso 696M Sep 21 16:04) configured and setup properly to
print to file, along with printing to printer. All tests showed this issue was
only hacked around (or more politely, worked-around). Of all the prints I did
using the hplip/gs HP-M1522NF postscript driver, I could only get postscript 2
files even after making sure postscript level 3 was set within the PPD files.
This is completely WRONG! When an admin sets-up a printer to print PS Level 3,
they should get PS Level 3 files and not PS Level 2 files.

The very least that could be done, run the *.ppd files through sed or gawk to
install a comment, "# Even though PS Level 3 is stated here, PS Level 2 will be
used (per bug# ...)."

And using the PCL HP-M1522NF still shows high page margins when printing
(hence, top/bottom of the page might be cut-off). I even tried to modify this
PCL ppd file per the related hplip bug, without success here.

On a side note, I hope you enjoy constructive criticism. ;-)

1) The desktop ran amazingly slow for my 2x750Hz P3's w/ 1GB RAM. I'm using
kernel 2.6.39 and 3.0 using nouveau and mesa-7.11 with gallium and I get really
good desktop performance. I can't recall your kernel in this, but performance
nouveau was looking good at kernel version 2.6.39 here, then I enabled gallium
(3d excell) and can now almost play HD videos here.

2) As with Linus, I do not like the new GNOME or KDE at all. Gnome2 was pretty
good, now I can't do anything. It's only focus is eye candy on fast cpu's and
lots of memory. Productivity means able to scale on older h/w and get things
done, if needed, put a picture of a flower on the wallpaper. And, there's so
much MS Windows influence, I can't get anything done.

3) Because of the above, I had lots of problems navigating the desktop, and as
usual, opened a terminal but still had problems as Bash didn't recognize
tab-completion on the first tab (can't remember if this was default or not).
And then, I had to keep clicking in each tabbed terminal to regain focus.

4) Top menu bars of windows ended up at the top of the desktop, while the
windows were placed elsewhere. Resizing windows was difficult because the
mouse had too small of a movement for resizing the window.

5) Installing the printer was completely non-intuitive. I remember to use CUPS
local server, but most distro's have their own configuration GUI for
configuring everything (ie. Mandrake/Mandriva). I would at least put a link
along with an initial libnotify event stating "To configure your printer, click
me..." and then open Mozilla to the CUPS local server page. However, one first
needs to configure their local network.

6) Configuring local network card, again non-intuitive. A user somehow must
know ...

Read more...

Roger (rogerx-oss) wrote :

No where, within the email forwarded from this list sent by Till Kamppeter containing his comment #40, did I see a CC to this list within the forwarded email.

The only address I sent an email to was using Till Kamppeter's address.

How the above reply ended-up here and beyond me, and is mostly OFF-TOPIC!

If somebody can, please delete the above comment #41 supposedly sent by me.

Roger (rogerx-oss) wrote :

Looks like the offending email header is "In-Reply-To:" containing non-common user name and a domain other then launchpad.net, which then sends/loops the email back into here.

Roger, can you open a new bug via the "Report Bug" link on

http://launchpad.net/hplip/

for your margin issue? It is most probably not the same as the one described here. The bug report will get directly to the HPLIP developers at HP. They use this site as their official bug tracking system.

Roger, can you post the mail which you have sent to me (accidentally posted here as comment #41) on the Ubuntu-devel-discuss mailing list (<email address hidden>, https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel-discuss), so that the appropriate Ubuntu developers get note of your issues? Thanks.

Sanjay Kumar (sanjay-kumar14) wrote :

Hi Roger,

Can you try following things and let us know if clipping still happens?

=>Remove all the print queues as follows:
 -Open terminal and the run "hp-toolbox" command
        - Press on (-) button and then select all entries and press Remove.
=>Add new print queue with PS ppd selection. You can do that as follows.
        - Open terminal and then run "hp-setup" command
        - Select 1st or 2nd option (USB or NW whichever applicable) in Step 1 of 3.
        - Then press "Next" in step 2 of 3.
        - In step 3 of 3, please change value of 4th edit box (PPD File:) to
            "/usr/share/ppd/HP/hp-laserjet_m1522nf_mfp-ps.ppd.gz" and then press Next.
        - Try to print now.

Thanks,
Sanjay

Roger (rogerx-oss) wrote :

I have no problems (that I can recall) using the PS (Postscript) based .ppd file.

The problem of broken margins is with the PCL based .ppd file.

Sanjay: I prefer command line over QT GUI. It's much easier.

Roger James (rogerjames99) wrote :

I can confirm that this bug is still present in 13.04. Using the add printer function from the desktop gui to find a network connected HP Photosmart 6510 and accepting all the defaults, results in a configuration which clips at the top and bottom margins. The simple fix is to go into the printer's properties in the desktop gui and change the "Make and Model:" to refer to "hpijs" rather than "hpcups". On my system the working "Make and Model" is "HP Photosmart 6510 Series hpijs, 3.13.3". When the gui asks you about the ppd tell it to use a new (default) one and the reapply any of your required changes (e.g. duplex printing).

Roger

Roger James (rogerjames99) wrote :

Some additional info. I ran some more tests using the hpijs driver and duplex printing on a Photosmart 6510, and there is still a 5mm clip of the top margin on when duplex printing a test pdf file using evince. This occurs irrespective of whether "Shrink to printable area" or "Fit to printable area" is set in the page handling options. I have attached the test file for info.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.