CP1515n with hplip-2.8.5 and PCL driver won't work

Bug #236618 reported by Andreas Eckstein
6
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned

Bug Description

Distribution: Gentoo 2007.1
HPLIP version: 2.8.5

I set up the printer with the hplip tool, everything worked fine, device status can be viewed with HP Device Manager, no error messages. All that is sent to the printer (pdf files from acrobat, images from konqueror, docs from staroffice) results in a single page with the content
PCL XL error
    Subsystem: KERNEL
    Error: IllegalAttribute
    Operator: BeginPage
    Position: 2

LaserJet 3055 on the same system works perfectly btw. CP1515n with generic postscript driver seems to work partially for files not too big, will eventually file a seperate bug for that.

hp-check returns this:

hp-check[26389]: info: :
Initializing. Please wait...
scheduler is running

1.3.7

Linux solon 2.6.25-gentoo-r4 #1 SMP Sun May 25 01:14:57 CEST 2008 i686 Intel(R) Core(TM)2 Duo CPU E6550 @ 2.33GHz GenuineIntel GNU/Linux

warning: Invalid ppd_dir value: None
hp-check[26389]: info: :
hp-check[26389]: info: :---------------
hp-check[26389]: info: :| SYSTEM INFO |
hp-check[26389]: info: :---------------
hp-check[26389]: info: :
hp-check[26389]: info: :[01mBasic system information:[0m
hp-check[26389]: info: :Linux solon 2.6.25-gentoo-r4 #1 SMP Sun May 25 01:14:57 CEST 2008 i686 Intel(R) Core(TM)2 Duo CPU E6550 @ 2.33GHz GenuineIntel GNU/Linux
hp-check[26389]: info: :
hp-check[26389]: info: :[01mDistribution:[0m
hp-check[26389]: info: :gentoo 0.0
hp-check[26389]: info: :[01m
HPOJ running?[0m
hp-check[26389]: info: :No, HPOJ is not running (OK).
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking Python version...[0m
hp-check[26389]: info: :OK, version 2.4.4 installed
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking PyQt version...[0m
hp-check[26389]: info: :OK, version 3.17 installed.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking SIP version...[0m
hp-check[26389]: info: :OK, Version 4.7.3 installed
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for CUPS...[0m
hp-check[26389]: info: :Status: scheduler is running
hp-check[26389]: info: :Version: 1.3.7
warning: /etc/cups/cupsd.conf file not found or not accessible.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dbus/python-dbus...[0m
hp-check[26389]: info: :dbus daemon is running.
hp-check[26389]: info: :python-dbus version: 0.80.2
hp-check[26389]: info: :
hp-check[26389]: info: :
hp-check[26389]: info: :------------------------------------
hp-check[26389]: info: :| COMPILE AND RUNTIME DEPENDENCIES |
hp-check[26389]: info: :------------------------------------
hp-check[26389]: info: :
note: To check for compile-time only dependencies, re-run hp-check with the -c parameter (ie, hp-check -c).
note: To check for run-time only dependencies, re-run hp-check with the -r parameter (ie, hp-check -r).
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: cups - Common Unix Printing System...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: cups-ddk - CUPS driver development kit...[0m
warning: NOT FOUND! This is an OPTIONAL/RUNTIME ONLY dependency. Some HPLIP functionality may not function properly.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: cups-devel- Common Unix Printing System development files...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: dbus - Message bus system...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: gcc - GNU Project C and C++ Compiler...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: GhostScript - PostScript and PDF language interpreter and previewer...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: libcrypto - OpenSSL cryptographic library...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: libjpeg - JPEG library...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: libnetsnmp-devel - SNMP networking library development files...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: libpthread - POSIX threads library...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: libtool - Library building support services...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: libusb - USB library...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: make - GNU make utility to maintain groups of programs...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: PIL - Python Imaging Library (required for commandline scanning with hp-scan)...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: ppdev - Parallel port support kernel module....[0m
error: NOT FOUND! This is a REQUIRED/RUNTIME ONLY dependency. Please make sure that this dependency is installed before installing or running HPLIP.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: PyQt - Qt interface for Python...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: python-ctypes - A foreign function library for Python...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: python-dbus - Python bindings for dbus...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: python-devel - Python development files...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: Python 2.3 or greater - Required for fax functionality...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: Python 2.2 or greater - Python programming language...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: Reportlab - PDF library for Python...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: SANE - Scanning library...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: SANE - Scanning library development files...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: scanimage - Shell scanning program...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for dependency: xsane - Graphical scanner frontend for SANE...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :
hp-check[26389]: info: :----------------------
hp-check[26389]: info: :| HPLIP INSTALLATION |
hp-check[26389]: info: :----------------------
hp-check[26389]: info: :
hp-check[26389]: info: :
hp-check[26389]: info: :[01mCurrently installed HPLIP version...[0m
hp-check[26389]: info: :HPLIP 2.8.5 currently installed in '/usr/share/hplip'.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mCurrent contents of '/etc/hp/hplip.conf' file:[0m
hp-check[26389]: info: :# hplip.conf. Generated from hplip.conf.in by configure.

[hpssd]
# Note: hpssd does not support dynamic ports
# Port 2207 is the IANA assigned port for hpssd
port=2207

[hplip]
version=2.8.5

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-2.8.5
icon=/usr/share/applications
cupsbackend=/usr/libexec/cups/backend
cupsfilter=/usr/libexec/cups/filter
drv=/usr/share/cups/drv/hp

# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=no
shadow-build=no
foomatic-drv-install=no
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
internal-tag=2.8.5.23

hp-check[26389]: info: :
hp-check[26389]: info: :--------------------------
hp-check[26389]: info: :| DISCOVERED USB DEVICES |
hp-check[26389]: info: :--------------------------
hp-check[26389]: info: :
hp-check[26389]: info: :No devices found.
hp-check[26389]: info: :
hp-check[26389]: info: :---------------------------------
hp-check[26389]: info: :| INSTALLED CUPS PRINTER QUEUES |
hp-check[26389]: info: :---------------------------------
hp-check[26389]: info: :
hp-check[26389]: info: :
hp-check[26389]: info: :[01mHPLJ3055[0m
hp-check[26389]: info: :[01m--------[0m
hp-check[26389]: info: :Type: Printer
hp-check[26389]: info: :Installed in HPLIP?: Yes, using the hp: CUPS backend.
hp-check[26389]: info: :Device URI: hp:/net/HP_LaserJet_3055?ip=192.168.2.88
hp-check[26389]: info: :PPD: /etc/cups/ppd/HPLJ3055.ppd
hp-check[26389]: info: :PPD Description: Generic PostScript Printer Foomatic/Postscript (recommended)
hp-check[26389]: info: :Printer status: printer HPLJ3055 is idle. enabled since So 01 Jun 2008 19:36:58 CEST
hp-check[26389]: info: :Communication status: Good
hp-check[26389]: info: :
hp-check[26389]: info: :[01mhpljcp1515n_pcl[0m
hp-check[26389]: info: :[01m---------------[0m
hp-check[26389]: info: :Type: Printer
hp-check[26389]: info: :Installed in HPLIP?: Yes, using the hp: CUPS backend.
hp-check[26389]: info: :Device URI: hp:/net/HP_Color_LaserJet_CP1515n?ip=192.168.2.115
hp-check[26389]: info: :PPD: /etc/cups/ppd/hpljcp1515n_pcl.ppd
hp-check[26389]: info: :PPD Description: HP Color LaserJet CP1515n Foomatic/hpijs, hpijs 2.8.5.23
hp-check[26389]: info: :Printer status: printer hpljcp1515n_pcl is idle. enabled since So 01 Jun 2008 23:12:27 CEST
hp-check[26389]: info: :Communication status: Good
hp-check[26389]: info: :
hp-check[26389]: info: :[01mhpljcp1515n_postscript[0m
hp-check[26389]: info: :[01m----------------------[0m
hp-check[26389]: info: :Type: Printer
hp-check[26389]: info: :Installed in HPLIP?: Yes, using the hp: CUPS backend.
hp-check[26389]: info: :Device URI: hp:/net/HP_Color_LaserJet_CP1515n?ip=192.168.2.115
hp-check[26389]: info: :PPD: /etc/cups/ppd/hpljcp1515n_postscript.ppd
hp-check[26389]: info: :PPD Description: Generic PostScript Printer Foomatic/Postscript (recommended)
hp-check[26389]: info: :Printer status: printer hpljcp1515n_postscript is idle. enabled since So 01 Jun 2008 23:02:20 CEST
hp-check[26389]: info: :Communication status: Good
hp-check[26389]: info: :
hp-check[26389]: info: :
hp-check[26389]: info: :----------------------
hp-check[26389]: info: :| SANE CONFIGURATION |
hp-check[26389]: info: :----------------------
hp-check[26389]: info: :
hp-check[26389]: info: :[01m'hpaio' in '/etc/sane.d/dll.conf'...[0m
hp-check[26389]: info: :OK, found. SANE backend 'hpaio' is properly set up.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking output of 'scanimage -L'...[0m
hp-check[26389]: info: :device `hpaio:/net/HP_LaserJet_3055?ip=192.168.2.88' is a Hewlett-Packard HP_LaserJet_3055 all-in-one

hp-check[26389]: info: :
hp-check[26389]: info: :---------------------
hp-check[26389]: info: :| PYTHON EXTENSIONS |
hp-check[26389]: info: :---------------------
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking 'cupsext' CUPS extension...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking 'pcardext' Photocard extension...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking 'hpmudext' I/O extension...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking 'scanext' SANE scanning extension...[0m
hp-check[26389]: info: :OK, found.
hp-check[26389]: info: :
hp-check[26389]: info: :
hp-check[26389]: info: :-----------------
hp-check[26389]: info: :| USB I/O SETUP |
hp-check[26389]: info: :-----------------
hp-check[26389]: info: :
hp-check[26389]: info: :
hp-check[26389]: info: :[01mChecking for permissions of USB attached printers...[0m
hp-check[26389]: info: :
hp-check[26389]: info: :-----------
hp-check[26389]: info: :| SUMMARY |
hp-check[26389]: info: :-----------
hp-check[26389]: info: :
error: 2 errors and/or warnings.
hp-check[26389]: info: :
hp-check[26389]: info: :Please refer to the installation instructions at:
hp-check[26389]: info: :http://hplip.sourceforge.net/install/index.html

hp-check[26389]: info: :
hp-check[26389]: info: :Done.

Revision history for this message
Stephan Peijnik (speijnik) wrote :

I can confirm this problem with hplip 2.8.5 on Ubuntu 8.04.

My CP1515n is connected via Ethernet. hp-setup detects the printer automatically, everything works fine until the last step in the configuration process:

If the 'Send test page to printer' checkbox is checked and one clicks on Finish an error message is shown saying that printing failed.

HP Device Manager shows a "Device communication error" with errorcode 5012.

When manually setting up the printer either using LPD or JetDirect connecting works, the print job is accepted by the printer, but printing itself generates a page with the same error message as reported (PCL XL error).

Using LDP or JetDirect using the generic PostScript driver that comes with CUPS printing is possible, but results in unreadable (scaling is horribly wrong) pages.

hp-check output is attached to this bug report.

Revision history for this message
Stephan Peijnik (speijnik) wrote :

As I've just tried it: Generic Postscript driver + JetDirect seems to be working properly now. The only thing that has changed since my last try is the printer firmware (now at 20080331).

Revision history for this message
Ron H (hilbolro) wrote :
Download full text (13.3 KiB)

Hello,

PCL XL error
    Subsystem: KERNEL
    Error: IllegalAttribute
    Operator: BeginPage
    Position: 2

This also seems to occur with Debian 4.0
Printer connected via Ethernet.

Installing hplip using sh hplip-2.8.5.run (downloaded from http://hplip.sourceforge.net/install/index.html)

Creating directory hplip-2.8.5
Verifying archive integrity... All good.
Uncompressing HPLIP 2.8.5 Self Extracting Archive...............
chown: changing ownership of `./.libs/hpmudext.soT': Operation not permitted
chown: changing ownership of `./.libs/libsane-hpaio.so.1.0.0T': Operation not permitted
chgrp: changing group of `./.libs/hpmudext.soT': Operation not permitted
chgrp: changing group of `./.libs/libsane-hpaio.so.1.0.0T': Operation not permitted

HP Linux Imaging and Printing System (ver. 2.8.5)
HPLIP Installer ver. 3.3

Copyright (c) 2001-8 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Installer log saved in: hplip-install_Thu-19-Jun-2008_22:02:09.log

|
note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.

INSTALLATION MODE
-----------------
Automatic mode will install the full HPLIP solution with the most common options.
Custom mode allows you to chose installation options to fit specific requirements.

Please choose the installation mode (a=automatic*, c=custom, q=quit) : c
c

Initializing. Please wait...

INSTALL TYPE
------------
For most users, it is recommended to install HPLIP with full support (scanning, faxing, toolbox, etc).
For servers or minimal installations, you can also install print support only (using HPIJS).

Install full support (recommended) or print-only support (m=multifunction*, s=single func, q=quit) ?m

INTRODUCTION
------------
This installer will install HPLIP version 2.8.5 on your computer.
Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).

VIEW RELEASE NOTES
------------------
Release notes from this version are available as a web (HTML) document.
The release notes file will be shown in a separate web browser window.

Would you like to view the release notes for this version of HPLIP (y=yes, n=no*, q=quit) ?

DISTRO/OS CONFIRMATION
----------------------
Distro appears to be Debian 4.0.

Is "Debian 4.0" your correct distro/OS and version (y=yes*, n=no, q=quit) ?

SELECT HPLIP OPTIONS
--------------------
You can select which HPLIP options to enable. Some options require extra dependencies.

Do you wish to enable 'Network/JetDirect I/O' (y=yes*, n=no, q=quit) ?
Do you wish to enable 'Graphical User Interfaces (GUIs)' (y=yes*, n=no, q=quit) ?
Do you wish to enable 'PC Send Fax support' (y=yes*, n=no, q=quit) ? n
Do you wish to enable 'Scanning support' (y=yes*, n=no, q=quit) ? n
Do you wish to enable 'Parallel I/O (LPT)' (y=yes*, n=no, q=quit) ? n
Do you wish to enable 'HPLIP documentation (HTML)' (y=yes*, n=no, q=quit) ?

ENTER ROOT/SUPERUSER PASSWORD
-----------------------------
Please enter the root/superuser password:
Password accepted

INSTALLATION NOTES
...

Revision history for this message
Aaron Albright (albrigha-deactivatedaccount) wrote :

Please retest with HPLIP 3.9.2 and post if you are still having a problem.

Thanks!

Aaron

Changed in hplip:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments