Cannot Install hplip-3.20.6.run on Linux Mint 20 python-qt4-dbus

Bug #1895438 reported by Raymond Clements on 2020-09-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned

Bug Description

Dear Sir/Madam,

I have a HP Laserjet Pro MFP M28w connected to a Linux Mint 20 and the script hplip-3.20.6.run runs to a point and then can install certain dependencies related to python.

I would like to have a better interface to my HP printer a sit has so many options.

I have moved from a Windows 10 environment where the support is really good.

It says it will install linuxmint-19.3 version packages. Then lower down I get the following:-

Would you like to retry installing the missing package(s) (y=yes*, n=no, q=quit) ? Running 'sudo apt-get install --assume-yes python-qt4-dbus'

Any help would be great!

If you need any other information then please let me know.

Blessings Raymond

Revision history for this message
shivani mandora (shivani1708) wrote :

Hi ,

Could you please try installing python3-dbus package manually and select 'no' for this python-qt4-dbus package.

Revision history for this message
shivani mandora (shivani1708) wrote :

We will provide Mint 20 support in our next release.

Changed in hplip:
status: New → In Progress
Revision history for this message
Judicaël Courant (judicael-courant-free) wrote :
Download full text (4.1 KiB)

Hi,

Similar problem on Debian 10.5 buster (see below). I do not understand how to apply shivani1708's suggestion (python3-dbus is already installed and many python or python3 qt5 packages are already installed).

Yours

MISSING DEPENDENCIES
--------------------
Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.
Package-Name Component Required/Optional
pyqt5-dbus gui_qt5 OPTIONAL
pyqt4-dbus gui_qt4 REQUIRED
pyqt5 gui_qt5 REQUIRED
Do you want to install these missing dependencies (y=yes*, n=no, q=quit) ?

INSTALL MISSING REQUIRED DEPENDENCIES
-------------------------------------
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)
warning: Missing REQUIRED dependency: pyqt5 (PyQt 5- Qt interface for Python (for Qt version 4.x))

INSTALL MISSING OPTIONAL DEPENDENCIES
-------------------------------------
note: Installation of dependencies requires an active internet connection.
warning: Missing OPTIONAL dependency for option 'gui_qt5': pyqt5-dbus (PyQt 5 DBus - DBus Support for PyQt5)

CHECKING FOR NETWORK CONNECTION
-------------------------------
Network connection present.

RUNNING PRE-PACKAGE COMMANDS
----------------------------
warning: An error occurred running 'su -c "dpkg --configure -a"'
su -c "dpkg --configure -a" (Pre-depend step 1)
su -c "apt-get install -f" (Pre-depend step 2)
su -c "apt-get update" (Pre-depend step 3)
OK

DEPENDENCY AND CONFLICT RESOLUTION
----------------------------------
Running 'su -c "apt-get install --force-yes -y python-qt4-dbus"'
Please wait, this may take several minutes...
Running 'su -c "apt-get install --force-yes -y gtk2-engines-pixbuf"'
Please wait, this may take several minutes...
Running 'su -c "apt-get install --force-yes -y python-pyqt5"'
Please wait, this may take several minutes...
Running 'su -c "apt-get install --force-yes -y python-dbus.mainloop.pyqt5"'
Please wait, this may take several minutes...
error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.

RUNNING POST-PACKAGE COMMANDS
-----------------------------
OK

RE-CHECKING DEPENDENCIES
------------------------
error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.
error: Installation cannot continue without these dependencies.
error: Please manually install this dependency and re-run this installer.

$ dpkg -l|grep python|grep qt5
ii python-dbus.mainloop.pyqt5 5.11.3+dfsg-1+b3 amd64 D-Bus Qt main loop support for Python 2
ii python-pyqt5 5.11.3+dfsg-1+b3 amd64 ...

Read more...

Revision history for this message
Raymond Clements (raymondthebrave) wrote : RE: [Bug 1895438] Re: Cannot Install hplip-3.20.6.run on Linux Mint 20 python-qt4-dbus
Download full text (5.7 KiB)

I got the same problem and the guys who look after hplip say they do not currently support Linux Mint 20. We have to wait for the next release. No date set but I would expect it soon. I then tried gscan2pdf and that has problems with trying to scan from my HP LaserJet Pro MFP M28w.

I currently have to use Windows 10 for this now.

Raymond Clements (<email address hidden>)

-----Original Message-----
From: <email address hidden> <email address hidden> On Behalf Of Judicaël Courant
Sent: 20 September 2020 17:14
To: <email address hidden>
Subject: [Bug 1895438] Re: Cannot Install hplip-3.20.6.run on Linux Mint 20 python-qt4-dbus

Hi,

Similar problem on Debian 10.5 buster (see below). I do not understand how to apply shivani1708's suggestion (python3-dbus is already installed and many python or python3 qt5 packages are already installed).

Yours

MISSING DEPENDENCIES
--------------------
Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.
Package-Name Component Required/Optional
pyqt5-dbus gui_qt5 OPTIONAL
pyqt4-dbus gui_qt4 REQUIRED
pyqt5 gui_qt5 REQUIRED
Do you want to install these missing dependencies (y=yes*, n=no, q=quit) ?

INSTALL MISSING REQUIRED DEPENDENCIES
-------------------------------------
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)
warning: Missing REQUIRED dependency: pyqt5 (PyQt 5- Qt interface for Python (for Qt version 4.x))

INSTALL MISSING OPTIONAL DEPENDENCIES
-------------------------------------
note: Installation of dependencies requires an active internet connection.
warning: Missing OPTIONAL dependency for option 'gui_qt5': pyqt5-dbus (PyQt 5 DBus - DBus Support for PyQt5)

CHECKING FOR NETWORK CONNECTION
-------------------------------
Network connection present.

RUNNING PRE-PACKAGE COMMANDS
----------------------------
warning: An error occurred running 'su -c "dpkg --configure -a"'
su -c "dpkg --configure -a" (Pre-depend step 1) su -c "apt-get install -f" (Pre-depend step 2) su -c "apt-get update" (Pre-depend step 3) OK

DEPENDENCY AND CONFLICT RESOLUTION
----------------------------------
Running 'su -c "apt-get install --force-yes -y python-qt4-dbus"'
Please wait, this may take several minutes...
Running 'su -c "apt-get install --force-yes -y gtk2-engines-pixbuf"'
Please wait, this may take several minutes...
Running 'su -c "apt-get install --force-yes -y python-pyqt5"'
Please wait, this may take several minutes...
Running 'su -c "apt-get install --force-yes -y python-dbus.mainloop.pyqt5"'
Please wait, this may take several minutes...
error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.

RUNNING POST-PACKAGE COMMANDS
-----------------------------
OK

RE-CHECKING DEPENDENCIES
----...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers