Cant' find my HP Laser MFP 137fnw through the network

Bug #1882390 reported by Facundo Batista on 2020-06-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned

Bug Description

While I can print just fine, and connect to the MFP through a browser, it's not detected as a "scanner".

I edited /etc/sane.d/dll.conf, added 'hpaio', and left only the hp* ones, and when running scanimage -L I get the attached report.

Facundo Batista (facundo) wrote :
Facundo Batista (facundo) wrote :

I tried hp-doctor, it wants to install a plugin, but it fails to accept my password (the same I use with sudo in other terminal and works). If I try to run `sudo python3 /usr/bin/hp-doctor`, it refuses because doesn't want to run as root.

Attached is the report of hp-check.

brian_p (claremont102) wrote :

Are you sure your device is an HP Laser MFP 137fnw? This is not
substantiated by hp-check.log.

Brian.

Facundo Batista (facundo) wrote :

I attached a photo that I just took of the printer at my right while I'm writing this.

Facundo Batista (facundo) wrote :

Note that the "printing system" recognized it ok. I attached a screenshot of its configuration.

brian_p (claremont102) wrote :

> hp:/usb/HP_LaserJet_P1005?serial=L405W94

Nice photos. :) Just checking because what is above is what is
in your hp-check.log. No sign of a MFP 137fnw. I have a good
idea why it isn't there, but, first, would you give what you
get from 'sudo grep PCFileName /etc/cups/ppd/YOUR_137fnw_PPD.

brian_p (claremont102) wrote :

Forgot. Would you also grep for "Nickname"?

Facundo Batista (facundo) wrote :

Note about "nickname" upper/lower spelling, but I think we're fine:

$ sudo grep "PCFileName\|NickName" /etc/cups/ppd/HP040E3C60A8A2_HP_Laser_MFP_131_133_135_138_.ppd
*PCFileName: "ippeve.ppd"
*NickName: "Laser MFP 137fnw"
*ShortNickName: "Laser MFP 137fnw"

brian_p (claremont102) wrote :

> *PCFileName: "ippeve.ppd"

It appear you are using driverless printing. That's good.
No HP drivers are required.

However, you have proceeded on the basis of the device using
HP printer and scanner languages. This is not the case; the
137fnw uses SPL, Samsung Printer Language. Basically, it is
not supported by HPLIP.

Details are in a post that is towards the end of

 http://forums.debian.net/viewtopic.php?f=5&t=146263&sid=b57e559da3f10bf134ac9e772d5d77e2

Should you take the sane-airscan route, I would appreciate the
information asked for in that post.

Facundo Batista (facundo) wrote :

Yes, I installed sane-airscan and now it works just great.

Thank you very much!!

I attached the requested info. Feel free to close this issue if it corresponds.

Thanks again.

brian_p (claremont102) wrote :

> Yes, I installed sane-airscan and now it works just great.

Very pleased, Facundo. You owe Alexander Pevzner a bottle of wine. :)
I suggest you use his PPA if you want to keep up-to-date with changes
to the package. With driverless printing and scanning you are now at
the cutting edge of technology!

Thanks for the info.

Regards,

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers