libsane-hpaio_3.20.5 undefined symbol error prevent scanning working in Debian sid

Bug #1880065 reported by A. GUEYE on 2020-05-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned

Bug Description

Latest package version in Debian sid: libsane-hpaio_3.20.5+dfsg0-2_amd64.deb
prevent scanning from working.

- Scanner frontends (simple-scan, xsane,...) and scanimage -L can not detect device usb device
hpaio:/usb/Deskjet_1050_J410_series?serial=CN12A3J12S05HW

while device
hp:/usb/Deskjet_1050_J410_series?serial=CN12A3J12S05HW
is ok
- Only Printing is working:

Downgrading to previous package libsane-hpaio_3.20.3+dfsg0-1_amd64.deb in Debian sid make Scanning work again

errors log:

user3@Deskstation:~$ export SANE_DEBUG_DLL=128
user3@Deskstation:~$ scanimage -L
[sanei_debug] Setting debug level of dll to 128.
[dll] sane_init: SANE dll backend version 1.0.13 from sane-backends 1.0.27
[dll] sane_init/read_dlld: attempting to open directory `./dll.d'
[dll] sane_init/read_dlld: attempting to open directory `/etc/sane.d/dll.d'
[dll] sane_init/read_dlld: using config directory `/etc/sane.d/dll.d'
[dll] sane_init/read_dlld: considering /etc/sane.d/dll.d/libsane-extras
[dll] sane_init/read_config: reading dll.d/libsane-extras
[dll] add_backend: adding backend `ls5000'
[dll] sane_init/read_dlld: done.
[dll] sane_init/read_config: reading dll.conf
[dll] add_backend: adding backend `net'
[dll] add_backend: adding backend `hp'
[dll] add_backend: adding backend `hpaio'
[dll] sane_get_devices
[dll] load: searching backend `hpaio' in `/usr/lib/x86_64-linux-gnu/sane:/usr/lib/sane'
[dll] load: trying to load `/usr/lib/x86_64-linux-gnu/sane/libsane-hpaio.so.1'
[dll] load: dlopen()ing `/usr/lib/x86_64-linux-gnu/sane/libsane-hpaio.so.1'
[dll] load: dlopen() failed (/usr/lib/x86_64-linux-gnu/sane/libsane-hpaio.so.1: undefined symbol: _DBG)
[dll] load: searching backend `hp' in `/usr/lib/x86_64-linux-gnu/sane:/usr/lib/sane'
[dll] load: trying to load `/usr/lib/x86_64-linux-gnu/sane/libsane-hp.so.1'
[dll] load: dlopen()ing `/usr/lib/x86_64-linux-gnu/sane/libsane-hp.so.1'
[dll] init: initializing backend `hp'
[dll] init: backend `hp' is version 1.0.8
[dll] load: searching backend `net' in `/usr/lib/x86_64-linux-gnu/sane:/usr/lib/sane'
[dll] load: trying to load `/usr/lib/x86_64-linux-gnu/sane/libsane-net.so.1'
[dll] load: dlopen()ing `/usr/lib/x86_64-linux-gnu/sane/libsane-net.so.1'
[dll] init: initializing backend `net'
[dll] init: backend `net' is version 1.0.27
[dll] load: searching backend `ls5000' in `/usr/lib/x86_64-linux-gnu/sane:/usr/lib/sane'
[dll] load: trying to load `/usr/lib/x86_64-linux-gnu/sane/libsane-ls5000.so.1'
[dll] load: couldn't open `/usr/lib/x86_64-linux-gnu/sane/libsane-ls5000.so.1' (No such file or directory)
[dll] load: trying to load `/usr/lib/sane/libsane-ls5000.so.1'
[dll] load: couldn't open `/usr/lib/sane/libsane-ls5000.so.1' (No such file or directory)
[dll] load: couldn't find backend `ls5000' (No such file or directory)
[dll] sane_get_devices: found 0 devices

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
[dll] sane_exit: exiting
[dll] sane_exit: calling backend `hp's exit function
[dll] sane_exit: calling backend `net's exit function
[dll] sane_exit: finished

Revision history for this message
Florian Hatat (mininet) wrote :

This seems strongly related to https://bugs.launchpad.net/hplip/+bug/1879445, since the proposed patch fixes this bug for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers