HPLIP reports "no systray found" error on Ubuntu 18.04

Bug #1821873 reported by Vectorio on 2019-03-27
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned

Bug Description

I made a fresh installation of Ubuntu 18.04 and installed HPLIP 3.19.1. Printing works fine, but I got an error saying that no systray found. In fact, no systray is visible, but this worked fine under Ubuntu 16.04. Also, other applications like mega and skype have no problem showing their systray.

I tried the methods suggested here: https://askubuntu.com/questions/101828/no-system-tray-detected-on-this-system

But none of them worked for me. Please let me know when you have an updated version that fixes this problem.

Vectorio (gprofos) wrote :
iGadget (igadget) wrote :

Same issue on Ubuntu 20.10.

iGadget (igadget) wrote :

'Solved' the problem by adding a startup delay of 10 secs. in /etc/xdg/autostart/hplip-systray.desktop, replacing the existing 'Exec=' line like so:

Exec=bash -c "sleep 10 && hp-systray -x"

Apparently, my problem is a bug in the Gnome version of Ubuntu 20.10.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers