No communication with Officejet J4660 via USB

Bug #1750584 reported by Tales Tomaz on 2018-02-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Shivani Mandora

Bug Description

I'm trying to run a HP Officejet J4660 All-in-One on my Ubuntu 16.04, but I get communication problems and it doesn't print or scan anything. In HPLIP the printer has the red X icon.

This printer worked fine on my brother's Ubuntu 14.04 and works fine on Windows. It works via USB, not Wifi. Tried already all the four USB ports. Result is the same. Other things work as usual in the same USB ports. Printer is powered on and attached. HPLIP is (apparently) successfully installed as well as HP-plugin.

When I run 'hp-check', this is what I get:

===
ttomaz@tales-inspiron:~$ hp-check
Saving output in log file: /home/ttomaz/hp-check.log

HP Linux Imaging and Printing System (ver. 3.17.11)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode
will check both of the above cases (both compile- and run-time dependencies).

Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]
PYEXT SCANCONF QUEUES PERMISSION

Status Types:
    OK
    MISSING - Missing Dependency or Permission or Plug-in
    INCOMPAT - Incompatible dependency-version or Plugin-version

---------------
| SYSTEM INFO |
---------------

 Kernel: 4.4.0-112-generic #135-Ubuntu SMP Fri Jan 19 11:48:36 UTC 2018 GNU/Linux
 Host: tales-inspiron
 Proc: 4.4.0-112-generic #135-Ubuntu SMP Fri Jan 19 11:48:36 UTC 2018 GNU/Linux
 Distribution: 12 16.04
 Bitness: 64 bit

-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.17.11
HPLIP-Home: /usr/share/hplip
HPLIP-Installation: Auto installation is supported for ubuntu distro 16.04 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.17.11

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.17.11
html=/usr/share/doc/hplip-3.17.11
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.17.11
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
qt5=no
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=yes
class-driver=no

Current contents of '/var/lib/hp/hplip.state' file:
[plugin]
installed = 1
eula = 1
version = 3.17.11

Current contents of '~/.hplip/hplip.conf' file:
[upgrade]
notify_upgrade = true
last_upgraded_time = 1518829966
pending_upgrade_time = 0
latest_available_version = 3.17.10

[installation]
date_time = 20/02/2018 11:44:26
version = 3.17.11

[settings]
systray_visible = 0
systray_messages = 0

[last_used]
device_uri = "hp:/usb/Officejet_J4660_series?serial=0"
printer_name =
working_dir = /home/ttomaz/Downloads/hplip-3.17.11/hplip-3.17.11-plugin.run

[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[refresh]
rate = 30
enable = false
type = 1

[polling]
enable = false
interval = 5
device_list =

[fax]
voice_phone =
email_address =

 <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

--------------
| COMPILEDEP |
--------------

 gcc gcc - GNU Project C and C++ Compiler REQUIRED - 5.4.0 OK -
 make make - GNU make utility to maintain groups of programs REQUIRED 3.0 4.1 OK -
 libtool libtool - Library building support services REQUIRED - 2.4.6 OK -

------------------------
| General Dependencies |
------------------------

 libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.0.2 OK -
 python-xml Python XML libraries REQUIRED - 2.1.0 OK -
 libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 5.7.3 OK -
 sane-devel SANE - Scanning library development files REQUIRED - 1.0.25 OK -
 pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 1.1.7 OK -
 pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 REQUIRED 4.0 4.11.4 OK -
 libpthread libpthread - POSIX threads library REQUIRED - 2.23 OK -
 python-devel Python devel - Python development files REQUIRED 2.2 2.7.12 OK -
 cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - 2.1.3 OK -
 python-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.0 OK -
 cups-ddk CUPS DDK - CUPS driver development kit OPTIONAL - - OK -
 reportlab Reportlab - PDF library for Python OPTIONAL 2.0 3.3.0 OK -
 pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 4.11.4 OK -
 libusb libusb - USB library REQUIRED - 1.0 OK -
 cups-image CUPS image - CUPS image development files REQUIRED - 2.1.3 OK -
 python2X Python 2.2 or greater - Python programming language REQUIRED 2.2 2.7.12 OK -
 python-notify Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - OK -
 libjpeg libjpeg - JPEG library REQUIRED - - OK -
 sane SANE - Scanning library REQUIRED - 1.0.25 OK -

----------------------
| Scan Configuration |
----------------------

 scanext Scan-SANE-Extension REQUIRED - 3.17.11 OK -
 hpaio HPLIP-SANE-Backend REQUIRED - 3.17.11 OK 'hpaio found in /etc/sane.d/dll.conf'

-------------------------
| External Dependencies |
-------------------------

 gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.18 OK -
 scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.25 OK -
 cups CUPS - Common Unix Printing System REQUIRED 1.1 2.1.3 OK 'CUPS Scheduler is running'
 network network -wget OPTIONAL - 1.17.1 OK -
 policykit PolicyKit - Administrative policy framework OPTIONAL - 0.105 OK -
 xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 0.999 OK -
 dbus DBus - Message bus system REQUIRED - 1.10.6 OK -
 avahi-utils avahi-utils OPTIONAL - 0.6.32 OK -

---------------------
| Python Extentions |
---------------------

 hpmudext IO-Extension REQUIRED - 3.17.11 OK -
 cupsext CUPS-Extension REQUIRED - 3.17.11 OK -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

Officejet_J4660
---------------
Type: Printer
Device URI: hp:/usb/Officejet_J4660_series?serial=0
PPD: /etc/cups/ppd/Officejet_J4660.ppd
PPD Description: HP Officejet j4660 Series, hpcups 3.17.11
Printer status: printer Officejet_J4660 is idle. enabled since Ter 20 Fev 2018 10:06:24 -03
error: Unable to communicate with device (code=12): hp:/usb/Officejet_J4660_series?serial=0
error: Device not found
error: Communication status: Failed

--------------
| PERMISSION |
--------------

-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
None

Missing Optional Dependencies
-----------------------------
None

Total Errors: 1
Total Warnings: 0

Done.
===

brian_p (claremont102) wrote :

Give the outputs of:

ls -l /dev/usb
lsusb | grep 03f0 (You want Bus and Device).
lsusb -D /dev/bus/usb/<Bus>/<Device> | grep iSerial (Done as root. Without < and >).

--
Brian.

Tales Tomaz (talestomaz) wrote :

[COMMAND #1]
ttomaz@tales-inspiron:~$ ls -l /dev/usb
total 0
crw------- 1 root root 180, 0 Fev 21 09:27 hiddev0
crw------- 1 root root 180, 1 Fev 21 09:27 hiddev1

[COMMAND #2] -- no output:
ttomaz@tales-inspiron:~$ lsusb | grep 03f0
ttomaz@tales-inspiron:~$

Don't know exactly what these commands do, but I think I should have an output in command #2 in order to get something meaningful for the command #3 (lsusb -D /dev/bus/usb/<Bus>/<Device> | grep iSerial), right?

(By the way, USB keeps working with other things - mouse via Wifi, pendrive - attached to the computer at the very moment I entered these commands).

brian_p (claremont102) wrote :

COMMAND #1 is intended to detect the device file which the aio set up when is plugged in. I'd expect lp0 but you have entries only for (probably) mouse and keyboard. This isn't good.

COMMAND #2 is intended to identify the aio and get its Bus and Device for using in COMMAND #3. You can use just 'lsusb' to see whether the aio is detected. 03f0 is the vendor code for HP.

At this stage it looks like the computer doesn't know about the machine.

--
Brian.

brian_p (claremont102) wrote :

Check the cable and the connections.

--
Brian.

Shivani Mandora (shivani1709) wrote :

Hi,

Can you check and confirm whether the service 'avahi-daemon' is running in your Ubuntu system or not? Can you try restarting this service (sudo restart avahi-daemon) and update if the issues get resolved or not?

Thanks,
Shivani Mandora

Changed in hplip:
assignee: nobody → Shivani Mandora (shivani1709)
status: New → In Progress
Tales Tomaz (talestomaz) wrote :

@brian_p: About cables and connection, I have tried already several cables that work fine with other equipment or OS.

@Shivani Mandora: Here it is:

[COMMAND "service avahi-daemon"]
ttomaz@tales-inspiron:~$ service avahi-daemon status
● avahi-daemon.service - Avahi mDNS/DNS-SD Stack
   Loaded: loaded (/lib/systemd/system/avahi-daemon.service; enabled; vendor pre
   Active: active (running) since Qui 2018-02-22 09:20:57 -03; 18min ago
 Main PID: 797 (avahi-daemon)
   Status: "avahi-daemon 0.6.32-rc starting up."
   CGroup: /system.slice/avahi-daemon.service
           ├─797 avahi-daemon: running [tales-inspiron.local
           └─817 avahi-daemon: chroot helpe

Fev 22 09:21:37 tales-inspiron avahi-daemon[797]: New relevant interface wlp2s0.
Fev 22 09:21:37 tales-inspiron avahi-daemon[797]: Registering new address record
Fev 22 09:21:39 tales-inspiron avahi-daemon[797]: Leaving mDNS multicast group o
Fev 22 09:21:39 tales-inspiron avahi-daemon[797]: Joining mDNS multicast group o
Fev 22 09:21:39 tales-inspiron avahi-daemon[797]: Registering new address record
Fev 22 09:21:39 tales-inspiron avahi-daemon[797]: Withdrawing address record for
Fev 22 09:21:39 tales-inspiron avahi-daemon[797]: Registering new address record
Fev 22 09:21:43 tales-inspiron avahi-daemon[797]: Joining mDNS multicast group o
Fev 22 09:21:43 tales-inspiron avahi-daemon[797]: New relevant interface wlp2s0.
Fev 22 09:21:43 tales-inspiron avahi-daemon[797]: Registering new address record
lines 1-19/19 (END)

[COMMAND "restart avahi-daemon"]
ttomaz@tales-inspiron:~$ sudo restart avahi-daemon
[sudo] senha para ttomaz:
restart: Não foi possível conectar ao Upstart: Failed to connect to socket /com/ubuntu/upstart: Conexão recusada

--translation---> Impossible to connect to Upstart: Failed ..... Connection refused.

Tried also these other commands:
ttomaz@tales-inspiron:~$ avahi-daemon -k
Failed to kill daemon: Operation not permitted
ttomaz@tales-inspiron:~$ avahi-daemon -r
Failed to kill daemon: Operation not permitted

==

Thanks for any help!

brian_p (claremont102) wrote :

 > @brian_p: About cables and connection, I have tried already
 > several cables that work fine with other equipment or OS.

A standard question. Always a long shot.

You didn't say whether the printer was in the output of 'lsusb'. Are other items like the pendrive shown?

--
Brian.

Tales Tomaz (talestomaz) wrote :

@brian_p: Tried again 'lsusb' and the result was the same:

ttomaz@tales-inspiron:~$ ls -l /dev/usb
total 0
crw------- 1 root root 180, 0 Fev 23 13:50 hiddev0
crw------- 1 root root 180, 1 Fev 23 13:50 hiddev1

At this moment, I have an external mouse and the pendrive attached to the laptop, besides the printer. Printer doesn't work ("Device communication error", red X on the icon in HP Device Manager). The other two devices are working.

brian_p (claremont102) wrote :

Please run the command 'lsusb' and post the output here.

Thanks,

Brian.

Tales Tomaz (talestomaz) wrote :

Maybe this can help:

ttomaz@tales-inspiron:~$ lsusb
Bus 001 Device 006: ID 064e:812e Suyin Corp.
Bus 001 Device 005: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 004: ID 04f3:0034 Elan Microelectronics Corp.
Bus 001 Device 007: ID 0cf3:0036 Atheros Communications, Inc.
Bus 001 Device 002: ID 8087:8000 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 002: ID 046d:c52f Logitech, Inc. Unifying Receiver
Bus 002 Device 003: ID 090c:1000 Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.) Flash Drive
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

brian_p (claremont102) wrote :

This was a double-check on what we knew from 'lsusb | grep 03f0'. No printer is detected. But lots of other USB devices are; so the lsusb utility is operating as it should.

The cable is ok so that leaves either something on the computer or the printer itself. Try removing the flash drive and plugging the printer into that port.

Do you have easy and quick access to another linux machine to test 'lsusb' with the printer plugged in?

Cheers,

Brian.

brian_p (claremont102) wrote :

The show stopper is in your hp-check:

  hp:/usb/Officejet_J4660_series?serial=0

It should be

  hp:/usb/officejet_j4660_series?serial=<something_which_isn't_zero>

You have an unhealthy 'lsusb' output; 'sudo lsusb -v' might not be any better. hp-setup looks for an HP printer to get the values of iProduct and iSerial. 'sudo lsusb -v' should show them.

A couple more things to be going on with: the outputs of '/usr/lib/cups/backend/hp' and the line from 'usr/sbin/lpinfo -v' beginning "direct usb://".

Cheers,

Brian.

brian_p (claremont102) wrote :

My last post on this issue. I do not want to respond solely to myself.

It is difficult to see why there is a HPLIP bug when the most basic of commands doesn't have any output and nothing is provided to debug the issue.

Cheers,

Brian.

Tales Tomaz (talestomaz) wrote :

@brian_p, I'll have to give up. I've just tried the whole day to make the printer work on my Windows. It was firstly recognized, but as soon as I began to install the drivers, it wasn't seen anymore by the system, exactly as it happened on Ubuntu. This must be a problem with the printer itself, maybe because of the transport when I brought it from my brother's house to mine (8 hours driving). Thanks for your help.

brian_p (claremont102) wrote :

Hello Tales,

You have obviously put some effort into this and I can understand your frustration. However, I am very reluctant to believe a 500+km drive would destroy a printer which was tested before the journey (it was, wasn't it?).

Nothing showing up in the lsusb command is the real problem. Beyond looking at BIOS settings and playing with them or updating your system I have no further suggestions. In the end, I can understand why you would see the printer as broken.

Cheers,

Brian.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers