Comment 14 for bug 1576800

Karlchen (karlchen) wrote :

Hi, folks.

Once more 24 hours later, I can report and confirm that printing and scanning works as expected on my networked device "HP Color LaserJet MFP M277dw"
+ on genuine Ubuntu 16.04.2 64-bit Unity
+ using the HPLIP 3.16.3 software which comes with Ubuntu 16.04

To be honest, the crucial step on how to make scanning work has been got from the German Ubuntuusers.de WIKI.
They mention that in a separate step the HP plugin has to be got and installed using "sudo /usr/bin/hp-plugin-ubuntu", instead of doing so from inside the HP Toolbox GUI (which will fail)
(cf. here: https://wiki.ubuntuusers.de/HPLIP/#Scannen)

OK. So here are the steps which I have followed:
+ inside Synaptic made sure that the following HPLIP 3.16.3 packages have been installed
  (actually added those that had not been pre-installed):
  hplip, hplip-data, hplip-doc, hplip-gui
+ inside Synaptic made sure that libsane-hpaio 3.16.3 had been pre-installed
+ Executed: "sudo /usr/bin/hp-plugin-ubuntu" in order to download and install the HP plugin
  Note: this will open an xterm window.
        At the end of the installation there were 2 lines saying "Done."
        The xterm window had to be closed manually.
+ Only now launched the "HPLIP Toolbox" from Dash.
  Completed the HP-Setup.
  (The step to download and install the HP-plugin did not appear, because HP-Setup
   detected the installed HP-plugin software)
+ Finally, in the HPLIP Toolbox sent a test page to the printer.
  Put the printed out test page into the ADF.
  Selected Scan in the HPLIP Toolobox.
  Simple Scan would open.
  Selected the ADF as my source and confirmed to scan.
  Worked as expected.

Summary:
-----------
The HPLIP software which is available in the Ubuntu repos for 16.04 can be used to setup an HP MFP printer/scanner like e.g. my "HP Color LaserJet MFP M277dw" and get it to print and scan.

The tricky detail is that the setup steps are a little bit different from what may be found on the HP webpage http://hplipopensource.com/hplip-web/install/manual/hp_setup.html
Namely hp-plugin-ubuntu should have been completed before launching hp-setup.

Conclusion:
-------------
As has been verified HPLIP 3.16.3 will recognize printer as well as scanner, provided the setup steps have been done correctly.
Hence the reported issue "scanner doesn't work after linux update to 16.04" must be considered a handling issue, rather than a software bug.
In this case there is no software bug.

Personally, I consider bug #1576800 solved. No bug involved. Handling problem.