Non-free code in ErnieFilter (license only grants rights for use with HP products)

Bug #1553628 reported by Julian Andres Klode
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Gaurav Sood
hplip (Debian)
Fix Released
Unknown
hplip (Fedora)
Fix Released
Undecided
hplip (Ubuntu)
Undecided
Unassigned

Bug Description

The headers of ErnieFilter.cpp and .h say:

// This software is licensed solely for use with HP products. Redistribution
// and use with HP products in source and binary forms, with or without
// modification, are permitted provided that the following conditions are met:

As such, the code is non-free because I cannot safely redistribute it. Could that be changed to a normal 3-clause BSD license like the other files?

Revision history for this message
Julian Andres Klode (juliank) wrote :

It later says:

"
This software contains technology licensed from third parties; use with
 non-HP products is at your own risk and may require a royalty."

So I believe that this is a bit confused license wise, as I have only been given the permission for HP products anyway.

Changed in hplip (Debian):
status: Unknown → Confirmed
Revision history for this message
Julian Andres Klode (juliank) wrote :

Further auditing found multiple directories mentioned neither in COPYING nor copyright (why two files?) which thus have no license attached to them.

Examples:

* ui4/
* common/
* fax/ (but that seems to have license headers)
* apparmor/
* the root directory of the source code

It would be great if that could be cleaned up as well. I can report that as a separate bug, if wanted. The easiest way is probably to add a catch all "Code is licensed under the GPL-2, unless mentioned otherwise." part.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hplip (Ubuntu):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.16.5+repack1-1

---------------
hplip (3.16.5+repack1-1) unstable; urgency=medium

  * Repack the 3.16.5 upstream release to remove
    prnt/hpcups/ErnieFilter.{cpp,h} source files as they are non-free
    (Closes: #816870) (LP: #1553628)
  * Add patch to disable ErnieFilter usage everywhere, to cope with the repack

 -- Didier Raboud <email address hidden> Sun, 10 Jul 2016 12:34:10 +0200

Changed in hplip (Ubuntu):
status: Confirmed → Fix Released
Changed in hplip (Debian):
status: Confirmed → Fix Released
Revision history for this message
In , mejiko (mejiko-redhat-bugs) wrote :

Hello.

hplip included questionable licensed code.

File List:

"prnt/hpcups/ErnieFilter.h"
"prnt/hpcups/ErnieFilter.cpp"

This license is "hardware specific" license.
It is non-free, incompatible GPL license.

This is code (software), not firmware.

This problem already reported. (Debian)

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=816870

I suggest that resolve license problem.

Thanks.

Revision history for this message
In , Zdenek (zdenek-redhat-bugs) wrote :

Created attachment 1188843
Patch

I removed files with proprietary license and disabled features using it (PCL3GUI2). Package was built in RAWHIDE.

Changed in hplip:
assignee: nobody → Gaurav Sood (gaurav-sood)
Changed in hplip (Fedora):
importance: Unknown → Undecided
status: Unknown → Fix Released
Revision history for this message
zdohnal (zdohnal) wrote :

As Julien wrote in comment#2, there are more files and directories in hplip source tarball, whose are mentioned neither in COPYING file nor copyright file and they have different licenses then mentioned in COPYING and copyright files.
Gaurav, is there any update on this matter? Would anyone in HP mind changing these licenses to e.g. GPL+?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.