hp-plugin -i (3.15.7) hangs on 'su'

Bug #1483820 reported by Jiri Popelka on 2015-08-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
Fedora
Invalid
Undecided

Bug Description

I've seen some reports [1] [2] that the new (requiring to be run as non-root user) hp-plugin in 3.15.7 hangs during the process when 'su' is invoked.

I (downstream hplip maintainer) am not able to reproduce it myself, so those original bug reports is all info I can provide at the moment.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1249282
[2] https://bugzilla.redhat.com/show_bug.cgi?id=1249414

Jiri Popelka (jpopelka) wrote :

There's also output of 'hp-plugin -i -g ' in https://bugzilla.redhat.com/show_bug.cgi?id=1252375#c6

See comment #10 in bug-report #1486731 (hplip-3.15.7-plugin.run doesn't return)

Sanjay Kumar (sanjay-kumar14) wrote :

Hello all,

Please take the files from https://bugs.launchpad.net/hplip/+bug/1510950 and merge/replace them into /usr/share/hplip/base directory and let me know if this fixes the problem.

Thanks,
 Sanjay

Changed in hplip:
status: New → Confirmed
status: Confirmed → Fix Committed
Sanjay Kumar (sanjay-kumar14) wrote :

Fixed in hplip-3.16.2

Changed in hplip:
status: Fix Committed → Fix Released
Changed in fedora:
importance: Unknown → Undecided
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.