After compiling plugin, get Filter Failed error when printing

Bug #1476920 reported by Richard Simpson on 2015-07-22
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned

Bug Description

Server platform: Raspbian armv6 "jessie"
Printer: HP laserjet pro mfp m127fn

Downloaded latest hplip-3.15.7 source file, and then followed the manual installation instructions provided for debian at
http://hplipopensource.com/hplip-web/install/manual/distros/debian.html

I then tried to print a test page from the cups web admin (using a browser on another machine), and got the message
Stopped "Filter Failed"
Nothing printed at the printer.

Related branches

goutam (goutamkk) wrote :

Hi Richard,

Sorry for our late response on this.
Thank you for attaching the log files. We are able to reproduce the issue and debug it.
We will fix this issue in our next release.

You can apply the attached patch on hplip-3.15.7/prnt/hpcups/CommonDefinations.h file to make it work with the current release.

How to apply patch and install ?
1. Copy the attached patch file CommonDefinations.patch file to the location hplip-3.15.7/prnt/hpcups/
2. Run command 'patch < CommonDefinations.patch
3. Run command 'make' and su -c"make install' / 'sudo make install' to install

Let us know if the issue is resolved with this patch.

Thanks,
Goutam

alea (olivier-garet-p) wrote :

I had the very same problem on Ubuntu Gnome 15.04.
The patch fixed the problem, thank you.
Note that it is necessary to shutdown and restart the printer if one attempted to print with the faulty driver, because this one makes the printer hang.

goutam (goutamkk) on 2015-09-07
Changed in hplip:
status: New → Fix Committed
Brett Ginsburg (zekeb) wrote :

Will this patch work with 3.14.x versions of hplip? I am running Raspbian (Wheezy v. 7.8) and the 3.15.X versions do not include the ppd file for the m127fn. 3.14.x versions will install and contain the ppd file, but I get the filter failed error message.

goutam (goutamkk) on 2016-01-06
Changed in hplip:
status: Fix Committed → Fix Released

Thanks, but I don't have debian, I have Ubuntu 14.04, but my HP Laserjet
1018 won't work looses driver.

JF

On Wed, Jan 6, 2016 at 1:33 AM, goutam <email address hidden> wrote:

> ** Changed in: hplip
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are subscribed to HPLIP.
> Matching subscriptions: joeinslw
> https://bugs.launchpad.net/bugs/1476920
>
> Title:
> After compiling plugin, get Filter Failed error when printing
>
> Status in HPLIP:
> Fix Released
>
> Bug description:
> Server platform: Raspbian armv6 "jessie"
> Printer: HP laserjet pro mfp m127fn
>
> Downloaded latest hplip-3.15.7 source file, and then followed the manual
> installation instructions provided for debian at
> http://hplipopensource.com/hplip-web/install/manual/distros/debian.html
>
> I then tried to print a test page from the cups web admin (using a
> browser on another machine), and got the message
> Stopped "Filter Failed"
> Nothing printed at the printer.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hplip/+bug/1476920/+subscriptions
>

Joseph Florio (joeinslw) wrote :

goutam,

I have Ubuntu 14.04 and now my Dell c1765 seems to have lost the driver
just like the HP did, and I get messages that my hard drive is full when I
have 2tb hard drive, and all that's in this HD are boot files just mb, and
not gb.
I don't have very much on this HD, I have 3 other 2tb HD's on this computer
that has video, music and pictures and have nothing to do with this HD, so
how can this hard drive be full?
Is this bug effecting the other printer since my HP Laserjet 1018 is now
working?
Please let me know if this is possible.

Thanks,
JF

On Wed, Jan 6, 2016 at 1:33 AM, goutam <email address hidden> wrote:

> ** Changed in: hplip
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are subscribed to HPLIP.
> Matching subscriptions: joeinslw
> https://bugs.launchpad.net/bugs/1476920
>
> Title:
> After compiling plugin, get Filter Failed error when printing
>
> Status in HPLIP:
> Fix Released
>
> Bug description:
> Server platform: Raspbian armv6 "jessie"
> Printer: HP laserjet pro mfp m127fn
>
> Downloaded latest hplip-3.15.7 source file, and then followed the manual
> installation instructions provided for debian at
> http://hplipopensource.com/hplip-web/install/manual/distros/debian.html
>
> I then tried to print a test page from the cups web admin (using a
> browser on another machine), and got the message
> Stopped "Filter Failed"
> Nothing printed at the printer.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hplip/+bug/1476920/+subscriptions
>

tapasoyel (tapasoyelgh) wrote :

TOLLFREE- 1-8OO-635*9659 Binance 2fa login issue support, Binance support number,, Binance helpline support number toll free number Binance login issues support

♨♨Binance ➩➩found online at Binance.com, is a popular currently sitting in the top 20 exchanges by volume. The exchange has particularly strong volume in pairs like NEO/BTC, GAS/BTC, ETH/BTC, and BNB/BTC. BNB is the exchange’s homegrown currency called Binance Coin cryptoforecast.com is an official support domain for Binance Customers you can

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers