HPLIP plugin fails to install in Ubuntu 15.04 and openSUSE Tumbleweed (20150425)

Bug #1449964 reported by calcatinge on 2015-04-29
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned

Bug Description

On Apr 28 17:45 calcatinge wrote (excerpt):
> HP Pro MFP M125nw
> I was not able to install the plugin of my printer
...
> It does not work under openSUSE Tumbleweed, nor Ubuntu 15.04.
> It only works under Ubuntu 14.04.2

> I have hplip 3.15.2 installed
...
> - in CLI, after running hp-plugin with root, it shows the following
> lines and opens the same blank window as in the case of GUI setup...
...
> X Error: BadAccess (attempt to access private resource denied) 10
...
> X Error: BadShmSeg (invalid shared segment parameter) 128
...
> X Error: BadDrawable (invalid Pixmap or Window parameter) 9

DmDr (cardioexp) wrote :

Printer P1102, error note is "... file doesnot match its checksum..." But there is not any file in desired directory.

JakeScully (jakescully) wrote :

1) RE-DOWNLOAD the correct version precompiled plugin from HP here:
http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/

2) Make the plugin executable e.g. chmod +x hplip-3.15.2-plugin.run

3) Run it as root e.g. sudo ./hplip-3.15.2-plugin.run

4) Follow the prompts. Should work.

Adam Williamson (awilliamson) wrote :

There's a simple workaround:

hp-plugin -i

We found this in Fedora a few weeks back and there's some discussion in a couple of RHBZ bugs:

https://bugzilla.redhat.com/show_bug.cgi?id=1185893#c6
https://bugzilla.redhat.com/show_bug.cgi?id=1196237

There's a good summary in https://bugzilla.redhat.com/show_bug.cgi?id=1185893#c6 - basically, this is fixed in qt5 but is not likely to be fixed in qt4, and the 'official' answer is 'graphical apps shouldn't run as root'. So the fix is either to port to qt5, or to split hp-plugin in some way such that the GUI does not need to run as root.

Adam Williamson (awilliamson) wrote :

Forgot to mention - the actual trigger for the bug, the reason we're seeing it in new distros, is that it happens when X isn't running as root. When X is running as root the problem is hidden because it can do the accesses in that case.

PrPom.cz (6n9o) wrote :

Tried chris2k solution. Didnt work.

******
root@hex-thinkpad:/home/prpom# ./hplip-3.15.6-plugin.run
Verifying archive integrity... All good.
Uncompressing HPLIP 3.15.6 Plugin Self Extracting Archive...........................................
Error importing HPLIP modules. Is HPLIP installed?
root@hex-thinkpad:/home/prpom#
******

Any suggestions? Thanks a lot...

goutam (goutamkk) wrote :

Hi,

This issue is now fixed in our latest hplip 3.15.7 version.
You can download the hplip-3.15.7.run (auto installer) package from http://hplipopensource.com/hplip-web/gethplip.html.
Install the package using command 'sh hplip-3.15.7.run'. To install the plugin run command 'hp-plugin' in terminal.
Please let us know if you are still facing this issue.

Regards,
Goutam

Changed in hplip:
status: New → Fix Released
Darren Conte (darren-conte) wrote :

Hi Goutam -

Tried Ubuntu 15.04 x64 (clean install) with downloaded hplip 3.15.7 with HP LaserJet Pro M127fn and still fails to print. The status of job shows 'stopped'. View Attributes from Queue shows cups-filter-failure. Downgraded to 3.15.4 and now status shows 'processing' but never prints. Below is what you can determine from Terminal when trying to print while running .

warning: Fail to read ppd=/etc/cups/ppd/HP127.ppd file
warning: Insufficient permission to access file /etc/cups/ppd/HP127.ppd
warning: Could not complete Queue(s) configuration check

Hope this helps
Darren

Darren Conte (darren-conte) wrote :

Goutam

Forgot to mention, with my notes on previous post showing 'Insufficient permission to access file /etc/cups/ppd/HP127.ppd'

Once I did a " chmod 777 /etc/cups/ppd/HP127.ppd " - printing works fine now with my older download of 3.15.4.

Paulo Sequeira (psequeirag) wrote :

For the record, the way I could work around this issue was as follows:

1) Download hplip-3.15.2-plugin.run and hplip-3.15.2-plugin.run.asc from http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/ as Chris2k suggests.
2) Kick off the Plug-in installer from the HP Device Manager.
3) Choose to install plug-in from a local file copy rather than downloading it from the server.
4) Proceed with installation as usual.

Guillermo Molleda (gmolleda) wrote :

A mi, con impresora HP Laserjet Color CP 1025nw, no me funcionó hplip-3.15.11 pero con hplip-3.15.2 sí lo hizo. Al descargar los ficheros hacerlo en un directorio distinto a ~/.hplip porque ahí los borra el instalador.
Luego directamente con el instalador hp-setup seguir los pasos usando el plugin descargado en tu ordenador y no desde el servidor web.

El inglés discrimina por nacionalidad y renta, mejor si usan el esperanto:

Al mi, kun la printilo HP Color LaserJet CP 1025nw ne funkciis hplip-3.15.11 sed la dosiero hplip-3.15.2 fariĝis. Kiam elŝutanta la dosierojn fari ĝin en malsama dosierujo de ~ / .hplip ĉar la instalilo forigos la dosierojn.
Poste kun la instalilo hp-setup, vi sekvas la paŝojn kaj uzas la elŝutitajn dosierojn.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.